Piwigo Bugtracker

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000375 [Piwigo] display major always 2006.05.09 09:27 2006.07.09 10:37
Reporter nikrou View Status public  
Assigned To rub
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 1.6.0RC3 Product Version 1.6.0RC1
  Target Version Product Build
Summary 0000375: html bug
Description Information when mode adviser is on are displayed out from the html tree.
Steps To Reproduce
Additional Information
Tags No tags attached.
browser any
Database engine and version
PHP version
Web server Apache 1.3.x
Attached Files

- Relationships
related to 0000445closedrub Missing <div id="theHeader">{PAGE_BANNER}</div> 
related to 0000337closedplg Pages warnings 

-  Notes
(0000936)
rub (developer)
2006.05.09 09:37

Problem, it's not only for adiver mode.
It's like for other informations (new upgrage, gallery locked, bad permission, etc...).
All this informations, must be send on good time after doctype.

I purpose to modify all this showed informations on one shot!

Are you ok?
(0000937)
nikrou (developer)
2006.05.09 10:01

> Are you ok?

yes. I understand now.
(0000938)
rub (developer)
2006.05.09 10:39

We can use same style for all kind all information. (Modify page header like [Subversion] r1299/1300 of nikrou, but global and test around new line [remove silver line]).

Be careful of test with die function.
For check this die, we can add new function (copy of redirect) witch call page header and page footer.

Be careful of information about new upgrade (must be always show even on error), I purpose to add die and not continue other actions.

If you are ok, we continue with specifications else we open topic on forum in order to define best solutions.
(0001106)
nikrou (developer)
2006.06.22 23:34

corrigé dans le tronc: [Subversion] r1380
reporté dans la branche 1.6: [Subversion] r1381
(0001108)
rub (developer)
2006.06.23 12:24

Associé à l'issue 337 pour l'utilisation d'un tableau warning.
(0001130)
rub (developer)
2006.06.26 07:28

The display are changed.
Before, mode adviser are displayed on middle, top with a grey band.
After, mode adviser are displayed on left with a green band.

For me, this informations must be showed before all the others informations.

Don't used class info on css but an other class.

For me, you are made the warning messages (issue 337).

Could you rename warning on header messsage? Create class header message? Keep warning? Create warning class?
(0001131)
nikrou (developer)
2006.06.26 10:14

> The display are changed.
> Before, mode adviser are displayed on middle, top with a grey band.
> After, mode adviser are displayed on left with a green band.

I know that display is changed but it's now just a matter of css.

> For me, this informations must be showed before all the others informations.

Do you mean before the banner ?

> Don't used class info on css but an other class.
> For me, you are made the warning messages (issue 337).

I wait for that issue to change the css class!
(0001132)
mathiasm (manager)
2006.06.26 10:43

So nikrou, can you add a class in default-layout.css, called something like "header_msg", and apply it to the adviser banner?
(0001133)
rub (developer)
2006.06.26 10:51
edited on: 2006.06.26 10:53

> Do you mean before the banner ?
Yes, I see that like a like a first banner (visible but discrete)

> I wait for that issue to change the css class!
Issue 337 will be resolved on 1.6.1 release.

What you do think about change "warning" to "header_information" (or banner_information, header_banner_information)?

> So nikrou, can you add a class in default-layout.css, called something like "header_msg", and apply it to the adviser banner?
I agree.
It's not only for adviser banner, it's for other kind of information too!

(0001143)
rub (developer)
2006.06.28 11:55

Nikrou, are you time to finish this issue?
Also, you can to assign this to me!
(0001149)
rub (developer)
2006.06.29 01:01

Done on [Subversion] r1414 [Subversion] r1415
(0001151)
nikrou (developer)
2006.06.29 09:12
edited on: 2006.06.29 09:15

line 214 too long (coding convention)

why do you use a table for header messages (around BANNER) ? It's better to use a list or at least paragraphe but not tables!

(0001154)
rub (developer)
2006.06.29 10:38

> line 214 too long (coding convention)
I will never succeeded to that correctly.

> why do you use a table for header messages ? It's better to use a list or
> at least paragraphe but not tables!
Because after there are no list.
And I don't success to do that with paragraph.
I will try again.

> You add id=header for title but by default the title already use that id
> so it is duplicated and the html is not correct.
I don't have add id=header! See my response on issue 0000445
(0001161)
rub (developer)
2006.06.30 00:19

Fixed on [Subversion] r1418 [Subversion] r1419

But, I am not happy for margin and padding.
I want less height banner but I want espace after each lines (First lines will not be directly on the top banner.

- Issue History
Date Modified Username Field Change
2006.05.09 09:27 nikrou New Issue
2006.05.09 09:27 nikrou Status new => assigned
2006.05.09 09:27 nikrou Assigned To => rub
2006.05.09 09:27 nikrou browser => any
2006.05.09 09:27 nikrou Web server => Apache 1.3.x
2006.05.09 09:37 rub Assigned To rub =>
2006.05.09 09:37 rub Note Added: 0000936
2006.05.09 10:01 nikrou Note Added: 0000937
2006.05.09 10:39 rub Note Added: 0000938
2006.06.19 23:19 nikrou Assigned To => nikrou
2006.06.22 23:34 nikrou Status assigned => resolved
2006.06.22 23:34 nikrou Fixed in Version => 1.6.0RC3
2006.06.22 23:34 nikrou Resolution open => fixed
2006.06.22 23:34 nikrou Note Added: 0001106
2006.06.23 12:21 rub Relationship added related to 0000337
2006.06.23 12:24 rub Status resolved => feedback
2006.06.23 12:24 rub Resolution fixed => reopened
2006.06.23 12:24 rub Note Added: 0001108
2006.06.26 07:28 rub Note Added: 0001130
2006.06.26 07:28 rub Status feedback => assigned
2006.06.26 10:14 nikrou Note Added: 0001131
2006.06.26 10:43 mathiasm Note Added: 0001132
2006.06.26 10:51 rub Note Added: 0001133
2006.06.26 10:53 rub Note Edited: 0001133
2006.06.28 11:55 rub Note Added: 0001143
2006.06.28 12:12 nikrou Assigned To nikrou =>
2006.06.28 12:13 nikrou Status assigned => feedback
2006.06.28 14:26 rub Status feedback => assigned
2006.06.28 14:26 rub Assigned To => rub
2006.06.29 01:01 rub Status assigned => resolved
2006.06.29 01:01 rub Resolution reopened => fixed
2006.06.29 01:01 rub Note Added: 0001149
2006.06.29 09:12 nikrou Status resolved => feedback
2006.06.29 09:12 nikrou Resolution fixed => reopened
2006.06.29 09:12 nikrou Note Added: 0001151
2006.06.29 09:13 nikrou Note Edited: 0001151
2006.06.29 09:15 nikrou Note Edited: 0001151
2006.06.29 10:38 rub Relationship added related to 0000445
2006.06.29 10:38 rub Note Added: 0001154
2006.06.30 00:19 rub Status feedback => resolved
2006.06.30 00:19 rub Resolution reopened => fixed
2006.06.30 00:19 rub Note Added: 0001161
2006.07.09 10:37 rub Status resolved => closed


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Contact
Powered by Mantis Bugtracker