Piwigo Bugtracker

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000388 [Piwigo] template minor always 2006.05.28 10:17 2009.08.11 00:58
Reporter pfrize View Status public  
Assigned To rvelices
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 1.6.0RC3 Product Version 1.6.0RC2
  Target Version Product Build
Summary 0000388: html errors in month_calendar.tpl
Description Line 4 : a style tag out of the head section does not validate in strict html.

Line 26 or after : not sure why, but the code generates an empty tr tag right after the table heading, which does not validate either.
Steps To Reproduce
Additional Information
Tags No tags attached.
browser any
Database engine and version
PHP version
Web server Apache 1.3.x
Attached Files

- Relationships

-  Notes
(0001012)
chrisaga (developer)
2006.06.03 18:23

Right we cannot use a style tag in html body !
Why not setting these height and width in template-common/default-layout.css ?
It's precisely it's job !
(0001027)
rvelices (developer)
2006.06.07 19:33

I wont be able to touch it for another week or so..., but the reason why it is not in default-layout is that it is already in the config file. We would need to change it in 2 places in order to work.

If you agree, I could completely inline the style block to every element -> more html output, but correct and parameters are to change only once in the config file.
(0001029)
chrisaga (developer)
2006.06.07 20:55

Why is it already in the config file ?
(0001035)
rvelices (developer)
2006.06.08 17:44

They are used in php to generate inline css style for images (relative top, left and image width,height) so that the thumbnail is centered in the calendar cell, and the thumbnail is scaled down (eventually) so that a maximum amount of the thumbnail is shown (for example a thumbnail in portrait mode larger than a calendar cell square will be rescaled with css so that the width fit exactly the cell; not all the height will be visible - overflow hidden, but it will the height will be centered). All these calculations are performed in php.
(0001052)
rvelices (developer)
2006.06.14 02:18

corrected in branch-1_6 [Subversion] r1351 and trunk [Subversion] r1352

- Issue History
Date Modified Username Field Change
2006.05.28 10:17 pfrize New Issue
2006.05.28 10:17 pfrize browser => any
2006.05.28 10:17 pfrize Web server => Apache 1.3.x
2006.06.03 18:23 chrisaga Note Added: 0001012
2006.06.03 18:23 chrisaga Assigned To => rvelices
2006.06.03 18:23 chrisaga Status new => assigned
2006.06.03 18:23 chrisaga Category other => template
2006.06.07 19:33 rvelices Note Added: 0001027
2006.06.07 20:55 chrisaga Note Added: 0001029
2006.06.08 17:44 rvelices Note Added: 0001035
2006.06.14 02:18 rvelices Note Added: 0001052
2006.06.14 02:18 rvelices Status assigned => closed
2006.06.14 02:18 rvelices Fixed in Version => 1.6.0RC3
2009.08.11 00:58 mathiasm Resolution open => fixed


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Contact
Powered by Mantis Bugtracker