Piwigo Bugtracker

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000039 [Piwigo] user comments feature N/A 2004.07.12 17:01 2009.08.11 00:53
Reporter marsue View Status public  
Assigned To plg
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 1.6 branch Product Version 1.2.0
  Target Version Product Build
Summary 0000039: switch on comments per category
Description having a possibility to enable/disable the comments on categories via the admin interface
Steps To Reproduce
Additional Information
Tags No tags attached.
browser any
Database engine and version
PHP version
Web server Apache 1.3.x
Attached Files

- Relationships

-  Notes
(0000050)
marsue (reporter)
2004.11.08 10:59
edited on: 2004.11.08 11:00

In fact we're using phpwebgallerie for our montly photo contest here:
http://concours.megapixel.free.fr [^] and we the vote is over we want to let the users to add comments but not to the upcomming contest, that's why it would be really good if we have a way to define which category is allowed to have comments.

(0000052)
plg (manager)
2004.11.11 00:11

Beautiful gallery ! And excellent Contest MOD. I would be very proud if you could open a topic on the forum section "testimonials and show off" to explain how you did it.

Then, your request... Since you have very few categories, I propose you a simple way to solve your problem :

1. adding a field in categories table comments_enable enum('true','false')
2. retrieving this info in photo.php
3. still in photo.php, if this field info is set to "true", comments are available

Setting this parameter would need a direct access to the database (PhpMyAdmin). Would this convince you ?
(0000053)
marsue (reporter)
2004.11.12 19:37

unfortunately I'm not the user of the account that host the gallery and the person who is isn't a technical person at all :-( So It might be a better solution to have in the admin section the ability to define which category is eligible for commenting. I was thinking about the page admin.php?page=cat_modify&cat=catid, with comments turned on by default and the adminuser will have to go to the category edit panel to disable the comment...

But I keep the solution in mind and will present your solution to the user comunity to see if they agree to have a gallery upgrading ... they are very reluctant to any changes because it works at the moment!
(0000055)
marsue (reporter)
2004.11.26 10:42

I've propsoed your suggestion to the photographer community, there are in favor of having parametrable comments per category so I would be glad to know what to do, where and how :-)

Thanks for your very good work.
i can be contacted via my email in my profile.
(0000080)
plg (manager)
2005.01.17 15:25

Sorry for the delay, see http://forum.phpwebgallery.net/viewtopic.php?id=3030 [^] for your MOD :-) Happy new year
(0000081)
plg (manager)
2005.01.17 15:27

This feature is added in branch 1.4 but require a specific MOD for marsue's 1.2 version, see http://forum.phpwebgallery.net/viewtopic.php?id=3030 [^]

- Issue History
Date Modified Username Field Change
2004.07.12 17:01 marsue New Issue
2004.11.08 10:59 marsue Note Added: 0000050
2004.11.08 11:00 marsue Note Edited: 0000050
2004.11.11 00:11 plg Note Added: 0000052
2004.11.11 00:11 plg Assigned To => plg
2004.11.11 00:11 plg Status new => assigned
2004.11.11 00:11 plg version => 1.2.0
2004.11.12 19:37 marsue Note Added: 0000053
2004.11.26 10:42 marsue Note Added: 0000055
2005.01.17 15:25 plg Note Added: 0000080
2005.01.17 15:27 plg Status assigned => closed
2005.01.17 15:27 plg Note Added: 0000081
2009.08.11 00:53 mathiasm Resolution open => fixed
2009.08.11 00:53 mathiasm Fixed in Version => 1.6 branch


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Contact
Powered by Mantis Bugtracker