Piwigo Bugtracker

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000407 [Piwigo] notification trivial always 2006.06.08 08:51 2006.07.10 07:05
Reporter plg View Status public  
Assigned To rub
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 1.6.0RC3 Product Version 1.6.0RC2
  Target Version Product Build
Summary 0000407: accents are not allowed in mail headers
Description In the notification by mail feature, in french, there are accentuated characters in the subject. This is not allowed. Is it possible to remove accentuated characters from the subject line?
Steps To Reproduce
Additional Information
Tags No tags attached.
browser any
Database engine and version
PHP version
Web server Apache 1.3.x
Attached Files

- Relationships

-  Notes
(0001036)
rub (developer)
2006.06.11 23:32

Not allowed to have accentuations on subjet!? In my opinionn it's not really but I know that accentuations on certain elements must be privided problem.

The best, it's not to delete accentuations but translate text ascii8bits on ascii7bits. It's possible to do that with iconv_substr but this fonction is not avaible on free provider for exemple. I would develop a new function.
(0001037)
rub (developer)
2006.06.11 23:37

With str_replace() and a definition for each language a correct convertion, it's possible.
(0001078)
rub (developer)
2006.06.18 01:03

Fix on [Subversion] r1361 [Subversion] r1362
(0001079)
nikrou (developer)
2006.06.18 13:57
edited on: 2006.06.18 13:58

Please correct include/functions.inc.php: line exceed 79 characters. (comment for str_translate_to_ascii7bits fucntion must be split into two lines)

(0001080)
rub (developer)
2006.06.18 18:33

It's really a problem?
(0001081)
rub (developer)
2006.06.18 18:51

Fix on [Subversion] r1363 [Subversion] r1365
(0001084)
rub (developer)
2006.06.18 23:55

-> Please correct include/functions.inc.php: line exceed 79 characters. (comment for str_translate_to_ascii7bits fucntion must be split into two lines)

Please, indicate that it's a pwg coding conventions mistake, because I asked to me if the problem was not only bad coding conventions!

- Issue History
Date Modified Username Field Change
2006.06.08 08:51 plg New Issue
2006.06.08 08:51 plg Status new => assigned
2006.06.08 08:51 plg Assigned To => rub
2006.06.08 08:51 plg browser => any
2006.06.08 08:51 plg Web server => Apache 1.3.x
2006.06.11 23:32 rub Note Added: 0001036
2006.06.11 23:37 rub Note Added: 0001037
2006.06.18 01:03 rub Status assigned => resolved
2006.06.18 01:03 rub Fixed in Version => 1.6.0RC3
2006.06.18 01:03 rub Resolution open => fixed
2006.06.18 01:03 rub Note Added: 0001078
2006.06.18 13:57 nikrou Status resolved => feedback
2006.06.18 13:57 nikrou Resolution fixed => reopened
2006.06.18 13:57 nikrou Note Added: 0001079
2006.06.18 13:58 nikrou Note Edited: 0001079
2006.06.18 18:33 rub Note Added: 0001080
2006.06.18 18:51 rub Status feedback => resolved
2006.06.18 18:51 rub Resolution reopened => fixed
2006.06.18 18:51 rub Note Added: 0001081
2006.06.18 23:55 rub Status resolved => feedback
2006.06.18 23:55 rub Resolution fixed => reopened
2006.06.18 23:55 rub Note Added: 0001084
2006.06.18 23:55 rub Status feedback => resolved
2006.06.18 23:55 rub Resolution reopened => fixed
2006.07.10 07:05 rub Status resolved => closed


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Contact
Powered by Mantis Bugtracker