Piwigo Bugtracker

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000451 [Piwigo] users & groups minor always 2006.07.06 04:54 2008.05.01 07:18
Reporter rvelices View Status public  
Assigned To nikrou
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 1.6.2 Product Version 1.6.0
  Target Version Product Build
Summary 0000451: Auto login does not work properly
Description When auto-login is checked, the browser gets the cookie with the correct life time, but the server deletes the session when the session garbage collector is called.
Steps To Reproduce Use 2 browsers or 2 different machines:
- connect with auto login on 1 of them and close it
- browse your gallery approx 100 times (for default gc_probability and gc_divisor parameters in php.ini)
- restart first browser -> you're not connected anymore

(can also test it with FF and Web developer extension by manually deleting/putting back the cookie)
Additional Information
Tags No tags attached.
browser any
Database engine and version
PHP version
Web server Apache 1.3.x
Attached Files

- Relationships
related to 0000492closed Am√©lioration de redirect 

-  Notes
(0001171)
plg (manager)
2006.07.06 09:35

Same problem for me. Each time I restart my computer, I have to reconnect :-/ This is a real problem for my members, they have to login each time they visit the gallery.
(0001271)
nikrou (developer)
2006.07.23 17:01

See http://forum.phpwebgallery.net/viewtopic.php?id=8313 [^] to follow discussion about a fixed solution
(0001272)
nikrou (developer)
2006.07.23 17:29

fixed in trunk: [Subversion] r1493
(0001327)
nikrou (developer)
2006.07.28 11:26

Fix problem with reconnexion when session expired with a time out
Fix in trunk [Subversion] r1511
(0001341)
rub (developer)
2006.08.01 00:06

with !$conf['guest_access'], indentification.php try to redirect himself ad infinitum.

Because
if ($user['is_the_guest'] and !$conf['guest_access'])
{
  redirect (get_root_url().'identification.php');
}
 are move to index.php to indentification.php
(0001345)
nikrou (developer)
2006.08.01 15:24

fix in trunk: [Subversion] r1522
(0001349)
rub (developer)
2006.08.02 22:32

See http://forum.phpwebgallery.net/viewtopic.php?pid=42658#p42658 [^]
(0001350)
nikrou (developer)
2006.08.02 23:11
edited on: 2006.08.07 15:31

fix in trunk: [Subversion] r1024

Slah problem fix in [Subversion] r1526

(0001445)
plg (manager)
2006.10.04 18:19

Can we have this problem fixed in branch 1.6?
(0001447)
nikrou (developer)
2006.10.04 20:44
edited on: 2006.10.04 22:48

> Can we have this problem fixed in branch 1.6?

Of course big chief! :-) Done: reported in branch 1.6 [Subversion] r1553, [Subversion] r1554

I didn't report it on the branch because, I hope you tell me if it solves all your problems. I think so because I don't see new problems.

p.s: I know I could require a report with mantis but I allways forget!

(0001449)
plg (manager)
2006.10.05 09:10

Now we have this bug resolved in current stable branch and on trunk, it's new status is "closed".
(0001470)
rvelices (developer)
2006.10.13 03:26

In branch 1.6 only, when a user logs out, you get:
Notice: Undefined index: template in D:\pwg\branch-1_6\include\functions.inc.php on line 564
Template->make_filename(): Error - file ./template//header.tpl does not exist

I think this comes from the move of some redirect functions (which use the template - at least in 1.6) before user initialization.
(0001471)
rvelices (developer)
2006.10.13 03:48

And by the way I just realized that the external authentication will not work anymore because the auto_login key is in the users table and not in the user_info table.
(0001472)
nikrou (developer)
2006.10.13 11:45

Does the way I fixed the problem in the trunk is correct for you ?
(0001473)
rvelices (developer)
2006.10.13 12:49

Not really. I thought we already had this discussion in the bug related to redirection.
I don't understand why you had to move all the code around.
(0001474)
nikrou (developer)
2006.10.14 09:21

> Not really.

Ok.

> I thought we already had this discussion in the bug related to redirection.
I don't understand why you had to move all the code around.

I alreadly explain how I want to fix that and You not agree me. So I don't know how to fix it.
Can we discuss it on the forum ?
http://forum.phpwebgallery.net/viewtopic.php?id=9068 [^]
(0001504)
plg (manager)
2006.11.10 09:42

In branch 1.6, I've moved #users.auto_login_key to #user_infos.auto_login_key in [Subversion] r1594

This move still need to be merged on trunk, I take this action.
(0002196)
VDigital (reporter)
2008.05.01 07:18

Auto-login is running well now.

- Issue History
Date Modified Username Field Change
2006.07.06 04:54 rvelices New Issue
2006.07.06 04:54 rvelices browser => any
2006.07.06 04:54 rvelices Web server => Apache 1.3.x
2006.07.06 09:34 plg Status new => assigned
2006.07.06 09:34 plg Assigned To => nikrou
2006.07.06 09:35 plg Note Added: 0001171
2006.07.23 17:01 nikrou Note Added: 0001271
2006.07.23 17:29 nikrou Note Added: 0001272
2006.07.23 17:30 nikrou Status assigned => resolved
2006.07.23 17:30 nikrou Resolution open => fixed
2006.07.28 11:22 nikrou Status resolved => feedback
2006.07.28 11:22 nikrou Resolution fixed => reopened
2006.07.28 11:26 nikrou Note Added: 0001327
2006.07.28 11:27 nikrou Status feedback => resolved
2006.07.28 11:27 nikrou Resolution reopened => fixed
2006.07.29 15:40 nikrou Status resolved => feedback
2006.07.29 15:40 nikrou Resolution fixed => reopened
2006.07.29 15:41 nikrou Status feedback => resolved
2006.07.29 15:41 nikrou Resolution reopened => fixed
2006.08.01 00:06 rub Status resolved => feedback
2006.08.01 00:06 rub Resolution fixed => reopened
2006.08.01 00:06 rub Note Added: 0001341
2006.08.01 15:04 nikrou Status feedback => confirmed
2006.08.01 15:24 nikrou Note Added: 0001345
2006.08.01 15:26 nikrou Status confirmed => resolved
2006.08.01 15:26 nikrou Fixed in Version => BSF branch (dev)
2006.08.01 15:26 nikrou Resolution reopened => fixed
2006.08.02 22:32 rub Status resolved => feedback
2006.08.02 22:32 rub Resolution fixed => reopened
2006.08.02 22:32 rub Note Added: 0001349
2006.08.02 23:11 nikrou Note Added: 0001350
2006.08.02 23:12 nikrou Status feedback => resolved
2006.08.02 23:12 nikrou Resolution reopened => fixed
2006.08.02 23:26 rub Status resolved => feedback
2006.08.02 23:26 rub Resolution fixed => reopened
2006.08.02 23:26 rub Relationship added related to 0000492
2006.08.07 15:31 nikrou Note Edited: 0001350
2006.08.07 15:31 nikrou Status feedback => resolved
2006.08.07 15:31 nikrou Resolution reopened => fixed
2006.10.04 18:19 plg Note Added: 0001445
2006.10.04 20:44 nikrou Status resolved => feedback
2006.10.04 20:44 nikrou Resolution fixed => reopened
2006.10.04 20:44 nikrou Note Added: 0001447
2006.10.04 22:45 nikrou Note Edited: 0001447
2006.10.04 22:47 nikrou Note Edited: 0001447
2006.10.04 22:47 nikrou Note Edited: 0001447
2006.10.04 22:48 nikrou Note Edited: 0001447
2006.10.04 22:48 nikrou Status feedback => resolved
2006.10.04 22:48 nikrou Fixed in Version BSF branch (dev) => 1.6.2
2006.10.04 22:48 nikrou Resolution reopened => fixed
2006.10.05 09:10 plg Note Added: 0001449
2006.10.05 09:10 plg Status resolved => closed
2006.10.13 03:26 rvelices Status closed => feedback
2006.10.13 03:26 rvelices Resolution fixed => reopened
2006.10.13 03:26 rvelices Note Added: 0001470
2006.10.13 03:48 rvelices Note Added: 0001471
2006.10.13 11:44 nikrou Assigned To nikrou =>
2006.10.13 11:45 nikrou Note Added: 0001472
2006.10.13 12:49 rvelices Note Added: 0001473
2006.10.14 09:21 nikrou Note Added: 0001474
2006.11.10 09:42 plg Note Added: 0001504
2006.11.10 09:42 plg Assigned To => nikrou
2006.11.10 09:42 plg Status feedback => resolved
2006.11.10 09:42 plg Resolution reopened => fixed
2008.05.01 07:18 VDigital Status resolved => closed
2008.05.01 07:18 VDigital Note Added: 0002196


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Contact
Powered by Mantis Bugtracker