Piwigo Bugtracker

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000452 [Piwigo] installation & upgrade block have not tried 2006.07.06 10:08 2006.07.06 22:54
Reporter chrisaga View Status public  
Assigned To chrisaga
Priority urgent Resolution fixed Platform online.fr
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 1.6.1 Product Version 1.6.0
  Target Version Product Build 1.6.0 release
Summary 0000452: upgrade fails with MySQL 3.x.x
Description Upgrade fails with MySQL error.
Worked perfectly well on my testing gallery (PHP: 5.0.4; MySQL: 4.0.20)
Failed on my production gallery (PHP: 4.3.10-2; MySQL: 3.23.47-log)
With an SQL error (see below) followed my the usual upgrade success message.
But the gallery did'nt work at all (blank page)

<:o((
Steps To Reproduce Follow upgrade instructions with MySQL 3.x.x (tested with 3.23.47-log)
Additional Information INSERT INTO phpwebgallery_config
  (param,value,comment)
  VALUES
  (
    'nbm_send_mail_as',
    '',
    'Send mail as param value for notification by mail'
  ),
  (
    'nbm_send_detailed_content',
    'true',
    'Send detailed content for notification by mail'
  ),
  (
    'nbm_complementary_mail_content',
    '',
    'Complementary mail content for notification by mail'
  )
;

[mysql error 1064] You have an error in your SQL syntax near ';
' at line 20

Upgrade from version 1.5.0 to 1.6.0

Statistics

    * total upgrade time : 2.225 s
    * total SQL time : 2.069 s
    * SQL queries : 47

Upgrade informations

    * [security] delete files "upgrade.php", "install.php" and "install" directory
    * in include/mysql.inc.php, remove

      define('PHPWG_IN_UPGRADE', true);

    * Perform a maintenance check in [Administration>General>Maintenance] if you encounter any problem.
Tags No tags attached.
browser any
Database engine and version 3.23.47-log
PHP version 4.3.10-2
Web server Apache 1.3.x
Attached Files

- Relationships

-  Notes
(0001172)
chrisaga (developer)
2006.07.06 10:08

PS. I know it isn't very good to have such different testing/running environments but I do with what my providers ... provide me. It's still good for testing templates/themes <;o)
(0001173)
plg (manager)
2006.07.06 11:36

I don't have any MySQL 3.x available. I don't understand what can be wrong with this query :-/ I don't even what test I can ask you to perform.
(0001174)
mathiasm (manager)
2006.07.06 11:38

did you try to remove the ; ?
(0001175)
chrisaga (developer)
2006.07.06 13:46
edited on: 2006.07.06 15:53

> did you try to remove the ; ?

No, but it was not a problem with SQL code executed above in upgrade_1.5.0.php

According to manual, this synthax seems to be correct for MySQL 3.23.x
It's the firs multi-line insert in upgrade_1.5.0.php so it might be a bug in the parser (but works throught PhpMyAdmin).
Other clue : comment is a keyword, so `comment` might be better (but it is used as this before in upgrade_1.5.0.php)

(0001177)
chrisaga (developer)
2006.07.06 21:23

After several unsuccessful tests, I read the error message more carefully.
What bothers the parser is the carriage return after the ending ';'.
Thought one !

Fixed in [Subversion] r1437
(0001178)
plg (manager)
2006.07.06 22:54

Well done :-)

- Issue History
Date Modified Username Field Change
2006.07.06 10:08 chrisaga New Issue
2006.07.06 10:08 chrisaga Status new => assigned
2006.07.06 10:08 chrisaga Assigned To => plg
2006.07.06 10:08 chrisaga browser => any
2006.07.06 10:08 chrisaga MySQL version => 3.23.47-log
2006.07.06 10:08 chrisaga PHP version => 4.3.10-2
2006.07.06 10:08 chrisaga Web server => Apache 1.3.x
2006.07.06 10:08 chrisaga Note Added: 0001172
2006.07.06 11:36 plg Note Added: 0001173
2006.07.06 11:38 mathiasm Note Added: 0001174
2006.07.06 13:46 chrisaga Note Added: 0001175
2006.07.06 13:47 chrisaga Note Edited: 0001175
2006.07.06 15:53 chrisaga Note Edited: 0001175
2006.07.06 21:15 chrisaga Assigned To plg => chrisaga
2006.07.06 21:23 chrisaga Status assigned => resolved
2006.07.06 21:23 chrisaga Fixed in Version => 1.6 branch
2006.07.06 21:23 chrisaga Resolution open => fixed
2006.07.06 21:23 chrisaga Note Added: 0001177
2006.07.06 22:54 plg Note Added: 0001178
2006.07.06 22:54 plg Status resolved => closed
2006.07.06 22:54 plg version 1.6.0RC3 => 1.6.0
2006.07.06 22:54 plg Fixed in Version 1.6 branch => 1.6.1


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Contact
Powered by Mantis Bugtracker