Piwigo Bugtracker

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000470 [Piwigo] display feature N/A 2006.07.15 00:22 2006.07.17 15:56
Reporter mathiasm View Status public  
Assigned To chrisaga
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 1.6.1 Product Version
  Target Version Product Build
Summary 0000470: page d'accueil et identification
Description Following this french topic http://forum.phpwebgallery.net/viewtopic.php?pid=40156#p40156, [^] it appears that some users want to display identification.php when guest access s forbidden and users are note logged in.

Code proposal by chrisaga below
Steps To Reproduce
Additional Information In index.php before the comment"change of image display order", insert
if ($user['is_the_guest'] and !$conf['guest_access'])
{
  redirect (get_root_url().'identification.php');
}
In include/config_local.inc.php, insert :
$conf['guest_access'] = false;

To get standard behavior, just replace false by true.
Tags No tags attached.
browser any
Database engine and version
PHP version
Web server Apache 1.3.x
Attached Files

- Relationships

-  Notes
(0001223)
chrisaga (developer)
2006.07.15 00:39

I will commit it unless somebody have an objection (maybe imissed something and my solution is not so "clean")
(0001226)
chrisaga (developer)
2006.07.15 10:16

Done in trunk [Subversion] r1470
(0001227)
chrisaga (developer)
2006.07.15 10:19

Merged in 1.6 [Subversion] r1471 because it was a regression introduced when category.php
became index.php

- Issue History
Date Modified Username Field Change
2006.07.15 00:22 mathiasm New Issue
2006.07.15 00:22 mathiasm browser => any
2006.07.15 00:22 mathiasm Web server => Apache 1.3.x
2006.07.15 00:37 chrisaga Status new => assigned
2006.07.15 00:37 chrisaga Assigned To => chrisaga
2006.07.15 00:39 chrisaga Note Added: 0001223
2006.07.15 00:39 chrisaga Status assigned => acknowledged
2006.07.15 10:16 chrisaga Status acknowledged => resolved
2006.07.15 10:16 chrisaga Fixed in Version => BSF branch (dev)
2006.07.15 10:16 chrisaga Resolution open => fixed
2006.07.15 10:16 chrisaga Note Added: 0001226
2006.07.15 10:19 chrisaga Status resolved => closed
2006.07.15 10:19 chrisaga Note Added: 0001227
2006.07.17 15:56 plg Fixed in Version BSF branch (dev) => 1.6.1


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Contact
Powered by Mantis Bugtracker