Piwigo Bugtracker

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000511 [Piwigo] database feature always 2006.08.10 08:16 2010.04.14 17:32
Reporter pard View Status public  
Assigned To nikrou
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 2.1.0RC1 Product Version
  Target Version 2.1.0 Product Build
Summary 0000511: Another db than MySQL
Description I like phpwebgallery and I want to run it on <a href=http://www.asus.com/products4.aspx?l1=12&l2=43&l3=0&model=359&modelmenu=1>ASUS [^] WL500g</a>, but MySQL is consumpting too much memory and consequently it's not best solution. Do you think about usage of another db background - eg. SQLite?
Steps To Reproduce
Additional Information
Tags No tags attached.
browser any
Database engine and version
PHP version
Web server
Attached Files

- Relationships
child of 0001255closednikrou Allow to use different database engine. 

-  Notes
(0001380)
plg (manager)
2006.08.16 18:07

I must admit the idea is pleasant but technicaly very hard to implement with the current code of PhpWebGallery. Indeed, there is no database access layer. I mean SQL queries are written directly in the middle of PHP pages. SQL queries are more MySQL queries than standard SQL queries.

I change the status of this issue to "acknowledged" but the implementation of seach a technical feature is not planned before a possible 2.0 release (which is not planned at all)
(0003361)
svn (reporter)
2010.01.28 12:30

[Subversion] r4781 by nikrou on trunk

-----[Subversion commit log]----------------------------------------------------
Feature 511 : add support for sqlite database engine

Using session_write_close function when session handler use database because write is called after object destruction.
(0003367)
svn (reporter)
2010.01.29 12:36

[Subversion] r4791 by nikrou on trunk

-----[Subversion commit log]----------------------------------------------------
Feature 511 : improve installation for sqlite
fatal error if database cannot be accessed
fix problem with booleans
(0003376)
nikrou (developer)
2010.02.01 10:15

calendar navigation is broken because of the way we store months and days : sometimes with leading zero and sometimes not !
(0003381)
svn (reporter)
2010.02.03 10:26

[Subversion] r4833 by nikrou on trunk

-----[Subversion commit log]----------------------------------------------------
Feature 511 : fix problems with calendar functions
add pwg_db_concat() function

- Issue History
Date Modified Username Field Change
2006.08.10 08:16 pard New Issue
2006.08.10 08:16 pard browser => any
2006.08.16 18:07 plg Note Added: 0001380
2006.08.16 18:07 plg Status new => acknowledged
2009.12.15 01:22 mathiasm Status acknowledged => assigned
2009.12.15 01:22 mathiasm Assigned To => nikrou
2009.12.21 19:08 mathiasm Relationship added child of 0001255
2010.01.26 22:29 nikrou Target Version => Colibri
2010.01.28 12:30 svn Checkin
2010.01.28 12:30 svn Note Added: 0003361
2010.01.28 12:33 nikrou Status assigned => resolved
2010.01.28 12:33 nikrou Fixed in Version => Colibri
2010.01.28 12:33 nikrou Resolution open => fixed
2010.01.29 12:36 svn Checkin
2010.01.29 12:36 svn Note Added: 0003367
2010.02.01 10:15 nikrou Note Added: 0003376
2010.02.01 10:15 nikrou Status resolved => feedback
2010.02.01 10:15 nikrou Resolution fixed => reopened
2010.02.03 10:26 svn Checkin
2010.02.03 10:26 svn Note Added: 0003381
2010.02.03 10:27 nikrou Status feedback => resolved
2010.02.03 10:27 nikrou Resolution reopened => fixed
2010.02.03 12:48 svn Checkin
2010.02.03 12:48 svn Note Added: 0003382
2010.02.03 12:49 plg Note Deleted: 0003382
2010.04.14 17:32 plg Status resolved => closed
2010.04.14 17:32 plg Fixed in Version 2.1.0 => 2.1.0RC1


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Contact
Powered by Mantis Bugtracker