Piwigo Bugtracker

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000532 [Piwigo] display major always 2006.09.06 01:16 2008.09.26 23:22
Reporter Guy_M View Status public  
Assigned To VDigital
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 2.0.0RC1 Product Version 1.6.1
  Target Version 2.0.0 Product Build
Summary 0000532: Dans Firefox Taille des emplacement catégories trop large pour les gérer
Description Quand on essaye de gérer les catégories des utilisateurs ( admin.php?page=user_perm&user_id= ) les emplacements pour afficher les catégories sont trop large pour pouvoir passer les catégories de interdit à autoriser : il débordent de la fenêtre, l'absence d'acenseur ne permet pas de voir le contenu de l'emplacement "interdit" et d'accéder au bouton '<'

J'ai fait le test avec IE, la taille des emplacement reste bien limité mais dans ce cas on ne pas lire tout le chemin et le nom (manque un ascenseur horizontal dans chaque emplacement).
Steps To Reproduce Cela ne se produit que si le nom et le chemin d'une catégorie autorisées est suffisamment long par exemple : Vacances / 2006, août Le Monastier sur Gazeille / Championnat du monde de vélo couché
Additional Information
Tags No tags attached.
browser Mozilla
Database engine and version
PHP version
Web server Apache 1.3.x
Attached Files

- Relationships

-  Notes
(0001421)
Guy_M (reporter)
2006.09.06 19:37
edited on: 2006.09.09 23:36

Dans d'autres page de gestion de catégories, on a le problème de cellule de tableau trop grande mais l'ascenseur horizontal de la page permet de gérer les catégories.

(0001427)
ericFabre (reporter)
2006.09.14 10:17

je rencontre le même problème, mais le contourne en cliquant sur une ligne, puis en descendant avec la touche flèche bas....
(0002266)
mathiasm (manager)
2008.07.04 00:03

Firefox does not resize equally both select when page is too narrow
While IE7 does, and Opera too.
(0002358)
VDigital (reporter)
2008.09.06 00:12

Need confirmation in Butterfly 1
(0002374)
VDigital (reporter)
2008.09.19 09:13

Without confirmation this "bug" will be closed by end of September, 2008.
(0002378)
mathiasm (manager)
2008.09.21 21:31

Confirmed under Firefox 2.0
(0002381)
VDigital (reporter)
2008.09.23 23:58

Boxes will have equal widths.
But the problem remains because long name cannot be visible.
I saw a javascript solution.
Another solution is to add title= in each option but {html_options doesn't support that).
(0002382)
mathiasm (manager)
2008.09.24 08:26

Can't we have horizontal scrollbar ?
(0002383)
VDigital (reporter)
2008.09.24 13:51

I spent a part of my evening for:
- Adding a horizontal scrollbar in a select box.
- Adding title= in <option> tag via {html_options}
- Understanding the cause of this bug (I found that one: Select and table)
- etc...
I know a javascript which add horizontal scrollbar (previous note).
I am going to search if jQuery has one proposal.
If not, I will see which solution is the fastest to apply.
(0002384)
VDigital (reporter)
2008.09.24 16:24

Solution to be implemented will be based on:
http://www.webmasterworld.com/css/3002788.htm [^]
or
http://www.codeproject.com/KB/scripting/WithHorizontalScrollbar.aspx [^]

In fact, they are the same solution.

In our case, I am expecting to do it without a <div>, so being a bit different from that they are explaining.
(0002386)
VDigital (reporter)
2008.09.25 08:57

Bad news: It isn't working as I expected, I have to find something else.
(0002389)
VDigital (reporter)
2008.09.26 23:22

Double selects are jQuery resizable.
[Subversion] r2600

- Issue History
Date Modified Username Field Change
2006.09.06 01:16 Guy_M New Issue
2006.09.06 01:16 Guy_M browser => Mozilla
2006.09.06 01:16 Guy_M Web server => Apache 1.3.x
2006.09.06 19:37 Guy_M Note Added: 0001421
2006.09.09 23:36 Guy_M Note Edited: 0001421
2006.09.14 10:17 ericFabre Note Added: 0001427
2008.07.04 00:03 mathiasm Note Added: 0002266
2008.07.04 00:04 mathiasm Status new => confirmed
2008.07.04 12:26 VDigital Assigned To => VDigital
2008.07.04 12:26 VDigital Target Version => Butterfly
2008.07.04 14:14 VDigital Status confirmed => assigned
2008.09.06 00:12 VDigital Note Added: 0002358
2008.09.06 00:12 VDigital Status assigned => feedback
2008.09.19 09:13 VDigital Note Added: 0002374
2008.09.21 21:31 mathiasm Note Added: 0002378
2008.09.23 23:58 VDigital Note Added: 0002381
2008.09.24 08:26 mathiasm Note Added: 0002382
2008.09.24 13:51 VDigital Note Added: 0002383
2008.09.24 16:24 VDigital Note Added: 0002384
2008.09.25 08:57 VDigital Note Added: 0002386
2008.09.26 23:22 VDigital Status feedback => closed
2008.09.26 23:22 VDigital Note Added: 0002389
2008.09.26 23:22 VDigital Resolution open => fixed
2008.09.26 23:22 VDigital Fixed in Version => 2.0.0RC1


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Contact
Powered by Mantis Bugtracker