Piwigo Bugtracker

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000562 [Piwigo] other feature always 2006.10.18 02:33 2007.01.23 14:29
Reporter rvelices View Status public  
Assigned To rvelices
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version Alligator 1 Product Version 1.6.2
  Target Version Product Build
Summary 0000562: For the history, add an option to ignore guest visits
Description As we have the option $conf['history_admin'] which will not log admin visits in the history table (when turned on), I would like a $conf['history_guest'] which will not track guests.
I need this because my history is growing a lot because of the search engines.
Steps To Reproduce
Additional Information
Tags No tags attached.
browser any
Database engine and version
PHP version
Web server Apache 1.3.x
Attached Files

- Relationships

-  Notes
(0001480)
rvelices (developer)
2006.10.19 02:35

[Subversion] r1565
(0001551)
plg (manager)
2006.11.24 00:56

I reopen this feature request because I need some explanations about the way it was implemented. Currently (trunk r1618) you can configure the history to log admin true/false, guest true/false, other user status true/false.

In this situation, I can have only admin log. Is that the wanted behaviour?

The way I saw it was: enable_history true/false, if enable_history is true, we take into account history_admin and history_guest. Does it make sense?

I just a discussion, I don't want rvelices to commit any modification on this code, because I'm deeply working on history management.
(0001558)
rvelices (developer)
2006.11.28 02:21

I chose the current behaviour only because that way you have full control on what is logged (you can choose "Admin but not users" or "Guests but not users"). Probably these full combinations are not really useful and on the downside the config variable names are not really very self-speaking anymore.
(0001667)
VDigital (reporter)
2007.01.20 09:26

User login history

I don't understand the exact added value.
Does that mean Users and Administrator(s) are logged at connection time even if they usually not logged?
That would be fine but it isn't working at all.
(Could we get a Loggin indicator in History?)
(0001669)
rvelices (developer)
2007.01.20 19:40

Vincent, depeux-tu reformuler en francais tes questions. J'ai peur de ne rien comprendre. Merci
(0001670)
VDigital (reporter)
2007.01.20 23:01

Configuration » Général » Configuration de PhpWebGallery
Historique
 o Historique des connexions (coché)

Je ne comprends pas ce que cela nous apporte de plus.
Est-ce que cela signifie que les membres et Admin sont historisés au moment de la connexion qu'ils soient historisés ou non?
Ce qui serait très bien mais pour moi cela ne marche pas.
( Est-ce que dans l'historique on pourrait avoir l'indication "Connexion"?
Aujourd'hui, la section dans la recherche de l'historique, c'est toujours "galeries" => aucune valeur ajoutée )
Is that clear enough?
(0001671)
rvelices (developer)
2007.01.20 23:06

As-tu lu http://bugs.phpwebgallery.net/view.php?id=564 [^] ?
(0001672)
VDigital (reporter)
2007.01.21 09:50

Vu. Mais...

 o Historique des connexions (coché)
On le laisse ou on le cache, on décide quoi???
(0001673)
rvelices (developer)
2007.01.21 17:37

On cache
(0001677)
rvelices (developer)
2007.01.23 14:28

? hmmm petit souci d'heure sur le serveur ?
(0001678)
rvelices (developer)
2007.01.23 14:29

c'est bon maintenant

- Issue History
Date Modified Username Field Change
2005.09.21 12:13 rvelices Status feedback => closed
2005.09.21 12:13 rvelices Resolution reopened => fixed
2006.10.18 02:33 rvelices New Issue
2006.10.18 02:33 rvelices Status new => assigned
2006.10.18 02:33 rvelices Assigned To => rvelices
2006.10.18 02:33 rvelices browser => any
2006.10.18 02:33 rvelices Web server => Apache 1.3.x
2006.10.19 02:35 rvelices Note Added: 0001480
2006.10.19 02:35 rvelices Status assigned => closed
2006.10.19 02:35 rvelices Resolution open => fixed
2006.10.19 02:35 rvelices Fixed in Version => Alligator (trunk)
2006.11.24 00:56 plg Note Added: 0001551
2006.11.24 00:56 plg Status closed => feedback
2006.11.24 00:56 plg Resolution fixed => reopened
2006.11.28 02:21 rvelices Note Added: 0001558
2007.01.20 09:26 VDigital Note Added: 0001667
2007.01.20 19:40 rvelices Note Added: 0001669
2007.01.20 23:01 VDigital Note Added: 0001670
2007.01.20 23:06 rvelices Note Added: 0001671
2007.01.21 09:50 VDigital Note Added: 0001672
2007.01.21 17:37 rvelices Note Added: 0001673
2007.01.23 14:28 rvelices Note Added: 0001677
2007.01.23 14:28 rvelices Status closed => assigned
2007.01.23 14:29 rvelices Note Added: 0001678
2007.01.23 14:29 rvelices Status assigned => closed


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Contact
Powered by Mantis Bugtracker