Piwigo Bugtracker

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000574 [Piwigo] other minor always 2006.10.27 18:07 2008.01.29 13:54
Reporter acp View Status public  
Assigned To
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 1.7.0 Product Version 1.6.1
  Target Version Product Build
Summary 0000574: Number of users on administration page
Description Hello,

I just realized that the number of users reported in the introduction page of the administration doesn't correspond to the list provided at the user_list page. The difference of 1 is due to the "guest" user.

IMHO, the 'guest' user isn't exactly a "real" user and should therefore not be counted. It's just a matter of consistency actually, not something "really" important, but I thought I should mention it :).

Keep up the good work.
Steps To Reproduce Load http://yoursite/admin.php [^] and compare with http://yoursite/admin.php?page=user_list [^]
Additional Information
Tags No tags attached.
browser any
Database engine and version
PHP version
Web server Apache 1.3.x
Attached Files

- Relationships
related to 0000578closedrub User guest must be real user 

-  Notes
(0001493)
VDigital (reporter)
2006.10.31 10:34

I disagree not about the difference but about guest.
Guest should be a real user at all (optionnal).
Except Customize.

But someone who can be include in a group.
In that case, guests can see different categories than members, categories which can be totally differents and not autorized to real members (because picures are in other categories).
(0001494)
acp (reporter)
2006.10.31 11:00

But isn't the point of public/private to define what guests can and can not see ?
(0001495)
VDigital (reporter)
2006.10.31 20:30
edited on: 2006.10.31 20:35

You're right but if guest became a real user... It will appear in the user list.
So the number of users reported in the introduction page will be correct.

Public means all users and no autorization checking (not only guest).
Private can also be private for guest ONLY (if guest is considered as a real user).

It is NOT a semantic problem.

(0002087)
mathiasm (manager)
2008.01.29 13:54

Fixed in 1.7.0

guest became a real user.

- Issue History
Date Modified Username Field Change
2006.10.27 18:07 acp New Issue
2006.10.27 18:07 acp browser => any
2006.10.27 18:07 acp Web server => Apache 1.3.x
2006.10.30 14:56 plg Status new => confirmed
2006.10.31 10:34 VDigital Note Added: 0001493
2006.10.31 11:00 acp Note Added: 0001494
2006.10.31 20:30 VDigital Note Added: 0001495
2006.10.31 20:34 VDigital Note Edited: 0001495
2006.10.31 20:35 VDigital Note Edited: 0001495
2006.11.07 15:34 VDigital Relationship added related to 0000578
2008.01.29 13:54 mathiasm Status confirmed => closed
2008.01.29 13:54 mathiasm Note Added: 0002087
2008.01.29 13:54 mathiasm Resolution open => fixed
2008.01.29 13:54 mathiasm Fixed in Version => 1.7.0


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Contact
Powered by Mantis Bugtracker