Piwigo Bugtracker

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000601 [Piwigo] navigation feature N/A 2006.12.10 23:05 2007.02.07 07:28
Reporter rub View Status public  
Assigned To rub
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version Alligator 2 Product Version
  Target Version Product Build
Summary 0000601: Filter all public pages with only recent elements
Description With a new icon, user can be restrict all lists to recent elements (picture or categories).
Steps To Reproduce
Additional Information See http://forum.phpwebgallery.net/viewtopic.php?pid=50015#p50015 [^]
See http://forum.phpwebgallery.net/viewtopic.php?id=9490 [^]
Tags No tags attached.
browser any
Database engine and version
PHP version
Web server Apache 1.3.x
Attached Files png file icon filter_mode_off.png [^] (126,759 bytes) 2006.12.10 23:10


png file icon filter_mode_on.png [^] (97,278 bytes) 2006.12.10 23:10


png file icon start_filter_mode.png [^] (1,064 bytes) 2006.12.10 23:11


png file icon stop_filter_mode.png [^] (765 bytes) 2006.12.11 21:38


png file icon no_filter_mode.png [^] (1,070 bytes) 2006.12.11 21:38


png file icon off_filter_mode.png [^] (1,083 bytes) 2006.12.11 21:39

- Relationships
related to 0000463assignedrub Liste des cat├ęgories... trop longue... 
related to 0000462closed Evolutions: Nouveaux affichages chronologiques 
related to 0000605closedrub Not linked elements failure with no virtual categories galleries 
related to 0000071closedplg Legend/Key Display Put Back Up 

-  Notes
(0001570)
rub (developer)
2006.12.10 23:44

[Subversion] r1648

It's a draft of the feature witch allows to show only recent elements.
Development are not finished.
Queries and special pages (best rates, tags, etc.) are not modified.
Only main php files about images and categories are ok.

Before to continue, I prefer to determinate a solution between modify cache implementation or hide counters.

Go to http://forum.phpwebgallery.net/viewtopic.php?pid=50015#p50015 [^]
(0001573)
VDigital (reporter)
2006.12.11 21:41

3 new attached icons.
(0001574)
rub (developer)
2006.12.12 18:26

[Subversion] r1650, new draft
(0001577)
rub (developer)
2006.12.13 00:57

Last draft [Subversion] r1651
(0001592)
rub (developer)
2006.12.21 22:29

[Subversion] r1677
(0001615)
VDigital (reporter)
2006.12.30 16:29

You have a bug when no recent pictures are available.
Way to reproduce it: Reduce your recent period.
(0001616)
rub (developer)
2006.12.30 23:23
edited on: 2006.12.30 23:35

> You have a bug when no recent pictures are available.
Fixed with [Subversion] r1684 and [Subversion] r1685

(0001635)
rvelices (developer)
2007.01.08 02:47
edited on: 2007.01.08 02:47

I think I have a problem when using the local filter (top right button):
- if an image appears in several categories (virtual ones)
- if you click on that image (the thumbnail) - i have several php warnings/errors and nothing is displayed

Not 100% sure but it appears that page['items'] is not unique ...

(0001638)
rub (developer)
2007.01.08 07:03

> - if an image appears in several categories (virtual ones)
> - if you click on that image (the thumbnail) - i have several php warnings/errors and nothing is displayed
Fixed with [Subversion] r1701
(0001657)
rub (developer)
2007.01.15 01:14

Done in [Subversion] r1722

There are no filter enabled if filter configuration is empty (no icon, no functions, ...)
New system for the filter page configuration

View mode flat_recent_cat becomes flat_cat (recent period is removed because global filter is sufficient)

Recent period of global filter must be defined "after" start parameter (default value is $user['recent_period']).
(0001658)
rub (developer)
2007.01.15 23:29

Missing information "recent" in URL filter start parameter
[Subversion] r1723
(0001743)
rvelices (developer)
2007.02.07 07:02
edited on: 2007.02.07 07:04

I still have issues with the computed counters in normal mode (not filter). I attach a screen shot:
http://www.modusoptimus.com/tmp/200702_capture_pwg.jpg [^]

(0001744)
rub (developer)
2007.02.07 07:14

There are really 4 sub-categories?
4th are locked, private?
(0001745)
rvelices (developer)
2007.02.07 07:19

There are only 2 categories with 31 and 3 images. Both image and category count are wrong (38 instead of 34 and 4 instead of 2). (Nothing is locked/private)
(0001746)
rvelices (developer)
2007.02.07 07:28

Damn. My fault ... Really sorry...
Politics contains both images and sub categories... The 2 is only number of images for itself...

- Issue History
Date Modified Username Field Change
2006.12.10 23:05 rub New Issue
2006.12.10 23:05 rub Status new => assigned
2006.12.10 23:05 rub Assigned To => rub
2006.12.10 23:05 rub browser => any
2006.12.10 23:05 rub Web server => Apache 1.3.x
2006.12.10 23:10 rub File Added: filter_mode_off.png
2006.12.10 23:10 rub File Added: filter_mode_on.png
2006.12.10 23:11 rub File Added: start_filter_mode.png
2006.12.10 23:12 rub Additional Information Updated
2006.12.10 23:44 rub Note Added: 0001570
2006.12.11 21:38 VDigital File Added: stop_filter_mode.png
2006.12.11 21:38 VDigital File Added: no_filter_mode.png
2006.12.11 21:39 VDigital File Added: off_filter_mode.png
2006.12.11 21:41 VDigital Note Added: 0001573
2006.12.11 22:29 rub Additional Information Updated
2006.12.12 10:42 rub Relationship added related to 0000463
2006.12.12 18:26 rub Note Added: 0001574
2006.12.13 00:57 rub Note Added: 0001577
2006.12.19 14:54 rub Relationship added related to 0000462
2006.12.20 11:59 rub Relationship added related to 0000605
2006.12.21 22:29 rub Status assigned => resolved
2006.12.21 22:29 rub Fixed in Version => Alligator (trunk)
2006.12.21 22:29 rub Resolution open => fixed
2006.12.21 22:29 rub Note Added: 0001592
2006.12.28 20:57 VDigital Relationship added related to 0000071
2006.12.30 16:29 VDigital Status resolved => feedback
2006.12.30 16:29 VDigital Resolution fixed => reopened
2006.12.30 16:29 VDigital Note Added: 0001615
2006.12.30 23:23 rub Status feedback => resolved
2006.12.30 23:23 rub Resolution reopened => fixed
2006.12.30 23:23 rub Note Added: 0001616
2006.12.30 23:35 rub Status resolved => feedback
2006.12.30 23:35 rub Resolution fixed => reopened
2006.12.30 23:35 rub Note Edited: 0001616
2006.12.30 23:35 rub Status feedback => resolved
2006.12.30 23:35 rub Resolution reopened => fixed
2007.01.08 02:47 rvelices Status resolved => feedback
2007.01.08 02:47 rvelices Resolution fixed => reopened
2007.01.08 02:47 rvelices Note Added: 0001635
2007.01.08 02:47 rvelices Note Edited: 0001635
2007.01.08 06:49 rub Status feedback => confirmed
2007.01.08 07:03 rub Status confirmed => resolved
2007.01.08 07:03 rub Resolution reopened => fixed
2007.01.08 07:03 rub Note Added: 0001638
2007.01.15 01:13 rub Status resolved => feedback
2007.01.15 01:13 rub Resolution fixed => reopened
2007.01.15 01:14 rub Status feedback => resolved
2007.01.15 01:14 rub Fixed in Version Alligator 1 => Alligator 2
2007.01.15 01:14 rub Resolution reopened => fixed
2007.01.15 01:14 rub Note Added: 0001657
2007.01.15 23:28 rub Status resolved => feedback
2007.01.15 23:28 rub Resolution fixed => reopened
2007.01.15 23:29 rub Status feedback => resolved
2007.01.15 23:29 rub Resolution reopened => fixed
2007.01.15 23:29 rub Note Added: 0001658
2007.01.26 23:44 rub Status resolved => closed
2007.02.07 07:02 rvelices Status closed => feedback
2007.02.07 07:02 rvelices Resolution fixed => reopened
2007.02.07 07:02 rvelices Note Added: 0001743
2007.02.07 07:04 rvelices Note Edited: 0001743
2007.02.07 07:14 rub Note Added: 0001744
2007.02.07 07:19 rvelices Note Added: 0001745
2007.02.07 07:28 rvelices Note Added: 0001746
2007.02.07 07:28 rvelices Status feedback => closed
2007.02.07 07:28 rvelices Resolution reopened => fixed


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Contact
Powered by Mantis Bugtracker