Piwigo Bugtracker

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000619 [Piwigo] other minor always 2007.01.15 19:38 2007.05.28 14:35
Reporter Yapuca View Status public  
Assigned To rub
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 1.7.1 Product Version 1.6.2
  Target Version Product Build
Summary 0000619: Fonction cookie_path() renvoie une chaine vide.
Description Lorsque $conf['guest_access'] = false (pas d'accès pour les visiteurs), la redirection ne fonctionne pas (page non trouvée) car la fonction cookie_path()
renvoie une chaine vide.

Hébergeur 1&1. On est dans un cas où les variables $_SERVER['REDIRECT_URL'] et $_SERVER['PATH_INFO'] ont la même valeur.

// cookie_path returns the path to use for the PhpWebGallery cookie.
// If PhpWebGallery is installed on :
// http://domain.org/meeting/gallery/category.php [^]
// cookie_path will return : "/meeting/gallery"

Dans mon cas la valeur renvoyée est "nulle".

Voir forum: http://forum.phpwebgallery.net/viewtopic.php?id=9482 [^]
Steps To Reproduce
Additional Information
Tags No tags attached.
browser any
Database engine and version 4.0.27-standard-log
PHP version PHP: 4.4.4
Web server Apache/1.3.33
Attached Files

- Relationships
related to 0000458closednikrou Cannot log due to broken session cookie when $_SERVER["PATH_INFO"] is empty or unset 

-  Notes
(0001849)
rub (developer)
2007.05.08 00:38

cf aussi discussion sur le forum:
http://forum.phpwebgallery.net/viewtopic.php?id=10636&p=1 [^]
(0001853)
rub (developer)
2007.05.08 12:17

[Subversion] r2004 & [Subversion] r2005
(0001860)
rub (developer)
2007.05.10 11:31

Après explication par rvelices de PATH_INFO et de la prise en compte de ma mauvaise interprétation de strRpos, PATH_INFO sera réintégré dans le code.
(0001862)
rub (developer)
2007.05.11 22:11

Réintégration de PATH_INFO avec de nouveau tests de conditions.

[Subversion] r2006 & [Subversion] r2007
(0001863)
rub (developer)
2007.05.14 23:12

Ancienne remarque de Nicco, mais non corrigé.
La fonction ne fonctionne avec une galerie installée directement à la racine du site.
(0001864)
rub (developer)
2007.05.14 23:13

[Subversion] r2010 & [Subversion] r2011

- Issue History
Date Modified Username Field Change
2007.01.15 19:38 Yapuca New Issue
2007.01.15 19:38 Yapuca browser => any
2007.01.15 19:38 Yapuca MySQL version => 4.0.27-standard-log
2007.01.15 19:38 Yapuca PHP version => PHP: 4.4.4
2007.01.15 19:38 Yapuca Web server => Apache/1.3.33
2007.05.07 11:44 rub Status new => assigned
2007.05.07 11:44 rub Assigned To => rub
2007.05.08 00:38 rub Note Added: 0001849
2007.05.08 12:17 rub Status assigned => resolved
2007.05.08 12:17 rub Fixed in Version => 1.7.1
2007.05.08 12:17 rub Resolution open => fixed
2007.05.08 12:17 rub Note Added: 0001853
2007.05.10 11:31 rub Status resolved => feedback
2007.05.10 11:31 rub Resolution fixed => reopened
2007.05.10 11:31 rub Note Added: 0001860
2007.05.11 22:11 rub Status feedback => resolved
2007.05.11 22:11 rub Resolution reopened => fixed
2007.05.11 22:11 rub Note Added: 0001862
2007.05.14 23:12 rub Status resolved => feedback
2007.05.14 23:12 rub Resolution fixed => reopened
2007.05.14 23:12 rub Note Added: 0001863
2007.05.14 23:13 rub Note Added: 0001864
2007.05.14 23:13 rub Status feedback => assigned
2007.05.28 14:35 rub Status assigned => closed
2007.05.28 14:35 rub Resolution reopened => fixed
2008.01.28 17:05 mathiasm Relationship added related to 0000458


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Contact
Powered by Mantis Bugtracker