Piwigo Bugtracker

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000620 [Piwigo] metadata feature always 2007.01.15 21:14 2010.05.05 01:50
Reporter eric View Status public  
Assigned To plg
Priority normal Resolution fixed Platform PhpWebGallery
Status closed   OS WinXP SP2
Projection none   OS Version 1.6.2
ETA none Fixed in Version 2.1.0 Product Version
  Target Version 2.1.0 Product Build
Summary 0000620: ability to synchronize metadata on any size of the photo
Description In case IPTC/EXIF metadata are not available in the "web resized" version of the photo, it would be useful to set the synchronization on another size of the photo.

For example, consider the "category A" as follows:

[Category A]
    |-> photo.jpg
    |-[pwg_high]
    | |-> photo.jpg
    |-[thumbnail]
           |-> TN-photo.jpg

I would like to set the metadata synchronization on the "high resolution" version of the photo.

VDigital has proposed to add a configuration variable for this.
Steps To Reproduce
Additional Information french topic : http://fr.piwigo.org/forum/viewtopic.php?id=9735 [^]
Tags No tags attached.
browser any
Database engine and version
PHP version
Web server Apache 1.3.x
Attached Files

- Relationships
has duplicate 0000394closedplg meta data pour le rĂ©pertoire pwg_high 

-  Notes
(0003325)
plg (manager)
2010.01.15 09:27

Polly has proposed a patch : when no exif/iptc data is found on the "web resized" photo, automatically search in the high definition photo.
(0003329)
svn (reporter)
2010.01.15 11:47

[Subversion] r4682 by plg on branch 2.0

-----[Subversion commit log]----------------------------------------------------
feature 620: if no exif/iptc found in the "web resized" photo, then we search
into the high definition picture if available. Thanks to Jochen Roth (Polly)
for the patch.
(0003330)
svn (reporter)
2010.01.15 11:47

[Subversion] r4683 by plg on trunk

-----[Subversion commit log]----------------------------------------------------
merge r4682 from branch 2.0 to trunk

feature 620: if no exif/iptc found in the "web resized" photo, then we search
into the high definition picture if available. Thanks to Jochen Roth (Polly)
for the patch.
(0003331)
plg (manager)
2010.01.15 11:52

Warning: with Piwigo 2.0.7, the patch provided by Polly only add the feature when you synchronize a single picture. This is due to a code duplication described in 0001380
(0003838)
svn (reporter)
2010.05.05 01:45

[Subversion] r6076 by plg on trunk

-----[Subversion commit log]----------------------------------------------------
feature 620: ability to synchronize metadata from high definition photo, if no
metadata available in "web sized" photo. This commit is a report of r4683 from
update_metadata function in admin/include/functions_metadata.php in the
duplicated code get_element_metadata of admin/site_reader_local.php. See
feature 620 for details about code duplication.
(0003840)
plg (manager)
2010.05.05 01:50

I've decided to keep the code duplicated as it is, see 0001380 for details.

The feature is now also available in the synchronization process.

- Issue History
Date Modified Username Field Change
2007.01.15 21:14 eric New Issue
2007.01.15 21:14 eric browser => any
2007.01.15 21:14 eric Web server => Apache 1.3.x
2007.01.15 21:14 eric Issue Monitored: eric
2009.10.07 22:07 plg Summary Evolution : Pouvoir synchroniser les metadata au choix sur les images HR, TN ou VL => ability to synchronize metadata on any size of the photo
2009.10.07 22:07 plg Description Updated
2009.10.07 22:07 plg Additional Information Updated
2010.01.15 09:27 plg Note Added: 0003325
2010.01.15 09:43 plg Assigned To => plg
2010.01.15 09:43 plg Status new => assigned
2010.01.15 09:43 plg Target Version => 2.0.8
2010.01.15 11:47 svn Checkin
2010.01.15 11:47 svn Note Added: 0003329
2010.01.15 11:47 svn Checkin
2010.01.15 11:47 svn Note Added: 0003330
2010.01.15 11:50 plg Relationship added has duplicate 0000394
2010.01.15 11:52 plg Note Added: 0003331
2010.04.14 17:44 plg Target Version 2.0.8 => 2.1.0RC3
2010.04.27 01:07 plg Target Version 2.1.0RC3 => 2.1.0
2010.05.05 01:45 svn Checkin
2010.05.05 01:45 svn Note Added: 0003838
2010.05.05 01:50 plg Note Added: 0003840
2010.05.05 01:50 plg Status assigned => closed
2010.05.05 01:50 plg Resolution open => fixed
2010.05.05 01:50 plg Fixed in Version => 2.1.0


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Contact
Powered by Mantis Bugtracker