Piwigo Bugtracker

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000793 [Piwigo] users & groups trivial always 2008.01.27 03:12 2008.05.14 14:46
Reporter mathiasm View Status public  
Assigned To Pat
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 1.7.2 Product Version 1.7.1
  Target Version Product Build
Summary 0000793: Admin: Added user does not appear in listing
Description When you create a user in the User administraiton page, this user does not appear in the list shown after.
You need to recall the page once more to get it.
Steps To Reproduce
Additional Information
Tags No tags attached.
browser any
Database engine and version
PHP version
Web server Apache 1.3.x
Attached Files

- Relationships
duplicate of 0000741closedPat Lors de la création d'un nouvel utilisateur, la liste des utilisateurs n'est pas immédiatement rafraîchie 

-  Notes
(0002148)
Pat (developer)
2008.02.28 23:16

J'ai trouvé la solution...
Ligne 841 dans la fonction create_user_infos, on a:

if (is_integer($arg_id))
{
  $user_ids[] = $arg_id;
}

Or, lors de la création d'un nouvel utilisateur, $arg_id est une chaine de caractère, et donc n'est pas considérée comme entier. Du coup, la table user_info n'est pas mise à jour, et l'utilsateur n'apparait qu'au rechargement de la page.
(0002153)
Pat (developer)
2008.02.29 14:11

branch 1.7: [Subversion] r2228
trunk: [Subversion] r2229

- Issue History
Date Modified Username Field Change
2008.01.27 03:12 mathiasm New Issue
2008.01.27 03:12 mathiasm browser => any
2008.01.27 03:12 mathiasm Web server => Apache 1.3.x
2008.01.29 21:07 mathiasm Relationship added duplicate of 0000741
2008.02.28 23:16 Pat Note Added: 0002148
2008.02.28 23:16 Pat Status new => assigned
2008.02.28 23:16 Pat Assigned To => Pat
2008.02.29 14:11 Pat Status assigned => resolved
2008.02.29 14:11 Pat Fixed in Version => 1.7.2
2008.02.29 14:11 Pat Resolution open => fixed
2008.02.29 14:11 Pat Note Added: 0002153
2008.05.14 14:46 VDigital Status resolved => closed


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Contact
Powered by Mantis Bugtracker