Piwigo Bugtracker

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000830 [Piwigo] authentication major always 2008.06.17 11:25 2008.07.19 23:52
Reporter worwan View Status public  
Assigned To plg
Priority normal Resolution fixed Platform x86
Status closed   OS Linux
Projection none   OS Version Debian Lenny
ETA none Fixed in Version 1.7.2 Product Version 1.7.1
  Target Version Product Build last stable release
Summary 0000830: apache authentication does not work
Description auth works only with account created during installation. Any new account does not work and in fact freeze and mysql/apache consume 100% of cpu. After web server timeout script is canceled and error is displayed:

UPDATE phpwebgallery_sessions
  SET expiration = now(),
  data = ''
  WHERE id = '873cf9878e212e4d48a8d24817df9664'
;
[mysql error 2013] Lost connection to MySQL server during query

Thanks a lot. This is stopper for me :). For any further information please ask!
Steps To Reproduce 1. install phpwebgallery
2. modify configuration to use apache for auth
3. try to log in as user that is not in gallery db yet
optional:) 4. check cpu usage of apache/mysql processes
5. after timeout (maybe lower it in apache configuration file so you dont have to wait 300 seconds :) you will see error
Additional Information
Tags No tags attached.
browser Mozilla
Database engine and version 5.0.51
PHP version 5.2.5
Web server Apache 2.2.8
Attached Files

- Relationships

-  Notes
(0002294)
plg (manager)
2008.07.19 23:52

I reproduce the problem with 1.7.1 but I don't reproduce the problem with the 1.7 development branch. So the good news is that it will be fixed in 1.7.2 (which should come soon). The bad news (for me) is that even after some investigation, I haven't been able to find what change fixed the bug!

- Issue History
Date Modified Username Field Change
2008.06.17 11:25 worwan New Issue
2008.06.17 11:25 worwan browser => Mozilla
2008.06.17 11:25 worwan MySQL version => 5.0.51
2008.06.17 11:25 worwan PHP version => 5.2.5
2008.06.17 11:25 worwan Web server => Apache 2.2.8
2008.06.17 11:26 worwan Issue Monitored: worwan
2008.07.19 23:52 plg Note Added: 0002294
2008.07.19 23:52 plg Assigned To => plg
2008.07.19 23:52 plg Status new => closed
2008.07.19 23:52 plg Resolution open => fixed
2008.07.19 23:52 plg Fixed in Version => 1.7.2


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Contact
Powered by Mantis Bugtracker