Piwigo Bugtracker

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000859 [Piwigo] display minor always 2008.09.13 23:05 2010.04.14 17:23
Reporter VDigital View Status public  
Assigned To plg
Priority normal Resolution fixed Platform Any
Status closed   OS Any
Projection none   OS Version Any
ETA none Fixed in Version 2.0.9 Product Version Butterfly 2
  Target Version Product Build
Summary 0000859: Non initalized dates and $conf['display_fromto'] = true;
Description Notice: Undefined offset: 0 in C:\wamp\www\phpwebgallery\trunk\include\functions.inc.php on line 624

A category has one picture with no exif/no itpc
=> date not initialized
from 00 0000 to Thursday 23 August 2007



The Reason is Bad JPEG file head, SOI marker not found: 0x3c 0x21
Status = -1
Unable to extract some or all of the Exif data.
Steps To Reproduce I could send in private the picture... (Don't use it in other purpose, not mine)
Additional Information
Tags No tags attached.
browser any
Database engine and version Any
PHP version Any
Web server Apache 1.3.x
Attached Files

- Relationships
related to 0001047closedplg Bug in the display of a pictures 

-  Notes
(0002808)
ddtddt (administrator)
2009.08.08 22:25

I think seeing a discussion on the forum for this

VDigital as you link?
(0003220)
grum (administrator)
2009.12.13 14:43

Same problem than bug 1047
(0003228)
VDigital (reporter)
2009.12.13 21:57

We are speaking about categories.
So it is linked to 1047.
But not the same.

You can have "from Tuesday 17 February 2009 to Thursday 29 October 2009"
on index.php page
or "from 00 0000 to Thursday 29 October 2009"


Config:
// display_fromto: display the date creation bounds of a
// category.
$conf['display_fromto'] = true;


Creation date with a value equal to zero, there is several cases:

$conf['use_iptc_mapping'] = array(
  ...
  'date_creation' => '2#055',
  ...
  );
$conf['use_exif_mapping'] = array(
  'date_creation' => 'DateTimeOriginal'
  );

Apparently (I didn't check):
1 - 2#055 updates date_creation first.
2 - If you turned off use_exif or have pics without exif, you could have 00 0000 dates.
3 - Some camera or scan software provide wrongly coded dates.

Tasks:
- When both are coded, if Exif is correctly coded it must override IPTC.
- When created_date has been set, il must be check before introduced in DB.
- Display (because old cases could exist) should test the date before display and avoid 00 0000 on any page.
(0003444)
svn (reporter)
2010.02.26 13:00

[Subversion] r4965 by plg on branch 2.0

-----[Subversion commit log]----------------------------------------------------
bug 1047 fixed: avoid warnings when the creation date is 0000-00-00 (which
happens when date_creation comes from corrupted EXIF)

bug 859 fixed: at display time only. Piwigo still inserts wrong date in the
database, to be fixed later.
(0003446)
svn (reporter)
2010.02.26 13:03

[Subversion] r4966 by plg on trunk

-----[Subversion commit log]----------------------------------------------------
merge r4965 from branch 2.0 to trunk

bug 1047 fixed: avoid warnings when the creation date is 0000-00-00 (which
happens when date_creation comes from corrupted EXIF)

bug 859 fixed: at display time only. Piwigo still inserts wrong date in the
database, to be fixed later.

- Issue History
Date Modified Username Field Change
2008.09.13 23:05 VDigital New Issue
2008.09.13 23:05 VDigital browser => any
2008.09.13 23:05 VDigital MySQL version => Any
2008.09.13 23:05 VDigital PHP version => Any
2008.09.13 23:05 VDigital Web server => Apache 1.3.x
2009.08.08 22:25 ddtddt Note Added: 0002808
2009.12.13 14:43 grum Note Added: 0003220
2009.12.13 15:27 ddtddt Relationship added related to 0001047
2009.12.13 21:57 VDigital Note Added: 0003228
2010.02.26 13:00 svn Checkin
2010.02.26 13:00 svn Note Added: 0003444
2010.02.26 13:03 svn Checkin
2010.02.26 13:03 svn Note Added: 0003446
2010.04.14 17:23 plg Assigned To => plg
2010.04.14 17:23 plg Status new => closed
2010.04.14 17:23 plg Resolution open => fixed
2010.04.14 17:23 plg Fixed in Version => 2.0.9


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Contact
Powered by Mantis Bugtracker