Piwigo Bugtracker

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000860 [Piwigo] installation & upgrade block have not tried 2008.09.15 11:51 2010.04.29 18:02
Reporter laurent_duretz View Status public  
Assigned To plg
Priority normal Resolution fixed Platform XAMPP 1.5.3a
Status closed   OS Windows XP SP2
Projection none   OS Version
ETA none Fixed in Version 2.1.0RC3 Product Version Butterfly 2
  Target Version 2.1.0RC3 Product Build
Summary 0000860: Fatal error at the beginning of installation
Description Directory _data is not created at this moment.
Refer the screenshot to see the detailed error
Steps To Reproduce
Additional Information
Tags No tags attached.
browser any
Database engine and version
PHP version
Web server
Attached Files png file icon crash.png [^] (11,465 bytes) 2008.09.15 11:51

- Relationships
has duplicate 0000854closed [Smarty] _data directory must be writable 

-  Notes
(0002807)
ddtddt (administrator)
2009.08.08 22:23

I believe we have done nothing for this

Done on something ?
(0003297)
mathiasm (manager)
2010.01.02 01:16

Maybe we should add a dummy file in tbhis folder in SVN so we'll have it in archive ?
(0003298)
ddtddt (administrator)
2010.01.02 01:19

yes I thinks to
(0003306)
plg (manager)
2010.01.06 00:04

mathiasm wrote:

> Maybe we should add a dummy file in tbhis folder in SVN so we'll have it in
> archive ?

Why a dummy file? Why not simply adding the directory _data and _data/templates_c ?
(0003307)
mathiasm (manager)
2010.01.06 09:31

dummy file: because some archivers doesn't uncompress empty directories.
(0003308)
nikrou (developer)
2010.01.06 09:44

> dummy file: because some archivers doesn't uncompress empty directories.

To prevent that problem, a usaually solution is to create an empty file in that directory:

_data/.empty for example.
(0003309)
plg (manager)
2010.01.06 10:12

I didn't know that nikrou, thank you for the information.

OK for _data/.empty

mkgetdir only checks for is_writable() and does not try to make the directory writable. Shouldn't we add a chmod? (this is what I do for pwg.images.add called by pLoader)
(0003320)
plg (manager)
2010.01.12 13:48

Shouldn't we create _data in tools/pwg_rel_create.sh instead?
(0003795)
plg (manager)
2010.04.26 23:49

The very first thing to do is to deliver a clear message, not a debug trace that only developers understand.

I take the point.
(0003811)
svn (reporter)
2010.04.28 18:11

[Subversion] r5985 by plg on trunk

-----[Subversion commit log]----------------------------------------------------
bug 860: display a more readable error when the _data directory is not writable
(0003820)
svn (reporter)
2010.04.29 16:43

[Subversion] r5998 by plg on trunk

-----[Subversion commit log]----------------------------------------------------
bug 860 related: if the directory doesn't exist (SVN users) first try to
create it. To avoid useless checks on filesystem (rvelices should
appreciate) a configuration variable tells if we have to check or not.
(0003821)
svn (reporter)
2010.04.29 18:02

[Subversion] r5999 by plg on trunk

-----[Subversion commit log]----------------------------------------------------
bug 860 related: don't try to update the configuration during install because
pwg_query is not available yet.

- Issue History
Date Modified Username Field Change
2008.09.15 11:51 laurent_duretz New Issue
2008.09.15 11:51 laurent_duretz File Added: crash.png
2008.09.15 11:51 laurent_duretz browser => any
2009.08.08 22:23 ddtddt Note Added: 0002807
2010.01.02 01:16 mathiasm Note Added: 0003297
2010.01.02 01:19 ddtddt Note Added: 0003298
2010.01.06 00:04 plg Note Added: 0003306
2010.01.06 09:31 mathiasm Note Added: 0003307
2010.01.06 09:44 nikrou Note Added: 0003308
2010.01.06 10:12 plg Note Added: 0003309
2010.01.12 13:48 plg Note Added: 0003320
2010.04.26 23:49 plg Note Added: 0003795
2010.04.26 23:49 plg Assigned To => plg
2010.04.26 23:49 plg Status new => assigned
2010.04.26 23:49 plg Target Version => 2.1.0RC3
2010.04.26 23:49 plg Description Updated
2010.04.28 18:11 svn Checkin
2010.04.28 18:11 svn Note Added: 0003811
2010.04.28 18:13 plg Status assigned => closed
2010.04.28 18:13 plg Resolution open => fixed
2010.04.28 18:13 plg Fixed in Version => 2.1.0RC3
2010.04.29 16:43 svn Checkin
2010.04.29 16:43 svn Note Added: 0003820
2010.04.29 18:02 svn Checkin
2010.04.29 18:02 svn Note Added: 0003821
2010.05.05 00:32 plg Relationship added has duplicate 0000854


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Contact
Powered by Mantis Bugtracker