Piwigo Bugtracker

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000861 [Piwigo] installation & upgrade tweak N/A 2008.09.17 14:05 2008.10.03 22:47
Reporter plg View Status public  
Assigned To plg
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 2.0.0RC2 Product Version
  Target Version 2.0.0 Product Build
Summary 0000861: upgrade feed: incoherent configuration by default
Description When installing a SVN trunk version of Piwigo, I have $conf['check_upgrade_feed'] = true BUT PHPWG_IN_UPGRADE is not defined but in include/common.inc.php:

if ($conf['check_upgrade_feed']
    and defined('PHPWG_IN_UPGRADE')
    and PHPWG_IN_UPGRADE)
{

This is due to my changes from bug:395

So it's quite confusing because $conf['check_upgrade_feed'] is true only for developers and beta testers (working directly with SVN) and by default, the upgrade feed can't work.

I propose to remove the mandatory PHPWG_IN_UPGRADE. This constant is useful for user upgrade (using upgrade.php) not for developer upgrade (upgrade_feed.php).
Steps To Reproduce
Additional Information
Tags No tags attached.
browser any
Database engine and version
PHP version
Web server Apache 1.3.x
Attached Files

- Relationships
related to 0000395closedplg Remove Install directory 

-  Notes
(0002370)
plg (manager)
2008.09.17 22:51

fixed on trunk Butterfly in [Subversion] r2544
(0002392)
plg (manager)
2008.09.29 23:24

completed on trunk Butterfly in [Subversion] r2625
(0002393)
rvelices (developer)
2008.09.29 23:34

is it ok to at least verify conf['check_upgrade_feed'] again in upgrade_feed.php ?

(I can do it if it's OK - the reason is I'm always the branch on my site and I dont want anyone to launch upgrade_feed.php)
(0002398)
plg (manager)
2008.10.03 11:25

rvelices wrote:

> (I can do it if it's OK - the reason is I'm always the branch on my site
> and I dont want anyone to launch upgrade_feed.php)

So on your "live" website, you are under SVN on the current branch. In your include/config_local.inc.php, you have $conf['check_upgrade_feed'] = false and you turn it on each time you know there is an upgrade. Right?

What do you think is smarter in upgrade_feed.php :

1. test $conf['check_upgrade_feed']
2. check is_admin()
3. both
(0002400)
rvelices (developer)
2008.10.03 12:06

You are right - I'm under svn current...

Only 1. is an option as there is no include common.inc.php - so no user is created etc...
(0002402)
plg (manager)
2008.10.03 22:46

fixed on trunk Butterfly in [Subversion] r2645

config_*.inc.php were not loaded themselves, so I have added them.

- Issue History
Date Modified Username Field Change
2008.09.17 14:05 plg New Issue
2008.09.17 14:05 plg Status new => assigned
2008.09.17 14:05 plg Assigned To => plg
2008.09.17 14:05 plg browser => any
2008.09.17 14:05 plg Web server => Apache 1.3.x
2008.09.17 14:06 plg Relationship added related to 0000395
2008.09.17 22:51 plg Note Added: 0002370
2008.09.17 22:51 plg Status assigned => closed
2008.09.17 22:51 plg Resolution open => fixed
2008.09.17 22:51 plg Fixed in Version => 2.0.0RC1
2008.09.29 23:24 plg Note Added: 0002392
2008.09.29 23:24 plg Fixed in Version 2.0.0RC1 => 2.0.0RC2
2008.09.29 23:34 rvelices Status closed => feedback
2008.09.29 23:34 rvelices Resolution fixed => reopened
2008.09.29 23:34 rvelices Note Added: 0002393
2008.09.30 06:48 rub Issue Monitored: rub
2008.10.03 11:25 plg Note Added: 0002398
2008.10.03 12:06 rvelices Note Added: 0002400
2008.10.03 21:32 plg Status feedback => assigned
2008.10.03 22:46 plg Note Added: 0002402
2008.10.03 22:47 plg Status assigned => closed
2008.10.03 22:47 plg Resolution reopened => fixed


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Contact
Powered by Mantis Bugtracker