Piwigo Bugtracker

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000889 [Piwigo] web API feature N/A 2008.10.07 23:54 2008.10.07 23:56
Reporter plg View Status public  
Assigned To plg
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 2.0.0RC3 Product Version 2.0.0RC2
  Target Version 2.0.0 Product Build
Summary 0000889: check existence of a photo before uploading
Description Instead of failing a pwg.images.add once the data are transfered (may take long with a poor connection and a big high resolution file) because the photo already exists (check based on file md5sum at the beginning of ws_images_add), it would be better to have a function that checks the existence of a list of md5sum in the database.
Steps To Reproduce
Additional Information
Tags No tags attached.
browser any
Database engine and version
PHP version
Web server Apache 1.3.x
Attached Files

- Relationships

-  Notes
(0002422)
plg (manager)
2008.10.07 23:56

added on trunk Butterfly in [Subversion] r2683

- Issue History
Date Modified Username Field Change
2008.10.07 23:54 plg New Issue
2008.10.07 23:54 plg Status new => assigned
2008.10.07 23:54 plg Assigned To => plg
2008.10.07 23:54 plg browser => any
2008.10.07 23:54 plg Web server => Apache 1.3.x
2008.10.07 23:56 plg Note Added: 0002422
2008.10.07 23:56 plg Status assigned => closed
2008.10.07 23:56 plg Resolution open => fixed
2008.10.07 23:56 plg version => 2.0.0RC2
2008.10.07 23:56 plg Fixed in Version => 2.0.0RC3


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Contact
Powered by Mantis Bugtracker