Piwigo Bugtracker

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000910 [Piwigo] other trivial always 2008.12.30 03:34 2009.07.05 12:22
Reporter pomPom View Status public  
Assigned To VDigital
Priority normal Resolution fixed Platform All
Status closed   OS All
Projection none   OS Version all
ETA none Fixed in Version 2.0.0 Product Version 2.0.0RC4
  Target Version Product Build None
Summary 0000910: Les balises meta keyword et meta description sont manquantes pour index.php et pictures.php
Description Les balises meta keyword et meta description sont manquantes pour index.php et pictures.php.
Ces informations étaient disponibles sur la version précédente. Est-ce un choix ou bien un oubli ?

Du point de vue référencement, ces deux éléments sont importants.
Steps To Reproduce
Additional Information
Tags No tags attached.
browser any
Database engine and version
PHP version
Web server Apache 1.3.x
Attached Files

- Relationships

-  Notes
(0002482)
VDigital (reporter)
2008.12.30 11:46

Previous release:
Tags were used for =>
<meta name="keywords" content="Art, Culture & Communities, Distant, High Resolution, Iles, Islands, Sculpture">

And Picture comment (description) was used for =>
<meta name="description" content="Moaïs on Easter Island (Chile) are monolithic human figures carved from rock on the Polynesian island of Rapa Nui.">



But currently, they are missing:
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<meta name="generator" content="Piwigo (aka PWG), see piwigo.org">
<title>PhpWebGallery demo :: Easter Island (CL)</title>
(0002483)
rvelices (developer)
2009.01.01 05:35

I think I more or less left out the tags from the previous release while migrating smarty because I have seen several discussions/opinions on what to put in those meta tags and what not so I believe it's better if plugins do it as they wish
(0002487)
VDigital (reporter)
2009.01.03 22:10

[Subversion] r3040 and [Subversion] r3041
(0002488)
VDigital (reporter)
2009.01.03 22:15

rvelices,

You are right but now they can use $conf['meta_ref'] = false; (noindex, nofollow).
And they can change description, keyword, author by using template-extension.

And they don't need to create a plugin which is a bit complex for non php developers.
(0002489)
VDigital (reporter)
2009.01.06 09:33

New: $conf['meta_ref'] is a new configuration parameter (Default true)
Meta tags for description, author, and keywords are generated,
except if meta robots "noindex" is forced (with some pages like search, recent cats, etc.).

In addition, $conf['meta_ref'] = false is forcing "noindex, nofollow".

[Subversion] r3040 and [Subversion] r3041

- Issue History
Date Modified Username Field Change
2008.12.30 03:34 pomPom New Issue
2008.12.30 03:34 pomPom browser => any
2008.12.30 03:34 pomPom Web server => Apache 1.3.x
2008.12.30 11:46 VDigital Note Added: 0002482
2008.12.30 11:46 VDigital Status new => confirmed
2009.01.01 05:35 rvelices Note Added: 0002483
2009.01.03 22:09 VDigital Assigned To => VDigital
2009.01.03 22:09 VDigital Status confirmed => resolved
2009.01.03 22:10 VDigital Note Added: 0002487
2009.01.03 22:10 VDigital Status resolved => feedback
2009.01.03 22:10 VDigital Resolution open => reopened
2009.01.03 22:15 VDigital Note Added: 0002488
2009.01.06 09:33 VDigital Note Added: 0002489
2009.01.06 09:33 VDigital Status feedback => resolved
2009.01.06 09:33 VDigital Fixed in Version => 2.0.0
2009.01.06 09:33 VDigital Resolution reopened => fixed
2009.07.05 12:22 plg Status resolved => closed


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Contact
Powered by Mantis Bugtracker