Piwigo Bugtracker

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000929 [Piwigo] template minor always 2009.03.04 09:00 2009.07.05 12:22
Reporter flipflip View Status public  
Assigned To Pat
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 2.1.0 Product Version 2.0.0
  Target Version Product Build
Summary 0000929: Separate HTML and PHP for the menubar
Description Following a french post on http://fr.piwigo.org/forum/viewtopic.php?id=15010 [^] it seems that the category list sent to the Smarty template already contains all the HTML structure while it should only send the data structure.
Steps To Reproduce
Additional Information --- Smarty template -----
{$block->data.MENU_CATEGORIES_CONTENT}
-----------------------

--- Result ---

      

  •     index.php?/category/1
        <span class="menuInfoCat" title=" 174 photos in this category">[174]</span>
        <img title="photos added in the last 7 days" src="template/alpha/theme/alpha/icon/recent.png" class="icon" style="border:0;height:16px;width:16px" alt="(!)" />
      


-----------------
Tags No tags attached.
browser any
Database engine and version
PHP version
Web server Apache 1.3.x
Attached Files

- Relationships

-  Notes
(0002508)
rvelices (developer)
2009.03.04 11:49

It is not going to be done easily because of the "recursivity" of data structure. The code is maybe too complex for smarty even though it is possible to write it in smarty
(0002509)
Pat (developer)
2009.03.04 23:00

Done in [Subversion] r3171

The code is not so much complex for smarty...

- Issue History
Date Modified Username Field Change
2009.03.04 09:00 flipflip New Issue
2009.03.04 09:00 flipflip browser => any
2009.03.04 09:00 flipflip Web server => Apache 1.3.x
2009.03.04 09:52 flipflip Issue Monitored: flipflip
2009.03.04 11:49 rvelices Note Added: 0002508
2009.03.04 22:59 Pat Status new => assigned
2009.03.04 22:59 Pat Assigned To => Pat
2009.03.04 23:00 Pat Note Added: 0002509
2009.03.05 00:48 plg Summary S├ęparation du contenue et du contant dans la menubar => Separate HTML and PHP for the menubar
2009.03.05 00:48 plg Description Updated
2009.03.05 00:48 plg Additional Information Updated
2009.03.16 18:09 Pat Status assigned => resolved
2009.03.16 18:09 Pat Fixed in Version => Colibri
2009.03.16 18:09 Pat Resolution open => fixed
2009.07.05 12:22 plg Status resolved => closed


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Contact
Powered by Mantis Bugtracker