Piwigo Bugtracker

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000953 [Piwigo] synchronization feature N/A 2009.03.19 19:24 2009.07.21 22:09
Reporter plg View Status public  
Assigned To plg
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 2.0.4 Product Version 2.0.0
  Target Version 2.0.2 Product Build
Summary 0000953: avoid fatal error when deleting a photo that doesn't exist on filesystem
Description When a photo is added with web API method pwg.images.add (as pLoader does), the administrator can delete it from Piwigo adminitrastion photo batch management screen.

The problem is that if the webmaster has removed uploaded files by hand, the "logical" deletion fails because the file cannot be found.

We should not fail: if the file does not exist, a part of the job has already been done, it's not a problem.

I would even say that an additionnal maintenance task "remove photos that don't have files anymore" would be useful (and don't tell me it would like a synchronization, because it's a very very light synchronization)
Steps To Reproduce
Additional Information
Tags No tags attached.
browser any
Database engine and version
PHP version
Web server Apache 1.3.x
Attached Files

- Relationships

-  Notes
(0002708)
svn (reporter)
2009.07.21 22:07

[Subversion] r3656 by plg on branch 2.0

-----[Subversion commit log]----------------------------------------------------
feature 953: avoid fatal error when delete a photo (added with pwg.images.add
API) and the file doesn't not exist on the filesystem.
(0002709)
svn (reporter)
2009.07.21 22:09

[Subversion] r3657 by plg on trunk

-----[Subversion commit log]----------------------------------------------------
merge r3656 from branch 2.0 to trunk

feature 953: avoid fatal error when delete a photo (added with pwg.images.add
API) and the file doesn't not exist on the filesystem.

- Issue History
Date Modified Username Field Change
2009.03.19 19:24 plg New Issue
2009.03.19 19:24 plg Status new => assigned
2009.03.19 19:24 plg Assigned To => plg
2009.03.19 19:24 plg browser => any
2009.03.19 19:24 plg Web server => Apache 1.3.x
2009.07.21 22:07 svn Checkin
2009.07.21 22:07 svn Note Added: 0002708
2009.07.21 22:09 svn Checkin
2009.07.21 22:09 svn Note Added: 0002709
2009.07.21 22:09 plg Status assigned => closed
2009.07.21 22:09 plg Resolution open => fixed
2009.07.21 22:09 plg Fixed in Version => 2.0.4


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Contact
Powered by Mantis Bugtracker