source: extensions/ContactForm/maintain.inc.php @ 18649

Revision 18649, 668 bytes checked in by mistic100, 7 years ago (diff)

correct upgrade procedure

Line 
1<?php
2if (!defined('PHPWG_ROOT_PATH')) die('Hacking attempt!');
3
4defined('CONTACT_FORM_ID') or define('CONTACT_FORM_ID', basename(dirname(__FILE__)));
5include_once(PHPWG_PLUGINS_PATH . CONTACT_FORM_ID . '/include/install.inc.php');
6
7function plugin_install() 
8{
9  contact_form_install();
10  define('contact_form_installed', true);
11}
12
13function plugin_activate()
14{
15  if (!defined('contact_form_installed'))
16  {
17    contact_form_install();
18  }
19}
20
21function plugin_uninstall() 
22{
23  global $prefixeTable;
24 
25  pwg_query('DELETE FROM `'. CONFIG_TABLE .'` WHERE param LIKE "ContactForm%" LIMIT 3;');
26  pwg_query('DROP TABLE IF EXISTS `'. $prefixeTable .'contact_form`;');
27}
28
29?>
Note: See TracBrowser for help on using the repository browser.