Changeset 10029


Ignore:
Timestamp:
04/04/11 01:15:59 (9 years ago)
Author:
patdenice
Message:

Display missing extension before major upgrade

Location:
extensions/autoupdate/branches/2.0
Files:
1 added
23 edited

Legend:

Unmodified
Added
Removed
  • extensions/autoupdate/branches/2.0/autoupdate.php

    r9623 r10029  
    120120    autoupdate_upgrade_to($_POST['upgrade_to'], $step); 
    121121  } 
     122 
     123  include_once(AUTOUPDATE_PATH.'include/autoupdate.class.php'); 
     124  $autoupdate = new autoupdate(); 
     125  $autoupdate->get_server_extensions($upgrade_to); 
     126  $template->assign('missing', $autoupdate->missing); 
    122127} 
    123128 
  • extensions/autoupdate/branches/2.0/language/ar_SA/plugin.lang.php

    r8589 r10029  
    3838$lang['Unable to dump database.'] = 'غير قادرعلى تفريق قاعدة البيانات.'; 
    3939 
     40/*TODO*/$lang['Following plugins may not be compatible with the new version of Piwigo:'] = 'Following plugins may not be compatible with the new version of Piwigo:'; 
     41/*TODO*/$lang['Following themes may not be compatible with the new version of Piwigo:'] = 'Following themes may not be compatible with the new version of Piwigo:'; 
     42/*TODO*/$lang['I decide to upgrade anyway'] = 'I decide to upgrade anyway'; 
    4043?> 
  • extensions/autoupdate/branches/2.0/language/cs_CZ/plugin.lang.php

    r6199 r10029  
    3838$lang['Unable to dump database.'] = 'Nelze provést výpis databáze.'; 
    3939 
     40/*TODO*/$lang['Following plugins may not be compatible with the new version of Piwigo:'] = 'Following plugins may not be compatible with the new version of Piwigo:'; 
     41/*TODO*/$lang['Following themes may not be compatible with the new version of Piwigo:'] = 'Following themes may not be compatible with the new version of Piwigo:'; 
     42/*TODO*/$lang['I decide to upgrade anyway'] = 'I decide to upgrade anyway'; 
    4043?> 
  • extensions/autoupdate/branches/2.0/language/da_DK/plugin.lang.php

    r6204 r10029  
    3838$lang['Unable to dump database.'] = 'Det er ikke muligt at dumpe databasen.'; 
    3939 
     40/*TODO*/$lang['Following plugins may not be compatible with the new version of Piwigo:'] = 'Following plugins may not be compatible with the new version of Piwigo:'; 
     41/*TODO*/$lang['Following themes may not be compatible with the new version of Piwigo:'] = 'Following themes may not be compatible with the new version of Piwigo:'; 
     42/*TODO*/$lang['I decide to upgrade anyway'] = 'I decide to upgrade anyway'; 
    4043?> 
  • extensions/autoupdate/branches/2.0/language/de_DE/plugin.lang.php

    r6196 r10029  
    3838$lang['Unable to dump database.'] = 'Es ist nicht möglich die Datenbank zu exportieren.'; 
    3939 
     40/*TODO*/$lang['Following plugins may not be compatible with the new version of Piwigo:'] = 'Following plugins may not be compatible with the new version of Piwigo:'; 
     41/*TODO*/$lang['Following themes may not be compatible with the new version of Piwigo:'] = 'Following themes may not be compatible with the new version of Piwigo:'; 
     42/*TODO*/$lang['I decide to upgrade anyway'] = 'I decide to upgrade anyway'; 
    4043?> 
  • extensions/autoupdate/branches/2.0/language/en_UK/plugin.lang.php

    r6196 r10029  
    3838$lang['Unable to dump database.'] = 'Unable to dump database.'; 
    3939 
     40$lang['Following plugins may not be compatible with the new version of Piwigo:'] = 'Following plugins may not be compatible with the new version of Piwigo:'; 
     41$lang['Following themes may not be compatible with the new version of Piwigo:'] = 'Following themes may not be compatible with the new version of Piwigo:'; 
     42$lang['I decide to upgrade anyway'] = 'I decide to upgrade anyway'; 
    4043?> 
  • extensions/autoupdate/branches/2.0/language/es_ES/plugin.lang.php

    r6196 r10029  
    3838$lang['Unable to dump database.'] = 'No se puede volcar la base de datos.'; 
    3939 
     40/*TODO*/$lang['Following plugins may not be compatible with the new version of Piwigo:'] = 'Following plugins may not be compatible with the new version of Piwigo:'; 
     41/*TODO*/$lang['Following themes may not be compatible with the new version of Piwigo:'] = 'Following themes may not be compatible with the new version of Piwigo:'; 
     42/*TODO*/$lang['I decide to upgrade anyway'] = 'I decide to upgrade anyway'; 
    4043?> 
  • extensions/autoupdate/branches/2.0/language/fr_FR/plugin.lang.php

    r6196 r10029  
    3838$lang['Unable to dump database.'] = 'Impossible de sauvegarder la base de données.'; 
    3939 
     40$lang['Following plugins may not be compatible with the new version of Piwigo:'] = 'Les plugins suivants ne seront peut-être pas compatibles avec la nouvelle version de Piwigo:'; 
     41$lang['Following themes may not be compatible with the new version of Piwigo:'] = 'Les thèmes suivants ne seront peut-être pas compatibles avec la nouvelle version de Piwigo:'; 
     42$lang['I decide to upgrade anyway'] = 'Je décide de migrer quand même'; 
    4043?> 
  • extensions/autoupdate/branches/2.0/language/hr_HR/plugin.lang.php

    r6242 r10029  
    3838$lang['Unable to dump database.'] = 'Nemoguće pražnjenje baze podataka.'; 
    3939 
     40/*TODO*/$lang['Following plugins may not be compatible with the new version of Piwigo:'] = 'Following plugins may not be compatible with the new version of Piwigo:'; 
     41/*TODO*/$lang['Following themes may not be compatible with the new version of Piwigo:'] = 'Following themes may not be compatible with the new version of Piwigo:'; 
     42/*TODO*/$lang['I decide to upgrade anyway'] = 'I decide to upgrade anyway'; 
    4043?> 
  • extensions/autoupdate/branches/2.0/language/hu_HU/plugin.lang.php

    r6211 r10029  
    3939$lang['Unable to dump database.'] = 'Nem lehet biztonsági másolatot készíteni az adatbázisról.'; 
    4040 
     41/*TODO*/$lang['Following plugins may not be compatible with the new version of Piwigo:'] = 'Following plugins may not be compatible with the new version of Piwigo:'; 
     42/*TODO*/$lang['Following themes may not be compatible with the new version of Piwigo:'] = 'Following themes may not be compatible with the new version of Piwigo:'; 
     43/*TODO*/$lang['I decide to upgrade anyway'] = 'I decide to upgrade anyway'; 
    4144?> 
  • extensions/autoupdate/branches/2.0/language/it_IT/plugin.lang.php

    r6344 r10029  
    3838$lang['Unable to dump database.'] = 'Impossibile eseguire il salvataggio del database.'; 
    3939 
     40/*TODO*/$lang['Following plugins may not be compatible with the new version of Piwigo:'] = 'Following plugins may not be compatible with the new version of Piwigo:'; 
     41/*TODO*/$lang['Following themes may not be compatible with the new version of Piwigo:'] = 'Following themes may not be compatible with the new version of Piwigo:'; 
     42/*TODO*/$lang['I decide to upgrade anyway'] = 'I decide to upgrade anyway'; 
    4043?> 
  • extensions/autoupdate/branches/2.0/language/ja_JP/plugin.lang.php

    r6375 r10029  
    3838$lang['Unable to dump database.'] = 'ダンプデータベースができません。'; 
    3939 
     40/*TODO*/$lang['Following plugins may not be compatible with the new version of Piwigo:'] = 'Following plugins may not be compatible with the new version of Piwigo:'; 
     41/*TODO*/$lang['Following themes may not be compatible with the new version of Piwigo:'] = 'Following themes may not be compatible with the new version of Piwigo:'; 
     42/*TODO*/$lang['I decide to upgrade anyway'] = 'I decide to upgrade anyway'; 
    4043?> 
  • extensions/autoupdate/branches/2.0/language/ka_GE/plugin.lang.php

    r7019 r10029  
    3939$lang['Unable to dump database.'] = 'შეუძლებელია მონაცემთა ბაზის წაშლა.'; 
    4040 
     41/*TODO*/$lang['Following plugins may not be compatible with the new version of Piwigo:'] = 'Following plugins may not be compatible with the new version of Piwigo:'; 
     42/*TODO*/$lang['Following themes may not be compatible with the new version of Piwigo:'] = 'Following themes may not be compatible with the new version of Piwigo:'; 
     43/*TODO*/$lang['I decide to upgrade anyway'] = 'I decide to upgrade anyway'; 
    4144?> 
  • extensions/autoupdate/branches/2.0/language/lv_LV/plugin.lang.php

    r7813 r10029  
    3838$lang['Unable to dump database.'] = 'Nevar izveidot datubāzes dampu.'; 
    3939 
     40/*TODO*/$lang['Following plugins may not be compatible with the new version of Piwigo:'] = 'Following plugins may not be compatible with the new version of Piwigo:'; 
     41/*TODO*/$lang['Following themes may not be compatible with the new version of Piwigo:'] = 'Following themes may not be compatible with the new version of Piwigo:'; 
     42/*TODO*/$lang['I decide to upgrade anyway'] = 'I decide to upgrade anyway'; 
    4043?> 
  • extensions/autoupdate/branches/2.0/language/nl_NL/plugin.lang.php

    r6196 r10029  
    3838$lang['Unable to dump database.'] = 'Het is niet mogelijk om de database te dumpen.'; 
    3939 
     40/*TODO*/$lang['Following plugins may not be compatible with the new version of Piwigo:'] = 'Following plugins may not be compatible with the new version of Piwigo:'; 
     41/*TODO*/$lang['Following themes may not be compatible with the new version of Piwigo:'] = 'Following themes may not be compatible with the new version of Piwigo:'; 
     42/*TODO*/$lang['I decide to upgrade anyway'] = 'I decide to upgrade anyway'; 
    4043?> 
  • extensions/autoupdate/branches/2.0/language/no_NO/plugin.lang.php

    r8567 r10029  
    3737$lang['Unable to send template directory.'] = 'Ikke i stand til å sende mal mappe.'; 
    3838$lang['Unable to dump database.'] = 'Ikke i stand til å tømme database.'; 
     39/*TODO*/$lang['Following plugins may not be compatible with the new version of Piwigo:'] = 'Following plugins may not be compatible with the new version of Piwigo:'; 
     40/*TODO*/$lang['Following themes may not be compatible with the new version of Piwigo:'] = 'Following themes may not be compatible with the new version of Piwigo:'; 
     41/*TODO*/$lang['I decide to upgrade anyway'] = 'I decide to upgrade anyway'; 
    3942?> 
  • extensions/autoupdate/branches/2.0/language/pl_PL/plugin.lang.php

    r6200 r10029  
    3838$lang['Unable to dump database.'] = 'Zrzucenie bazy danych nie powiodło się.'; 
    3939 
     40/*TODO*/$lang['Following plugins may not be compatible with the new version of Piwigo:'] = 'Following plugins may not be compatible with the new version of Piwigo:'; 
     41/*TODO*/$lang['Following themes may not be compatible with the new version of Piwigo:'] = 'Following themes may not be compatible with the new version of Piwigo:'; 
     42/*TODO*/$lang['I decide to upgrade anyway'] = 'I decide to upgrade anyway'; 
    4043?> 
  • extensions/autoupdate/branches/2.0/language/pt_PT/plugin.lang.php

    r8930 r10029  
    3838$lang['Unable to dump database.'] = 'Impossível descarregar base de dados.'; 
    3939 
     40/*TODO*/$lang['Following plugins may not be compatible with the new version of Piwigo:'] = 'Following plugins may not be compatible with the new version of Piwigo:'; 
     41/*TODO*/$lang['Following themes may not be compatible with the new version of Piwigo:'] = 'Following themes may not be compatible with the new version of Piwigo:'; 
     42/*TODO*/$lang['I decide to upgrade anyway'] = 'I decide to upgrade anyway'; 
    4043?> 
  • extensions/autoupdate/branches/2.0/language/ru_RU/plugin.lang.php

    r6196 r10029  
    3838/*TODO*/$lang['Unable to dump database.'] = 'Unable to dump database.'; 
    3939 
     40/*TODO*/$lang['Following plugins may not be compatible with the new version of Piwigo:'] = 'Following plugins may not be compatible with the new version of Piwigo:'; 
     41/*TODO*/$lang['Following themes may not be compatible with the new version of Piwigo:'] = 'Following themes may not be compatible with the new version of Piwigo:'; 
     42/*TODO*/$lang['I decide to upgrade anyway'] = 'I decide to upgrade anyway'; 
    4043?> 
  • extensions/autoupdate/branches/2.0/language/sk_SK/plugin.lang.php

    r7041 r10029  
    3838$lang['Unable to dump database.'] = 'Nemôžem odpojiť databázu.'; 
    3939 
     40/*TODO*/$lang['Following plugins may not be compatible with the new version of Piwigo:'] = 'Following plugins may not be compatible with the new version of Piwigo:'; 
     41/*TODO*/$lang['Following themes may not be compatible with the new version of Piwigo:'] = 'Following themes may not be compatible with the new version of Piwigo:'; 
     42/*TODO*/$lang['I decide to upgrade anyway'] = 'I decide to upgrade anyway'; 
    4043?> 
  • extensions/autoupdate/branches/2.0/language/vi_VN/plugin.lang.php

    r7110 r10029  
    3838$lang['Unable to dump database.'] = 'Không thể tạo bản sao cơ sở dữ liệu.'; 
    3939 
     40/*TODO*/$lang['Following plugins may not be compatible with the new version of Piwigo:'] = 'Following plugins may not be compatible with the new version of Piwigo:'; 
     41/*TODO*/$lang['Following themes may not be compatible with the new version of Piwigo:'] = 'Following themes may not be compatible with the new version of Piwigo:'; 
     42/*TODO*/$lang['I decide to upgrade anyway'] = 'I decide to upgrade anyway'; 
    4043?> 
  • extensions/autoupdate/branches/2.0/language/zh_CN/plugin.lang.php

    r6196 r10029  
    3838$lang['Unable to dump database.'] = '不能转存数据库.'; 
    3939 
     40/*TODO*/$lang['Following plugins may not be compatible with the new version of Piwigo:'] = 'Following plugins may not be compatible with the new version of Piwigo:'; 
     41/*TODO*/$lang['Following themes may not be compatible with the new version of Piwigo:'] = 'Following themes may not be compatible with the new version of Piwigo:'; 
     42/*TODO*/$lang['I decide to upgrade anyway'] = 'I decide to upgrade anyway'; 
    4043?> 
  • extensions/autoupdate/branches/2.0/template/autoupdate.tpl

    r9981 r10029  
    1717    jQuery('.autoupdate_bar').show(); 
    1818        }); 
     19  jQuery('[name="understand"]').click(function() {ldelim} 
     20    jQuery('[name="submit"]').attr('disabled', !this.checked); 
     21  }); 
    1922}); 
    2023</script> 
     
    8790<fieldset> 
    8891  <legend>{'autoupdate_step_'|cat:$i|@translate}</legend> 
    89   <p><input type="submit" name="submit" value="{'Upgrade to Piwigo %s'|@translate|@sprintf:$UPGRADE_TO}"></p> 
     92  {if !empty($missing.plugins)} 
     93  <p><i>{'Following plugins may not be compatible with the new version of Piwigo:'|@translate}</i></p> 
     94  <p><ul>{foreach from=$missing.plugins item=plugin}<li><a href="{$plugin.uri}" class="externalLink">{$plugin.name}</a></li>{/foreach}</ul><br></p> 
     95  {/if} 
     96  {if !empty($missing.themes)} 
     97  <p><i>{'Following themes may not be compatible with the new version of Piwigo:'|@translate}</i></p> 
     98  <p><ul>{foreach from=$missing.themes item=theme}<li><a href="{$theme.uri}" class="externalLink">{$theme.name}</a></li>{/foreach}</ul><br></p> 
     99  {/if} 
     100  <p> 
     101  {if !empty($missing.plugins) or !empty($missing.themes)} 
     102  <p><label><input type="checkbox" name="understand"> &nbsp;{'I decide to upgrade anyway'|@translate}</label></p> 
     103  {/if} 
     104  <p><input type="submit" name="submit" value="{'Upgrade to Piwigo %s'|@translate|@sprintf:$UPGRADE_TO}" {if !empty($missing.plugins) or !empty($missing.themes)}disabled="disabled"{/if}> 
     105  </p> 
    90106  <p class="autoupdate_bar" style="display:none;">&nbsp; {'Update in progress...'|@translate}<br><img src="plugins/autoupdate/template/ajax-loader-bar.gif"></p> 
    91107</fieldset> 
Note: See TracChangeset for help on using the changeset viewer.