Changeset 29307


Ignore:
Timestamp:
08/27/14 20:10:49 (5 years ago)
Author:
mistic100
Message:

compatibility 2.7

Location:
extensions/AntiAspi
Files:
1 added
1 deleted
1 edited

Legend:

Unmodified
Added
Removed
  • extensions/AntiAspi/main.inc.php

    r28323 r29307  
    1919define('ANTIASPI_ID', basename(dirname(__FILE__))); 
    2020define('ANTIASPI_PATH', PHPWG_PLUGINS_PATH.ANTIASPI_ID.'/'); 
    21 define('ANTIASPI_VERSION', 'auto'); 
    2221define('ANTIASPI_TABLE' , $prefixeTable . 'antiaspi_ip_ban'); 
    2322define('ANTIASPI_LOG_TABLE' , $prefixeTable . 'antiaspi_log'); 
    24  
    25 // init the plugin 
    26 add_event_handler('init', 'antiaspi_init'); 
    27  
    28 /** 
    29  * plugin initialization 
    30  *   - check for upgrades 
    31  *   - load language 
    32  */ 
    33 function antiaspi_init() 
    34 { 
    35   // apply upgrade if needed 
    36   include_once(ANTIASPI_PATH.'maintain.inc.php'); 
    37   $maintain = new AntiAspi_maintain(ANTIASPI_ID); 
    38   $maintain->autoUpdate(ANTIASPI_VERSION, 'install'); 
    39 } 
    4023 
    4124add_event_handler('loc_end_section_init', 'antiaspi'); 
     
    139122  pwg_query($query); 
    140123} 
    141 ?> 
Note: See TracChangeset for help on using the changeset viewer.