Changeset 3679


Ignore:
Timestamp:
07/26/09 15:19:41 (10 years ago)
Author:
grum
Message:

Update Grum Plugind Classes to 2.0.3
Minor changes (bug about the config loader from then common_plugin class)

Location:
extensions/grum_plugins_classes-2
Files:
2 edited

Legend:

Unmodified
Added
Removed
  • extensions/grum_plugins_classes-2/common_plugin.class.inc.php

    r3395 r3679  
    22/* ----------------------------------------------------------------------------- 
    33  class name: common_plugin 
    4   class version: 2.0 
    5   date: 2008-07-13 
     4  class version: 2.0.1 
     5  date: 2009-07-24 
    66 
    77  ------------------------------------------------------------------------------ 
     
    3737  2.0.0     - 2008-07-13 
    3838              migrate to piwigo 2.0 ; use of PHP5 classes possibilities 
     39  2.0.1     - 2009-07-24 
     40             config loader : better management for arrays items 
    3941 
    4042  --------------------------------------------------------------------------- */ 
     
    104106        reset($config); 
    105107        while (list($key, $val) = each($config))  
    106         { $this->my_config[$key] =$val; } 
     108        {  
     109          if(is_array($val)) 
     110          { 
     111            foreach($val as $key2 => $val2) 
     112            { 
     113              $this->my_config[$key][$key2]=$val2;  
     114            } 
     115          } 
     116          else 
     117          { 
     118            $this->my_config[$key] =$val;  
     119          } 
     120        } 
    107121      } 
    108122    } 
  • extensions/grum_plugins_classes-2/main.inc.php

    r3395 r3679  
    22/* 
    33Plugin Name: Grum Plugins Classes.2 
    4 Version: 2.0.2 
     4Version: 2.0.3 
    55Description: Collection de classes partagées entre mes plugins (existants, ou à venir) / Partaged classes between my plugins (actuals or futures) 
    66Plugin URI: http://phpwebgallery.net/ext/extension_view.php?eid=199 
     
    2121:: HISTORY 
    2222  2.0.0       - 2008/07/20  +convert classes for piwigo 2.0 
    23   2.0.1       - 2008/12/28  +convert classe tables.class.inc to php5  
     23  2.0.1       - 2008/12/28  +convert classe tables.class.inc to php5 
    2424  2.0.2       - 2009/04/26  +add set_options/get_options for pages_navigation class 
    25                             +add option to set first/prev/next/last textes  
     25                            +add option to set first/prev/next/last textes 
     26  2.0.3       - 2009/07/24  +modify common_plugin class config loader (r2.0.1) 
    2627 
    2728:: TO DO 
     
    3233Classes version for this package 
    3334    ajax.class.php -v2.0 + ajax.js -v1.0.1 
    34     common_plugin.class.php -v2.0 
     35    common_plugin.class.php -v2.0.1 
    3536    css.class.php -v2.0 
    3637    pages_navigation.class.php -v1.0 
     
    5152define('GPC_PATH' , PHPWG_PLUGINS_PATH . GPC_DIR . '/'); 
    5253 
    53 define('GPC_VERSION' , '2.0.2'); 
     54define('GPC_VERSION' , '2.0.3'); 
    5455 
    5556/* 
    56   this function return true if class release if greater than needed by the plugin 
     57  this function return true if class release if greater or equal than needed by the plugin 
    5758*/ 
    5859function checkGPCRelease($major, $minor, $minor2) 
    5960{ 
    6061  $release = explode(".", GPC_VERSION); 
    61   if(($release[0]>=$major)&&($release[1]>=$minor)&&($release[2]>=$minor2)) 
     62 
     63  if(($release[0]>$major) || 
     64     ($release[0]==$major)&&($release[1]>$minor) || 
     65     ($release[0]==$major)&&($release[1]==$minor)&&($release[2]>=$minor2)) 
    6266  { 
    6367    return(true); 
Note: See TracChangeset for help on using the changeset viewer.