Changeset 7576 for extensions/GMaps


Ignore:
Timestamp:
11/02/10 18:43:50 (9 years ago)
Author:
grum
Message:

fix bug:1996 - Incompatibility with PHP prior than 5.2.2

Location:
extensions/GMaps
Files:
3 edited

Legend:

Unmodified
Added
Removed
  • extensions/GMaps/gmaps_pip.class.inc.php

    r7567 r7576  
    117117 
    118118    $mapParams=array(); 
    119     if(preg_match_all('/\[gmaps=(?:id:(?<id>\d+);|width:(?<width>\d+);|height:(?<height>\d+);|markerImg:(?<markerImg>[a-z0-9\-\._]+);|kmlId:(?<kmlId>\d+);|kmlUrl:"(?<kmlUrl>.+)";|allowBubble:(?<allowBubble>y|n);|kmlZoom:(?<kmlZoom>y|n);|markerVisible:(?<markerVisible>y|n);)+\]/i',$desc,$mapParams,PREG_SET_ORDER)>0) 
     119    if(preg_match_all('/\[gmaps=(?:id:(?P<id>\d+);|width:(?P<width>\d+);|height:(?P<height>\d+);|markerImg:(?P<markerImg>[a-z0-9\-\._]+);|kmlId:(?P<kmlId>\d+);|kmlUrl:"(?P<kmlUrl>.+)";|allowBubble:(?P<allowBubble>y|n);|kmlZoom:(?P<kmlZoom>y|n);|markerVisible:(?P<markerVisible>y|n);)+\]/i',$desc,$mapParams,PREG_SET_ORDER)>0) 
    120120    { 
    121121 
     
    132132 
    133133      $desc = preg_replace( 
    134         '/\[gmaps=(?:id:(?<id>\d+);|width:(?<width>\d+);|height:(?<height>\d+);|markerImg:(?<markerImg>[a-z0-9\-\._]+);|kmlId:(?<kmlId>\d+);|kmlUrl:"(?<kmlUrl>.+)";|allowBubble:(?<allowBubble>y|n);|kmlZoom:(?<kmlZoom>y|n);|markerVisible:(?<markerVisible>y|n);)+\]/i', 
     134        '/\[gmaps=(?:id:(?P<id>\d+);|width:(?P<width>\d+);|height:(?P<height>\d+);|markerImg:(?P<markerImg>[a-z0-9\-\._]+);|kmlId:(?P<kmlId>\d+);|kmlUrl:"(?P<kmlUrl>.+)";|allowBubble:(?P<allowBubble>y|n);|kmlZoom:(?P<kmlZoom>y|n);|markerVisible:(?P<markerVisible>y|n);)+\]/i', 
    135135        "<div class='gmapsMarkup' id='gmapsMarkupId$1'></div>", $desc); 
    136136 
  • extensions/GMaps/gmaps_version.inc.php

    r7562 r7576  
    1515  if (!defined('PHPWG_ROOT_PATH')) die('Hacking attempt!'); 
    1616 
    17   define('GMAPS_VERSION',  '1.2.1'); 
    18   define('GMAPS_VERSION2', '01.02.01'); 
     17  define('GMAPS_VERSION',  '1.2.2'); 
     18  define('GMAPS_VERSION2', '01.02.02'); 
    1919  define('GMAPS_GPC_NEEDED', '3.3.2'); 
    2020  define('GMAPS_AMD_NEEDED', '0.5.2'); //advanced metadata plugin is needed 
  • extensions/GMaps/main.inc.php

    r7568 r7576  
    22/* 
    33Plugin Name: GMaps 
    4 Version: 1.2.1 
     4Version: 1.2.2 
    55Description: Display and manage (google) maps 
    66Plugin URI: http://phpwebgallery.net/ext/extension_view.php?eid=454 
     
    7575|         |            |     kml files 
    7676|         |            | 
     77| 1.2.2   | 2010-11-02 | * mantis bug:1996 
     78|         |            |   . Incompatibility with PHP prior than 5.2.2 
     79|         |            | 
     80|         |            | 
     81|         |            | 
     82|         |            | 
     83|         |            | 
    7784 
    7885 
Note: See TracChangeset for help on using the changeset viewer.