Announcement

#1 2009-02-17 19:16:33

Jason
Guest

Upgrade problem...

I'm trying to do an upgrade from an earlier version of the gallery.

After uploading the files, the installation script runs and returns the following error:

Piwigo requires PHP 5 or above

...the only thing is, the server is running PHP 5.2.8.

Does anyone know what could be happening?

Thanks!

~ Jason

 

#2 2009-02-28 12:58:27

titounet
Member
Vic-Fezensac
2009-02-28
3

Re: Upgrade problem...

Hello,

Same problem for me.

Last edited by titounet (2009-02-28 12:58:41)

Offline

 

#3 2009-02-28 15:05:05

P@t
Piwigo Team
Nice
2007-06-13
4098

Re: Upgrade problem...

If this is true (that I'm not sure at all!), try to remove from upgrade.php file, line 24:

//check php version
if (version_compare(PHP_VERSION, '5', '<'))
{
  die('Piwigo requires PHP 5 or above.');
}


P@t

Offline

 

#4 2009-02-28 17:13:22

VDigital
Former Piwigo Team
Paris (FR)
2005-05-04
17680

Re: Upgrade problem...

Or just remove the "die" line.


I will like to know what is the value of PHP_VERSION.
Tell us when it will run.
We will ask you some details.


Piwigo.com: Start and run your own photo gallery. Signup and get 30 days to try for free, no commitment.
8-)

Offline

 

#5 2009-02-28 18:01:33

titounet
Member
Vic-Fezensac
2009-02-28
3

Re: Upgrade problem...

OK thanks, , a special line needed in the .htaccess to active PHP 5 with my provider(OVH).
upgrade OK (from PWG 1.7.3).

No problem with the front, but 2 problems withe the admin section :
- errors when I try to active plugin
- indisponibilty message from the host

Last edited by titounet (2009-03-01 00:19:59)

Offline

 

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2018 · Contact