Announcement

#1 2010-01-10 22:25:14

HowardCSJ
Member
2008-01-15
50

Images and thumbnails lost

In one of the main categories (including 4-5 sub-categories) of my Gallery, Piwigo is not showing either the thumbnails or the pictures (the captions and the tags etc are still there), but I can see from FileZilla that both the images and the thumbnails are in place.  I have tried deleting the images and the thumbnails, re-loading them, and re-creating the thumbnails, but they still aren't visible. In the other two main categoies, everything is working fine. What has gone wrong with the first category?

Offline

 

#2 2010-01-10 22:55:42

ddtddt
Piwigo Team
Quetigny - France
2007-07-27
6707

Re: Images and thumbnails lost

Have you. htaccess files in the directory ?


You love Piwigo so don't hesitate to participate, learn more on the "Contribute to Piwigo" page. If you don't have much time for contribution, you can also help the project with a donation.

Offline

 

#3 2010-01-11 09:15:41

HowardCSJ
Member
2008-01-15
50

Re: Images and thumbnails lost

Thanks for this quick reply: I'm afraid you'll have to tel me what you mean by .htaccess files, and where I should look for them.

Offline

 

#4 2010-01-11 10:09:52

VDigital
Former Piwigo Team
Paris (FR)
2005-05-04
17680

Re: Images and thumbnails lost

Howard,

Just a strong advice: Do not synchronise currently till your issue is not solved!

Give us a link to your gallery.
Copy/paste the "Distant site" page maybe (hide part of URLs if some need to be confidentiel).

.htaccess : it could be in the website root directory or any picture directory.


Piwigo.com: Start and run your own photo gallery. Signup and get 30 days to try for free, no commitment.
8-)

Offline

 

#5 2010-01-11 11:23:16

HowardCSJ
Member
2008-01-15
50

Re: Images and thumbnails lost

Hello Vincent -

I'm very pleased that you're willing to help me again.  The gallery in question is a new one (the 3rd I've created).  It's at http://www.ludmillajordanova.com/gallery/index.php .  The problem is with the category called "The Look of the Past".

I'm afraid I have synchronised since the problem arose - as part of my own efforts to solve the problem.

I've looked through the gallery section in Filezilla, and haven't found any files called .htaccess

I don't mind giving you the .ftp access codes, for speed and simplicity - would you like to givbe me a private e-mil address that I can send them to?

All the best,

Howard

Offline

 

#6 2010-01-14 15:02:30

VDigital
Former Piwigo Team
Paris (FR)
2005-05-04
17680

Re: Images and thumbnails lost

After several emails with Howard, the issue is still there... Obviously your help is welcome.
I spent one hour last night to try several changes.

1 - I should say there is no .htaccess at all from the root to any subfolder in ./galleries

2 - I check filenames and they are well constructed
By several change, I obtain a view on the Chapter 2 pictures.
In "The Look of the Past" (dirname "Illustrations_of_LotP") category you can find Chapter 2 ("Chap02").
http://www.ludmillajordanova.com/gallery/galleries/Illustrations_of_LotP/Chap02/thumbnail/TN-02-315.jpg
http://www.ludmillajordanova.com/gallery/galleries/Illustrations_of_LotP/Chap02/thumbnail/TN-02-315.jpg
As you can see, other chapters have no available pictures or thumbnails.
http://www.ludmillajordanova.com/gallery/galleries/Illustrations_of_LotP/Chap06/thumbnail/TN-FoM007.jpg
Resulting in:
http://www.ludmillajordanova.com/gallery/galleries/Illustrations_of_LotP/Chap06/thumbnail/TN-FoM007.jpg

For your information, I required Howard to make a full backup of the Database.
By a non provided process, I renamed the dirname ("Illustrations_of_LotP") several times.
The original directory name was "TLOTP".
I suspected an issue with full UPPERCASE categories (Not proven).
I moved Chap02/Chap0x... in another directory (again a non described process). Nothing changed.
After several changed, Chap02 became visible as it is currently.

I upgraded his gallery manually because I found some wrong labels in admin. The gallery is now in 2.0.7 (last full transfer was without error).

I used RV DB Integrity and all controls are passed.
I have an FTP client access and is gallery and pictures are all accessible and readable.
I used several synchro stages (all files and directories) were just updated (I mean recognized).
Files are recognized as existing but could not be displayed (even if you were in admin).
I used several tips to diagnose the cause without any positive results.

I still have some checks to do on his website tonight:
- Like checking chmods... maybe here it is (a difference between read/exec).
I will see and come back.

If you have any idea, again you're welcome.
Many thanks in advance.

I proposed to offer a view to the whole team in our private forum, but ...

Howard wrote:

Bonjour Vincent, et encore un grand merci!



I was away from the computer most of yesterday, but have picked up your several messages now. I can see that Chapter 2 of TLOTP is displaying as it should, which is good progress, though I can’t pretend to understand what went wrong,ot how you have been able to correct it.  Chapter 6, as far as I can see, still isn’t displaying.



By all means share this case with the private forum – the more people who know about this problem the better!



Do I understand that you have updated the gallery to the latest release of Piwigo ?  If so, thanks again – it was something I was intending to do.



Happy to wait to hear from you again ...



Howard


Piwigo.com: Start and run your own photo gallery. Signup and get 30 days to try for free, no commitment.
8-)

Offline

 

#7 2010-01-14 15:21:11

tosca
Former Piwigo Team
Cévennes (France)
2006-09-23
567

Re: Images and thumbnails lost

VDigital wrote:

If you have any idea, again you're welcome.
Many thanks in advance.

May be a completely dumb idea ... but if is always the same pictures/thumbnails that don't appear, couldn't the jpg has been corrupted? Did you try to re-upload some of them? Or put others in their place, with the same name?

EDIT: just read again what you've written about chapter 2 ... do you mean you've only moved the pictures around, till they suddenly appear? Nothing else?

Last edited by tosca (2010-01-14 15:28:05)


My galleries : Photos, Watercolours, Recipes

Offline

 

#8 2010-01-14 15:31:24

Gotcha
Piwigo Team
Pourrières (83) [FR]
2007-03-14
604

Offline

 

#9 2010-01-14 16:17:24

tosca
Former Piwigo Team
Cévennes (France)
2006-09-23
567

Re: Images and thumbnails lost

Gotcha wrote:

http://www.ludmillajordanova.com/gallery/galleries/Illustrations_of_LotP/Chap06/thumbnail/TN-FoM007.jpg

Why are we redirected?

Compare :
http://www.ludmillajordanova.com/gallery/fake.jpg

??? Got this in either case (see screecopy)
Maybe VDigital has changed something in the meantime, the site seems to be not available any longer ...


Uploaded Images

Last edited by tosca (2010-01-14 16:18:58)


My galleries : Photos, Watercolours, Recipes

Offline

 

#10 2010-01-14 17:38:24

Eric
Piwigo Team
VALENCE (FR)
2005-03-25
1767

Re: Images and thumbnails lost

Hi !

I'll agree with Tosca : JPG files could be corrupted or not in JPG real format. Maybe a proprietary (from the camera) format ?
These pictures could be well viewed on a PC because graphic filters in several picture viewer softwares are strong enouth to decode them. But not the embedded apache / php  modules.

This could explain why all the pictures (TN as well as normal sized and HD ones) are not displayed. TN pictures are set from the HD / normal sized pics. If they are corrupted, TN will be corrupted too.

This issue remembers me another one similar but I can't remember / find the related topic (if there is one).

Offline

 

#11 2010-01-14 19:25:56

VDigital
Former Piwigo Team
Paris (FR)
2005-05-04
17680

Re: Images and thumbnails lost

VDigital wrote:

I still have some checks to do on his website tonight:
- Like checking chmods... maybe here it is (a difference between read/exec).
I will see and come back.

I only review some files/dir authorisations (chmod 744 => 755).

The Look of the Past / Chapter 6: The Family of Man | Ludmilla Jordanova

Thanks to those who gave me their view, by email or in this topic.

Howard,

I will remove my debuging template-extension.
I let you solve other files and directories.

;-)


Piwigo.com: Start and run your own photo gallery. Signup and get 30 days to try for free, no commitment.
8-)

Offline

 

#12 2010-01-14 20:13:34

tosca
Former Piwigo Team
Cévennes (France)
2006-09-23
567

Re: Images and thumbnails lost

VDigital wrote:

I will remove my debuging template-extension.
I let you solve other files and directories.

??
Did you eventually find out what the problem was?

VDigital wrote:

I only review some files/dir authorisations (chmod 744 => 755).

Do you mean it was only a permission matter,

Last edited by tosca (2010-01-14 20:55:21)


My galleries : Photos, Watercolours, Recipes

Offline

 

#13 2010-01-14 23:34:08

VDigital
Former Piwigo Team
Paris (FR)
2005-05-04
17680

Re: Images and thumbnails lost

Absolutely
;-)


Piwigo.com: Start and run your own photo gallery. Signup and get 30 days to try for free, no commitment.
8-)

Offline

 

#14 2010-01-15 21:02:42

mathiasm
Former Piwigo Team
2006-02-06
2648

Re: Images and thumbnails lost

I don't understand why php need execution rights on files. But he needs it on directories.

Offline

 

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2018 · Contact