Announcement

#1 2010-05-23 21:11:05

ppat
Member
2009-08-25
74

[resolved] Upgrade Errors

Hi Team

How do I resolve following errors during upgrade on ubuntu server ? Upgrading from 2.0.10 to 2.1.0 and pw is my piwigo installation directory. using Autoupgrade

Warning: touch(): Utime failed: Operation not permitted in /var/www/pw/admin/include/pclzip.lib.php on line 2619
Warning: include(./template/yoga/theme/VerticalWhite/themeconf.inc.php): failed to open stream: No such file or directory in /var/www/pw/include/template.class.php on line 82 Warning: include(): Failed opening './template/yoga/theme/VerticalWhite/themeconf.inc.php' for inclusion (include_path='.:/usr/share/php:/usr/share/pear') in /var/www/pw/include/template.class.php on line 82 Notice: Undefined variable: themeconf in /var/www/pw/include/template.class.php on line 83 Warning: Cannot modify header information - headers already sent by (output started at /var/www/pw/admin/include/pclzip.lib.php:2619) in /var/www/pw/include/page_header.php on line 98 Warning: Smarty error: unable to read resource: "header.tpl" in /var/www/pw/include/smarty/libs/Smarty.class.php on line 1093 Warning: Smarty error: unable to read resource: "redirect.tpl" in /var/www/pw/include/smarty/libs/Smarty.class.php on line 1093 Warning: Smarty error: unable to read resource: "footer.tpl" in /var/www/pw/include/smarty/libs/Smarty.class.php on line 1093

Thanks for the help in advanced.
ppat

Edit : after performing sudo chown ppat pclzip.lib.php , above errors are gone however following error(s) displayed (for lot of tables..)

Warning: [mysql error 1146] Table 'pw.pw_languages' doesn't exist

SELECT id, name
  FROM pw_languages
  ORDER BY name ASC
; in /var/www/pw/include/dblayer/functions_mysql.inc.php on line 642
Warning: mysql_fetch_assoc() expects parameter 1 to be resource, boolean given in /var/www/pw/include/dblayer/functions_mysql.inc.php on line 1

Last edited by ppat (2010-05-23 22:58:52)


piwigo - 2.4.5 | ploader - 1.6 (Windows Client) | Ubuntu Server 9.10

Offline

 

#2 2010-05-24 16:10:04

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13176

Re: [resolved] Upgrade Errors

Hi ppat (please do not edit your post to add information, add another post in the same topic)

Now open http://yourwebsite/photos/upgrade.php and fill the form


Latest blog post (November 9th 2018) Why Flickr could not remain free for ever

Offline

 

#3 2010-05-25 06:42:22

ppat
Member
2009-08-25
74

Re: [resolved] Upgrade Errors

plg wrote:

Hi ppat (please do not edit your post to add information, add another post in the same topic)

Sorry plg. will remember next time

plg wrote:

Now open http://yourwebsite/photos/upgrade.php and fill the form

That did the trick .. thank you


piwigo - 2.4.5 | ploader - 1.6 (Windows Client) | Ubuntu Server 9.10

Offline

 

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2018 · Contact