Announcement

#1 2010-06-22 12:16:15

73shelves.com
Guest

[resolved] fresh new install Piwigo 2.1.1 - error on adding category and upload

Hi,

I have freshly installed the Piwigo to test it to my website but I always get this error whenever I create category or add upload pictures..
here are the error message that I get at the top of the admin page

Notice: Undefined index: uploads in 73shelves.com/photos/admin/photos_add_direct.php  on line 207

Warning: implode() [function.implode]: Invalid arguments passed in 73shelves.com/photos/admin/photos_add_direct.php on line 217



Warning:  [mysql error 1064] You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ')' at line 3

UPDATE piwi_images
  SET level = 0
  WHERE id IN ()
; in /73shelves.com/photos/include/dblayer/functions_mysql.inc.php on line 642


Warning: Invalid argument supplied for foreach() in 73shelves.com/photos/admin/photos_add_direct.php on line 225

Warning: Cannot modify header information - headers already sent by (output started at /73shelves.com/photos/admin/photos_add_direct.php:207) in /73shelves.com/photos/include/page_header.php on line 98

 

#2 2010-06-22 15:08:38

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13139

Re: [resolved] fresh new install Piwigo 2.1.1 - error on adding category and upload

Hi 73shelves.com,

JPEG files or PNG files?
Did'nt you have errors before this one? (in the small notification "bubbles")
What is your photo filesize?
Have you tried with smaller filesize?
Have you tried the "old style" form?


Latest blog post (May 3rd 2018) New subscription form

Offline

 

#3 2010-06-22 23:29:54

josi
Member
2010-06-22
5

Re: [resolved] fresh new install Piwigo 2.1.1 - error on adding category and upload

I get the same error message.

Using Mandriva 2010.1. Jpeg-files.

Offline

 

#4 2010-06-22 23:41:57

josi
Member
2010-06-22
5

Re: [resolved] fresh new install Piwigo 2.1.1 - error on adding category and upload

I can find the photos I uploaded in Recent pictures --> Elements

==
==


I also have this error messages in 'Administration home':


Integrity check

Anomaly    Correction
    $conf['show_exif'] value is incorrect because exif are not supported     $conf['show_exif'] must be set to false in your local/config/config.inc.php file
Go to the forum or the wiki for more informations
    $conf['use_exif'] value is incorrect because exif are not supported     $conf['use_exif'] must be set to false in your local/config/config.inc.php file
Go to the forum or the wiki for more informations


==
==

More info about the system:
Environment
Operating system: Linux
PHP: 5.3.2 (Show info) [2010-06-22 23:41:15]
mysql: 5.1.46 [2010-06-22 21:41:15]
Database
2 images (first element added on Tuesday 22 June 2010)
1 category including 0 physical and 1 virtual (0 associations)
0 tags (0 associations)
2 users
0 groups
0 comments

Offline

 

#5 2010-06-22 23:49:57

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13139

Re: [resolved] fresh new install Piwigo 2.1.1 - error on adding category and upload

Hi josi,

I'm absolutely not sure the origin of the problem is the same as for 73shelves.com. But for you, I would say that you should try to deactivate the use of EXIF. To do so:

1) Go to screen Administration>Plugins>Manage and activate "LocalFiles Editor"
2) Go to screen Administration>Plugins>LocalFiles Editor>local config, the code must be:

<?php
$conf['use_exif'] = false;
?>

3) click on the "Save file" button
4) try to upload another photo


Latest blog post (May 3rd 2018) New subscription form

Offline

 

#6 2010-06-23 01:45:36

73shelves.com
Guest

Re: [resolved] fresh new install Piwigo 2.1.1 - error on adding category and upload

sorry for late reply.

the file size is 36 kb, and dimension or size is 150x150 picture type is jpeg

the website is fresh install as in nothing yet added to the system or nothing modified to the website very fresh install.

I tried them 10 times adding categories and pictures it gives me the same error at the top of the admin pages.

the installed pwigi is release 2.1.1

 

#7 2010-06-23 01:48:07

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13139

Re: [resolved] fresh new install Piwigo 2.1.1 - error on adding category and upload

73shelves.com,

Didn't you have errors before this one? (in the small notification "bubbles")
Have you tried the "old style" form?


Latest blog post (May 3rd 2018) New subscription form

Offline

 

#8 2010-06-23 02:06:01

73shelves.com
Guest

Re: [resolved] fresh new install Piwigo 2.1.1 - error on adding category and upload

the problem on the new category and add new pictures is now solved, 
below is the configuration that I added to the config file. 
using localfiles editor at the plugins on the admin page

<?php

/* File is not existing and will be created by LocalFiles Editor */

$conf['show_exif'] = false;
$conf['use_exif'] = false;


?>

 

#9 2010-06-23 02:15:56

73shelves.com
Guest

Re: [resolved] fresh new install Piwigo 2.1.1 - error on adding category and upload

yes I got the bubbles error at the admin pages, I thought it can be ignored because there is a message that says "ignore selected anomalies" I thought is just a minor bugs and can be ignored but turns out that it needs to have it fix.
thanks is now fix.

plg wrote:

73shelves.com,

Didn't you have errors before this one? (in the small notification "bubbles")
Have you tried the "old style" form?

 

#10 2010-06-23 12:21:36

josi
Member
2010-06-22
5

Re: [resolved] fresh new install Piwigo 2.1.1 - error on adding category and upload

I solved the problem by installing php-exif.

Maybe Piwigo could suggest that php-exif is missing?

Offline

 

#11 2010-06-23 12:40:44

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13139

Re: [resolved] fresh new install Piwigo 2.1.1 - error on adding category and upload

josi wrote:

Maybe Piwigo could suggest that php-exif is missing?

Yes, I think I will add:

1) a warning message saying that EXIF functions are missing
2) a piece of code to avoid trying to read the EXIF metadata if the EXIF functions are disabled


Latest blog post (May 3rd 2018) New subscription form

Offline

 

#12 2010-06-23 12:42:54

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13139

Re: [resolved] fresh new install Piwigo 2.1.1 - error on adding category and upload


Latest blog post (May 3rd 2018) New subscription form

Offline

 

#13 2010-06-24 07:39:54

73shelves.com
Guest

Re: [resolved] fresh new install Piwigo 2.1.1 - error on adding category and upload

how do we install the php-exif to piwigo?

josi wrote:

I solved the problem by installing php-exif.

Maybe Piwigo could suggest that php-exif is missing?

 

#14 2010-06-24 13:02:15

josi
Member
2010-06-22
5

Re: [resolved] fresh new install Piwigo 2.1.1 - error on adding category and upload

In linux, just install the package php-exif using the package manager.

In my case, I'm on a Mandriva server, I just typed 'urpmi php-exif' in the terminal.

Offline

 

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2018 · Contact