Announcement

#1 2010-06-24 21:42:30

val54
Guest

SQLite / problem status users

Hello,
The installation process is ok. But when I want to manage or add a user, I have the following errors :

Notice: Undefined index: level in /var/www/piwigo/admin/user_list.php on line 690
Notice: Undefined index: status in /var/www/piwigo/admin/user_list.php on line 711
Notice: Undefined index: adviser in /var/www/piwigo/admin/user_list.php on line 711
Notice: Undefined index: level in /var/www/piwigo/admin/user_list.php on line 690
Notice: Undefined index: status in /var/www/piwigo/admin/user_list.php on line 711
Notice: Undefined index: adviser in /var/www/piwigo/admin/user_list.php on line 711
Warning: Cannot modify header information - headers already sent by (output started at /var/www/piwigo/admin/user_list.php:690) in /var/www/piwigo/include/page_header.php on line 98

Tks

 

#2 2010-06-24 22:57:13

nicolas
Former Piwigo Team
2004-12-30
1176

Re: SQLite / problem status users

I cannot reproduce the bug. Can you explain me what you did ?

Offline

 

#3 2010-06-26 08:23:41

val54
Guest

Re: SQLite / problem status users

Hello,

I made the installation on a debian 5. Apache 2 , php 5.2.6-1 and sqlite 3.5.9.

I made with the package 2.1.1.zip not with the Netinstall. The process install is ok.

But when I go to the administration page on the User Menu, on the top of the web page I have the error describe previously. On the table with the user, the status of Admin and Guest is "_user_status".

Thk

 

#4 2010-06-26 09:27:48

nicolas
Former Piwigo Team
2004-12-30
1176

Re: SQLite / problem status users

val54 wrote:

Hello,

I made the installation on a debian 5. Apache 2 , php 5.2.6-1 and sqlite 3.5.9.

I made with the package 2.1.1.zip not with the Netinstall. The process install is ok.

But when I go to the administration page on the User Menu, on the top of the web page I have the error describe previously. On the table with the user, the status of Admin and Guest is "_user_status".

Thk

I think the status of Admin and Guest is "user_status_". The underscore is at the end. I will double check with same version as yours.

Offline

 

#5 2010-06-30 21:28:22

val54
Guest

Re: SQLite / problem status users

Hi,

Yes, the underscore is at the end. I have tested with the new version 2.1.2 and I have the same errors.

 

#6 2010-06-30 21:35:45

nicolas
Former Piwigo Team
2004-12-30
1176

Re: SQLite / problem status users

val54 wrote:

Hi,

Yes, the underscore is at the end. I have tested with the new version 2.1.2 and I have the same errors.

I'm very disapointed. I cannot reproduce the problem and I don't in which way to go to find a solution. :-(

Do you use sqlite3 native extension or sqlite via PDO ? You can see it in local/config/database.inc.php file. What is the value for $conf['dblayer'] ?

Offline

 

#7 2010-07-01 06:50:03

val54
Guest

Re: SQLite / problem status users

The value :
<?php
$conf['dblayer'] = 'pdo-sqlite';
$conf['db_base'] = 'piwigo_db';
$conf['db_user'] = '';
$conf['db_password'] = '';
$conf['db_host'] = 'localhost';

$prefixeTable = 'piwigo_';

define('PHPWG_INSTALLED', true);
define('PWG_CHARSET', 'utf-8');
define('DB_CHARSET', 'utf8');
define('DB_COLLATE', '');

?>

 

#8 2010-07-01 11:02:30

nicolas
Former Piwigo Team
2004-12-30
1176

Re: SQLite / problem status users

Thanks val54.
I cannot already reproduce your problem but there problems. I have to confirm and to reproduce it but I found another one.

Offline

 

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2019 · Contact