Announcement

  •  » Engine
  •  » Smarty 3 upgrade

#16 2012-05-15 15:53:35

flop25
Piwigo Team
2006-07-06
6900

Re: Smarty 3 upgrade

it seems the most problematic issues are
== {php} Tag ==
{php} tags is
deprecated. But it can be enabled with $smarty->allow_php_tag=true.

== Delimiters and whitespace ==
But it can be disable with $smarty->auto_literal = false;

== Unquoted Strings ==
this may be the most problematic ; You can still pass strings without quotes
so long as they contain no special characters. (anything outside of A-Za-z0-9_)

extracted from
http://smarty-php.googlecode.com/svn/tr … _NOTES.txt


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#17 2012-05-30 15:25:09

vdanjean
Member
2010-03-16
2

Re: Smarty 3 upgrade

Hi,

  For information, the next Debian release will only have smarty3 and not smarty anymore. This means that piwigo will soon be removed from Debian unless a version compatible with smarty3 can be uploaded:
http://bugs.debian.org/672374
  Debian plans to do the freeze for the next release during June. So, I'm afraid that piwigo wont be released in the next Debian (wheezy).

  Regards,
    Vincent

Offline

 

#18 2012-05-30 15:34:34

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13182

Re: Smarty 3 upgrade

vdanjean wrote:

For information, the next Debian release will only have smarty3 and not smarty anymore.

This is exactly after an email from the Piwigo package maintainer in Debian that I wrote [Forum, post 130057 by plg in topic 16742] Smarty 3 upgrade


Latest blog post (November 9th 2018) Why Flickr could not remain free for ever

Offline

 

#19 2012-05-30 15:39:33

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13182

Re: Smarty 3 upgrade

Actually yes, Piwigo will probably be removed from Debian for version 7. The best we can do is to update for Piwigo 2.5 which can't be released before october/november 2012.


Latest blog post (November 9th 2018) Why Flickr could not remain free for ever

Offline

 

#20 2012-05-30 19:28:35

Billr
Piwigo Team, forum moderator
2011-06-22
144

Re: Smarty 3 upgrade

What will this mean to the average user who upgrades to the latest Debian?  Will their Piwigo server stop working?  Should they be warned not to upgrade Debian until Piwigo changes to Smarty3?

Offline

 

#21 2012-05-30 19:34:27

flop25
Piwigo Team
2006-07-06
6900

Re: Smarty 3 upgrade

you could upgrade it and test with
$smarty->allow_php_tag=true;
$smarty->auto_literal = false;
it might be ok


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#22 2012-05-30 20:06:48

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13182

Re: Smarty 3 upgrade

Billr wrote:

What will this mean to the average user who upgrades to the latest Debian?  Will their Piwigo server stop working?  Should they be warned not to upgrade Debian until Piwigo changes to Smarty3?

It only concerns users who have installed Piwigo with the Debian package system. Actually I think it's a tiny part of Piwigo users. I use Debian on my servers. I don't use the Debian package to install Piwigo.


Latest blog post (November 9th 2018) Why Flickr could not remain free for ever

Offline

 

#23 2012-05-30 20:07:53

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13182

Re: Smarty 3 upgrade

flop25 wrote:

you could upgrade it and test with
$smarty->allow_php_tag=true;
$smarty->auto_literal = false;
it might be ok

Well, I don't want this for Piwigo 2.4 BUT I can tell the Debian maintainer (nicolas) to give a try to this solution.


Latest blog post (November 9th 2018) Why Flickr could not remain free for ever

Offline

 

#24 2012-05-30 20:45:04

nicolas
Former Piwigo Team
2004-12-30
1176

Re: Smarty 3 upgrade

smarty 2 has been removed from testing and will probably not enter unstable. If upstream (piwigo team) do not provided an official release with smarty 3, I'm afraid I will have to patch piwigo with flop25 propositon.

Offline

 

#25 2012-05-30 21:03:49

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13182

Re: Smarty 3 upgrade

nicolas wrote:

If upstream (piwigo team) do not provided an official release with smarty 3, I'm afraid I will have to patch piwigo with flop25 propositon.

This is exactly the suggestion :-) if it avoids to remove Piwigo from Debian 7, it's a very good solution.


Latest blog post (November 9th 2018) Why Flickr could not remain free for ever

Offline

 

#26 2013-04-12 23:15:06

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13182

Re: Smarty 3 upgrade

Piwigo 2.6 is now under preparation. Considering Statistics on Wordpress.org, PHP 5.2+ = 99.4%. Can we upgrade to smarty 3 for Piwigo 2.6?


Latest blog post (November 9th 2018) Why Flickr could not remain free for ever

Offline

 

#27 2013-04-13 07:39:59

rvelices
Piwigo Team
2005-12-29
1960

Re: Smarty 3 upgrade

yes .

Offline

 

#28 2013-04-13 15:04:22

flop25
Piwigo Team
2006-07-06
6900

Re: Smarty 3 upgrade

As I said Yes! :-)


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#29 2013-04-15 11:13:17

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13182

Re: Smarty 3 upgrade

One problem with PHP 5.2 : the hosting provider Free.fr does not support it. It might seem surprising to block such an enhancement for just a single hosting provider, but we have many users hosted on Free.fr.

Wordpress 3.2+ requires PHP 5.2.4. Free.fr users can only upgrade up to Wordpress 3.1 (latest release in 2011)

Questions:

1) how much is PHP 5.2 required by Smarty 3? is it just a missing function or is it completely blocked?

2) considering that Free.fr is already not very welcoming for Piwigo users (small upload_max_filesize, no automatic install/upgrade, no 1-click install for plugins, etc.), how long can we afford to make specific code for Free.fr?


Latest blog post (November 9th 2018) Why Flickr could not remain free for ever

Offline

 

#30 2013-04-15 11:28:42

flop25
Piwigo Team
2006-07-06
6900

Re: Smarty 3 upgrade


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 
  •  » Engine
  •  » Smarty 3 upgrade

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2019 · Contact