Piwigo.org

You are not logged in. (Register / Login)

Announcement

#1 2011-07-23 01:52:04

styxsailor
Translation Team
Registered: 2011-07-18
Posts: 34

[resolved] Public album not seen by guest.

After installing piwigo I created a first album and choose "Public" as access type and "Everybody" can see the uploaded photos. As long as I am logged in with the Admin account, the album and images can be seen, but as soon as I logout, the album disappears!

What settings am I missing to make the newly created album publicly viewable without needing to log in?

Thanks for any help!

styxsailor

Offline

#2 2011-07-23 02:18:44

styxsailor
Translation Team
Registered: 2011-07-18
Posts: 34

Re: [resolved] Public album not seen by guest.

After a day of hassle, suddenly after posting of course I managed to resolve this - apologies for any noise!

The details of the issue as follows:

(FAIL:)
- I uploaded the photos to the gallery, then created an album ("Public") and associated these photos to the album. I went through the Administration Home -> Photos -> Batch Manager (global mode) and selected all the 5 photos. From the drop list I selected "Who can see these photos?", and the next droplist "Everybody" and then apply.  As admin I could browse my album peacefully, but after logging out the album and images disappeared. Went over this loop a few times to no avail.

(SUCCESS:)
- I gave up and tried viewing the gallery from the admin account. I noticed for every picture there was a descriptor "Who can see this picture" again, but here it showed "Administrators". Setting this to "Everyone" individually for all photos and logging out, the photos (and album) could still be seen by the guest.

I am sure this must be a PEBCAK, but I haven't verified that the first method works yet.

regards

-- styxsailor

Offline

Board footer

Powered by FluxBB

twitter facebook google+ newsletter Donate Piwigo.org © 2002-2014 · Contact