Announcement

#1 2012-06-28 13:07:35

Polly
Translation Team
2010-01-15
60

Watermark and Piwigo 2.4

Hello,

i want to enable watermarks within Piwigo. I simply enabled it with the default image.
But there is no Watermark on any image.

No errors in the Log files!

Anyone an idea what is wrong?

Thx for your help.

cheers,
polly


Uploaded Images

Offline

 

#2 2012-06-28 13:26:15

flop25
Piwigo Team
2006-07-06
6965

Re: Watermark and Piwigo 2.4

hello
thx for the feedback ; do you have a link ?


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#3 2012-06-28 13:26:35

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13277

Re: Watermark and Piwigo 2.4

If you change the position of the watermark, does it update the photos?

Offline

 

#4 2012-06-28 13:29:48

Polly
Translation Team
2010-01-15
60

Re: Watermark and Piwigo 2.4

@flop25, link to the gallery http://neu.sam-net.de/piwigo/picture.php?/39/category/1

@plg, i changed the position several times, from right-rop to left-top and center. No visible change

Offline

 

#5 2012-07-04 04:23:34

gjtoth
Member
2009-10-13
28

Re: Watermark and Piwigo 2.4

Same here.  I uploaded my personal .png file, it shows in the window, but that's all.  No photos updated with the watermark.  Did I miss a step or two?

Offline

 

#6 2012-07-04 10:07:13

Polly
Translation Team
2010-01-15
60

Re: Watermark and Piwigo 2.4

Hello again,

update to version 2.4.1 .... still the same.
no errors in the log files :-(

Cheers,
polly

Offline

 

#7 2012-07-04 13:12:59

flop25
Piwigo Team
2006-07-06
6965

Re: Watermark and Piwigo 2.4

hi
what's your graphic library and environment ? : see it on the first admin page


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#8 2012-07-04 13:18:10

Polly
Translation Team
2010-01-15
60

Re: Watermark and Piwigo 2.4

Hey

the System i'm using:
        Betriebssystem: Linux
        PHP: 5.3.6 (Info anzeigen) [2012-07-04 13:15:37]
        mysql: 5.0.95 [2012-07-04 13:15:37]
        Grafikbibliothek: External ImageMagick 6.2.8


Thx.

cheers,
polly

Offline

 

#9 2012-07-10 04:25:43

Blackmarx
Guest

Re: Watermark and Piwigo 2.4

I am having the same problem. I can not get my watermarks to work.

 

#10 2012-07-10 05:40:39

Blackmarx
Guest

Re: Watermark and Piwigo 2.4

Environment
Operating system: Linux
PHP: 5.2.14 (Show info) [2012-07-09 23:40:11]
mysql: 5.0.95-community [2012-07-09 23:40:11]
Graphics Library: External ImageMagick 6.2.8

 

#11 2012-07-10 06:56:01

rvelices
Piwigo Team
2005-12-29
1960

Re: Watermark and Piwigo 2.4

The only thing I see in common is that you both use external imagick 6.2.8 which is pretty old ...

- if you change to gd the watermark appears ?

Offline

 

#12 2012-07-10 09:39:02

Polly
Translation Team
2010-01-15
60

Re: Watermark and Piwigo 2.4

hey .... thx for your reply :-)

the watermark works if i use GDlib and change to position once to get the pitures updated.
http://neu.sam-net.de/piwigo/picture.php?/39/category/1

Thanks for that hint....

i tried on an other server with a more recent version of ImageMagick, and it worked :-)

Code:

convert --version
Version: ImageMagick 6.5.4-7 2010-11-10 Q16 OpenMP http://www.imagemagick.org
Copyright: Copyright (C) 1999-2009 ImageMagick Studio LLC

Do you guys think it can be fixed? or schould i ask my admin to update ImageMagick?

Cheers,

polly

Offline

 

#13 2012-07-10 11:38:43

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13277

Re: Watermark and Piwigo 2.4

Polly wrote:

Do you guys think it can be fixed? or schould i ask my admin to update ImageMagick?

If you have ImageMagick 6.2.8, I think you're hosting provider is running on Debian Etch, released on 2007-04-08 and is no longer supported since 2010-02-15 (that's 2 years ago). I think it's time to upgrade to Debian Squeeze.

Offline

 

#14 2012-07-10 12:55:05

Polly
Translation Team
2010-01-15
60

Re: Watermark and Piwigo 2.4

Hello, :-)

we are running CentOS release 5.5 (Final) on that Server. On the other its CentOS 6 (Final) ...

cheers,
polly

Offline

 

#15 2012-10-12 21:27:27

gumoore
Member
2012-10-12
6

Re: Watermark and Piwigo 2.4

My info is:


        Operating system: Linux
        PHP: 5.2.17 (Show info) [2012-10-12 15:17:43]
        mysql: 5.1.65-cll [2012-10-12 15:17:43]
        Graphics Library: External ImageMagick 6.4.8



Question, how do I change the graphics library because I too cannot get the watermark to work.

Offline

 

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2019 · Contact