Announcement

#1 2013-02-20 19:49:37

mendip_discovery
Member
Mendip Hills, Somerset, UK
2012-05-19
89

PHP Stict Errors on Upgrade to 2.4.7

Just upgraded the site from 2.4.6 to 2.4.7 and after it upgraded at the top of the page was some php errors, doesn't look like anything is broken. Just thought I would put it here just in case I am not the only one.

Operating system: Linux
PHP: 5.4.11 (Show info) [2013-02-20 18:49:21]
mysql: 5.5.30 [2013-02-20 18:49:21]
Graphics Library: External ImageMagick 6.5.4-7

Code:

Strict Standards: Non-static method updates::upgrade_to() should not be called statically in /var/www/vhosts/gallery/admin/updates_pwg.php on line 121

Code:

Strict Standards: Non-static method updates::process_obsolete_list() should not be called statically in /var/www/vhosts/gallery/admin/include/updates.class.php on line 451

Code:

Strict Standards: Non-static method updates::deltree() should not be called statically in /var/www/vhosts/gallery/admin/include/updates.class.php on line 452

Offline

 

#2 2013-02-21 12:44:58

Eric
Piwigo Team
VALENCE (FR)
2005-03-25
1768

Re: PHP Stict Errors on Upgrade to 2.4.7

Hi,

I noticed these messages too during upgrade from 2.4.6 to 2.4.7. I think it's only warnings (and not real errors) due to Php 5.4 because the upgrade is optimal. Piwigo has not been fully qualified for Php 5.4 yet.

Offline

 

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2019 · Contact