Announcement

#1 2013-03-06 20:33:49

phantomracer
Member
2013-03-06
30

error on oauth facebook

I just upgraded to 2.5

I installed and configured the app on facebook.

I get the following error when I try and use the facebook login in a separate window:

Notice: Undefined variable: params in /piwigo/plugins/oAuth/auth.php on line 73

Warning: Cannot modify header information - headers already sent by (output started at /piwigo/plugins/oAuth/auth.php:73) in /piwigo/plugins/oAuth/include/hybridauth/Hybrid/Auth.php on line 351

---------------------

my website is www.seeberg.com/piwigo

---------------------

here is the facebook app info:

Display Name: seeberg
   
App Domains: www.seeberg.com

Hosting URL: You have not generated a URL through one of our partners (Get one)

Sandbox Mode: Disabled

Select how your app integrates with Facebook
Website with Facebook Login
Site URL: http://www.seeberg.com/piwigo

Last edited by phantomracer (2013-03-06 20:34:41)

Offline

 

#2 2013-03-06 22:14:59

mistic100
Former Piwigo Team
Lyon (FR)
2008-09-27
3271

Re: error on oauth facebook

thanks

strange I didn't noticed it (not related to facebook)

Offline

 

#3 2013-03-06 23:24:08

phantomracer
Member
2013-03-06
30

Re: error on oauth facebook

The error is in the pop up after you click the facebook icon by the login info (by 'or sign in with F')

The photo gallery seems to be working great.. just the plug in isn't working.

Offline

 

#4 2013-03-06 23:47:41

cyberthrills
Member
2011-07-07
28

Re: error on oauth facebook

Having a similar error with twitter.

Notice: Undefined variable: params in /plugins/oAuth/auth.php on line 73

Warning: Cannot modify header information - headers already sent by (output started at /plugins/oAuth/auth.php:73) in /plugins/oAuth/include/hybridauth/Hybrid/Auth.php on line 351

Offline

 

#5 2013-03-06 23:51:40

mistic100
Former Piwigo Team
Lyon (FR)
2008-09-27
3271

Re: error on oauth facebook

obviously you have

did you update the plugin

Offline

 

#6 2013-03-06 23:55:23

cyberthrills
Member
2011-07-07
28

Re: error on oauth facebook

Yes I have running 1.0 beta.

Offline

 

#7 2013-03-07 00:02:29

mistic100
Former Piwigo Team
Lyon (FR)
2008-09-27
3271

Re: error on oauth facebook

so not updated as it's the first version...

1.0.0 was published since you reported the bug

Offline

 

#8 2013-03-07 00:04:35

cyberthrills
Member
2011-07-07
28

Re: error on oauth facebook

Ok what I did was deleted plugin reinstalled now version 1.0.0. Activated plugin tried it again still getting the same error.

Offline

 

#9 2013-03-07 00:08:26

phantomracer
Member
2013-03-06
30

Re: error on oauth facebook

Any idea on the new facebook plugin? Is there something wrong with the setup? any detailed installation other than the pop up help on the plugin page?   I thought I did it right

Offline

 

#10 2013-03-07 00:26:45

mistic100
Former Piwigo Team
Lyon (FR)
2008-09-27
3271

Re: error on oauth facebook

@cyberthrills: there was ne need to delete it
anyway I'm pretty sure you didn't install the very last version, the bug came from an error I made, but now it's fixed, I tested it on two website without any bugs (example http://piwigo.strangeplanet.fr/)

@phantomracer: you have the same error ?
I can't give more detailled instructions than what's given in the the config page, and anyway this bug was NOT related to a specific provider

Offline

 

#11 2013-03-07 00:31:43

phantomracer
Member
2013-03-06
30

Re: error on oauth facebook

I posted the text of the error in my opening post. you can go to my page and try it and see the error.

www.seeberg.com/piwigo ..scroll down a bit... facebook icon on the left (not the social button on the top of the page)


in a pop up window with the URL of http://www.seeberg.com/piwigo/plugins/o … nit_auth=1



Notice: Undefined variable: params in /piwigo/plugins/oAuth/auth.php on line 73

Warning: Cannot modify header information - headers already sent by (output started at /piwigo/plugins/oAuth/auth.php:73) in /piwigo/plugins/oAuth/include/hybridauth/Hybrid/Auth.php on line 351

Offline

 

#12 2013-03-07 00:44:47

phantomracer
Member
2013-03-06
30

Re: error on oauth facebook

got further. uninstalled the app, and reinstalled..

but still failing..

in the pop up

"Authentication canceled"

Offline

 

#13 2013-03-07 00:45:49

mistic100
Former Piwigo Team
Lyon (FR)
2008-09-27
3271

Re: error on oauth facebook

sorry I mingled your two pseudonyms

so, phantomracer, I don't have any PHP error, the only issue is that the plugin answer "Authentication cancelled"

try with "seeberg.com" as "App Domains"
if it's not working, add a trailing slash to "Site URL"
(please try both solutions separately, so I can know witch one is important )

Offline

 

#14 2013-03-07 00:59:32

cyberthrills
Member
2011-07-07
28

Re: error on oauth facebook

mistic100 wrote:

@cyberthrills: there was ne need to delete it
anyway I'm pretty sure you didn't install the very last version, the bug came from an error I made, but now it's fixed, I tested it on two website without any bugs (example http://piwigo.strangeplanet.fr/)

@phantomracer: you have the same error ?
I can't give more detailled instructions than what's given in the the config page, and anyway this bug was NOT related to a specific provider

Ya I know, but I noticed when I updated it didn't change the version it still was 1.0 beta. When I deleted and reinstalled it was the updated version. It says it's version 1.0.0 now and have the same error I will just down load the latest version and try that way.

Offline

 

#15 2013-03-07 01:49:25

phantomracer
Member
2013-03-06
30

Re: error on oauth facebook

tried it.. didn't make any difference.

adding a slash to the app name causes an error.

sorry .. added slash to the url as well, didn't change

Last edited by phantomracer (2013-03-07 01:57:14)

Offline

 

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2019 · Contact