Piwigo.org

You are not logged in. (Register / Login)

Announcement

#1 2013-03-25 10:09:05

Erik
Guest

oauth - Google

Tags: [oauth]

Hi All,

I've installed the latest versions of Piwigo and Oauth, and I have been able to login thru Google.
Now comes the thing that seems strange to me, I can't find if it is "work as designed":

If I click on the Google sign it opens a Google popup and you need to approval to use your account. all fine so far, I confirm and the popup closes.
After this the Piwigo has my Google's accounts full name and asks for my mail adres, password and Captcha (another extension I installed), I'm not logged in at this point and if I fill this in I create an account on my Piwigo site.

Is this correct? If I do this the second time it wont let me because the user allready exist in the Piwigo database..

Kind regards,
Erik Willemstein

#2 2013-03-25 13:01:26

mistic100
Piwigo Team
Location: Lyon (FR)
Registered: 2008-09-27
Posts: 2744
Website

Re: oauth - Google

Hello

the workflow should be this (from not logged)
- click on Google button
- fill Google logins
- redirect to register page
- fill Piwigo email (if needed) for registering
- login (automatic after register)

this is done once, after that (every time you try to login) :
- click on Google button
- fill Google logins
- login on Piwigo (automatic)


if the system ask you to register again, there is a problem

give a link please


» All my plugins  » My website
For an efficient support give the URL of your website

Offline

#3 2013-03-25 13:11:26

Erik
Guest

Re: oauth - Google

That's indeed not the case.

http://willemstein-online.nl/slf/
This is the link, it is a test case so it doenst matter if it breaks down.
user: slf
pwd: slf

I've noticed a couple of PHP errors after I entered my mail adres the first time, but it goes away to fast to read.

thx for checking

#4 2013-03-25 13:17:51

mistic100
Piwigo Team
Location: Lyon (FR)
Registered: 2008-09-27
Posts: 2744
Website

Re: oauth - Google

please try with a core theme like elegant


» All my plugins  » My website
For an efficient support give the URL of your website

Offline

#5 2013-03-25 13:43:44

Erik
Guest

Re: oauth - Google

Did that, did'nt solve the problem.

I did manage to capture the PHP which was flying by:
http://willemstein-online.nl/piwigo.jpg

#6 2013-03-25 18:27:33

mistic100
Piwigo Team
Location: Lyon (FR)
Registered: 2008-09-27
Posts: 2744
Website

Re: oauth - Google

I don't understand, it shouldn't append, you have two different bugs

- the line 50 of register.php musn't be executed because it's intercepted earlier
- the new user IS registered (you can see my full name in your users list) be when I logon again, the system don't find me and try to register

could you send me by mail (I registered on your gallery with a good email) a dump of your table "piwigo_users" (use phpMyAdmin)


» All my plugins  » My website
For an efficient support give the URL of your website

Offline

#7 2013-03-26 21:30:35

Erik
Guest

Re: oauth - Google

I've send you an email. Did you find anything?

Kind of strange I have 2 bugs at the same time.

#8 2013-03-26 21:33:32

mistic100
Piwigo Team
Location: Lyon (FR)
Registered: 2008-09-27
Posts: 2744
Website

Re: oauth - Google

I received it

for the first bug : no idea
for the second one : the collumn "oauth_id" of your table is NULL where it shouldn't be, why ? no idea :-)

perhaps both bugs are related
sorry I don't have free time right now to search


» All my plugins  » My website
For an efficient support give the URL of your website

Offline

#9 2013-06-26 00:22:39

martinis
Guest

Re: oauth - Google

Did you find a solution? I have exactly the same problem when trying to use the Google sign-in.   It seems to want me to register again as, in addition to the Captcha, there is the message "Your registration is almost done, please complete the registration form."   Thanks.

Board footer

Powered by FluxBB

twitter facebook google+ newsletter Donate Piwigo.org © 2002-2014 · Contact