Announcement

  •  » Extensions
  •  » Evil_blog: Missing editing submit button in admin area

#1 2013-07-29 17:25:42

Romtom
Member
2013-07-25
11

Evil_blog: Missing editing submit button in admin area

I guess something went wrong on my install of evil_blog as I can't find any submit button, when I'm trying to change an existing post. It simply looks like the 2nd pic.

I deactivated it and reactivated it again then I tried to restore it and also deleted it. When I activated it again after the install, I got a short visible error message on the screen (1st pic).

Everthing else seems to work fine, I just can't edit a post.

Can someone help solve this problem?


Uploaded Images

Last edited by Romtom (2013-07-29 17:29:30)

Offline

 

#2 2013-08-12 15:41:34

Ann
Member
NC, USA
2013-08-10
40

Re: Evil_blog: Missing editing submit button in admin area

I'm seeing the same thing - can't figure out how to edit blog posts. I don't remember seeing this when I first tested it, so I'm wondering if it is caused by having deactivated/reactivated the feature while playing around with the site. I get the following error when reactivating Evil_Blog:

Warning: mysql_fetch_row(): supplied argument is not a valid MySQL result resource in /path to my Piwigo installation/plugins/Evil_Blog/maintain.inc.php on line 58


Warning: [mysql error 1050] Table 'kos_evil_blog' already exists
CREATE TABLE kos_evil_blog (

id INT( 1 ) NOT NULL AUTO_INCREMENT,
date DATETIME NOT NULL,
header VARCHAR( 255 ) NOT NULL ,
text LONGTEXT NOT NULL ,
PRIMARY KEY (id))
DEFAULT CHARACTER SET utf8; in /path to my Piwigo installation/include/dblayer/functions_mysqli.inc.php on line 834

Warning: Cannot modify header information - headers already sent by (output started at /path to my Piwigo installation/plugins/Evil_Blog/maintain.inc.php:58) in /path to my Piwigo installation/include/page_header.php on line 101

I tried uninstalling (deleting from my plugins) and reinstalling as well, and I'm getting the same error, except that it refers to line 11 instead of 58:

Warning: mysql_fetch_row(): supplied argument is not a valid MySQL result resource in /path to my Piwigo installation/plugins/Evil_Blog/maintain.inc.php on line 11


Warning: [mysql error 1050] Table 'kos_evil_blog' already exists
CREATE TABLE kos_evil_blog (

id INT( 1 ) NOT NULL AUTO_INCREMENT,
date DATETIME NOT NULL,
header VARCHAR( 255 ) NOT NULL ,
text LONGTEXT NOT NULL ,
PRIMARY KEY (id))
DEFAULT CHARACTER SET utf8; in /path to my Piwigo installation/include/dblayer/functions_mysqli.inc.php on line 834

Warning: Cannot modify header information - headers already sent by (output started at /path to my Piwigo installation/plugins/Evil_Blog/maintain.inc.php:11) in /path to my Piwigo installation/include/page_header.php on line 101

Offline

 

#3 2013-08-12 15:55:36

flop25
Piwigo Team
2006-07-06
6623

Re: Evil_blog: Missing editing submit button in admin area

seems like the author forgot to add a IF NOT EXISTS to the CREATE sql request, in order to avoid an error saying the table already exists


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#4 2013-09-02 22:30:37

Stanislav
Guest

Re: Evil_blog: Missing editing submit button in admin area

Dear authors of Piwigo!

I really like your photogallery engine and enjoy it's functionality but (!) I can't edit blog posts (Evil_Blog). Actually I can but it is not possible to SAVE (submit) changes!

Please, fix the problem!

Thanks a lot :)

 

#5 2013-09-08 11:09:21

EvilKant
Member
Russia
1970-01-01
98

Re: Evil_blog: Missing editing submit button in admin area

Bug was fixed. Install version 1.2.2

Last edited by EvilKant (2013-09-08 11:10:13)

Offline

 

#6 2013-09-08 11:51:00

ddtddt
Piwigo Team
Quetigny - France
2007-07-27
6689

Re: Evil_blog: Missing editing submit button in admin area

Hi EvilKant :-)

on translate tool ans SVN they're 19 languages on version 1.2.2 only 12 ?


You love Piwigo so don't hesitate to participate, learn more on the "Contribute to Piwigo" page. If you don't have much time for contribution, you can also help the project with a donation.

Offline

 
  •  » Extensions
  •  » Evil_blog: Missing editing submit button in admin area

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2017 · Contact