Announcement

#1 2015-04-05 02:43:30

tido.com
Member
Sofia / Bulgaria
2015-04-04
1

Unable to upload using Web Form Uncaught TypeError 2.7.4 clean install

Hello/Hi/Greetings,

On a clean install of Piwigo 2.7.4 I get "Uncaught TypeError"(s) when trying to upload a picture using the  Photos/Add/Web Form
(admin.php?page=photos_add&section=direct)

Using the same browser/image I am able to successfully upload to my free trial account on Piwigo.com
http://tido.piwigo.com/admin.php?page=p … ion=direct

Also - If I do a FTP + Synchronization upload everything works correctly
(admin.php?page=photos_add&section=ftp)

I am able to add a file (or files) using either the Add Files button or drag and drop
01-file_added.pnghttp://piwigo.org/forum/showimage.php?pid=158661&filename=01-file_added.png&preview=true

When I press Start Upload I get a Cancel button and a progress bar
03-in_progress.pnghttp://piwigo.org/forum/showimage.php?pid=158661&filename=03-in_progress.png&preview=true

In the Network console I get the following:
* After adding a file I receive delete.gif
** 02-delete.pnghttp://piwigo.org/forum/showimage.php?pid=158661&filename=02-delete.png&preview=true
* After pressing Start Upload the POST to ws.php?method=pwg.images.upload&format=json completes and I even receive done.gif (which never gets displayed) ()
** 04-upload_error.pnghttp://piwigo.org/forum/showimage.php?pid=158661&filename=04-upload_error.png&preview=true

In the Console Log I get the following errors:
* Uncaught TypeError: Cannot read property 'image_id' of undefined    admin.php?page=photos_add:427
* Uncaught TypeError: Cannot read property 'id' of null                         admin.php?page=photos_add:449

And if I press the cancel button nothing happens but I get more Console Log errors:
* Uncaught TypeError: Cannot read property 'id' of null                         admin.php?page=photos_add:449
05-cancel_error.pnghttp://piwigo.org/forum/showimage.php?pid=158661&filename=05-cancel_error.png&preview=true

06-errors_expanded.pnghttp://piwigo.org/forum/showimage.php?pid=158661&filename=06-errors_expanded.png&preview=true

In the upload/buffer directory I get zero length filename.ext.part file(s)

The page responds as if the upload is in progress, and If I try to navigate to any other link I get the Confirm Navigation / Upload in progress popup

For comparison here is what a successful upload to the free trial account on Piwigo.com looks like for me:
07-upload_to_trial_account.pnghttp://piwigo.org/forum/showimage.php?pid=158661&filename=07-upload_to_trial_account.png&preview=true

I have tried both Manual Installation and NetInstall in a clean environment:
* Removing all files from the installation directory
* Dropping all tables in the database before each attempt
* Restarting php-fpm and nginx
* Clearing the browser cache to "the beginning of time"
** Browsing history, Download history, Cookies and other site data, Cached images and files, Hosted app data
* Also tried after updating Language Switch to 2.7.2 (to get rid of the warning)

Client:
Browser: chromium 41.0.2272.101-1

Server Information:
Operating System: Arch Linux (all packages updated before testing)
Database: mariadb 10.0.17-2
PHP: php, php-fpm, php-gd - all 5.6.7-1
Webserver: nginx-passenger 1.6.2-8
ImageMagick: imagemagick 6.9.1.0-1

From Administration Home (admin.php):
Environment:
Operating system: Linux
Graphics Library: External ImageMagick 6.9.1-0

Piwigo version: 2.7.4
PHP version: 5.6.7 (Show info) [2015-04-05 01:54:36]
MySQL version: 5.5.5-10.0.17-MariaDB-log [2015-04-05 01:54:36]
Piwigo URL: https://tido.com/media/


Uploaded Images

Last edited by tido.com (2015-04-05 03:20:51)

Offline

 

#2 2015-07-06 17:48:22

George Miller
Guest

Re: Unable to upload using Web Form Uncaught TypeError 2.7.4 clean install

Hey there,

I too have this exact same issue with my own Piwigo instance. Any fixes?

 

#3 2015-07-06 17:48:23

George Miller
Guest

Re: Unable to upload using Web Form Uncaught TypeError 2.7.4 clean install

Hey there,

I too have this exact same issue with my own Piwigo instance. Any fixes?

 

#4 2015-07-13 22:48:50

StephenH
Guest

Re: Unable to upload using Web Form Uncaught TypeError 2.7.4 clean install

I have the same problem.

 

#5 2015-07-14 09:50:59

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13182

Re: Unable to upload using Web Form Uncaught TypeError 2.7.4 clean install

Hi,

tido, I have registered on your Piwigo. Can you give me "administrator" user status so that I can test on your Piwigo please? I would like to check the console log on the ws.php http request.


Latest blog post (November 9th 2018) Why Flickr could not remain free for ever

Offline

 

#6 2015-07-14 22:39:01

Fotogleder
Guest

Re: Unable to upload using Web Form Uncaught TypeError 2.7.4 clean install

Can't upload photos either.. uploads about 1/3 of the photo.. and it takes very long time.. and when I managed uploading one..it showed only the half of it..the rest was grey..

 

#7 2015-07-18 22:35:42

Mikko Syrjä
Guest

Re: Unable to upload using Web Form Uncaught TypeError 2.7.4 clean install

I have similar problems with uploading. My site is hosted by OVH and I noticed that it has something to do with PHP version. Uploading works with PHP 5.4 but breaks with PHP versions 5.5 and 5.6.

 

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2019 · Contact