Announcement

#1 2009-03-10 05:27:32

Spooktalker
Member
2009-02-26
7

Metadata synchronization suddenly stopped working

Hello all,

I have a problem on my hands that has me completely confused.


By editing the include/config_local.inc.php, I succeeded in importing IPTC metadata into Piwigo. I should say at first I made some edits to the doc that seemed to have no effect. Then I noticed that on some pictures, the metadata WAS imported, while on others it was not.

I checked the jpegs to confirm that ALL the picture files themselves indeed had metadata. They did. Then I uploaded some new pictures to see if THEY could be synchronized. I synchronized, and even more strangely, ALL of the OLD pictures synchronized (author, title, tags, etc) while NONE of the new pictures synchronized.

Now the new pictures will not synchronize for anything. I've scrutinized config_default.inc.php but can't figure it out. I've tried replacing config_local.inc.php with a backup I made, and I've tried creating a new copy of config_local.inc.php from config_default.inc.php. It simply won't synchronize the metadata anymore.

What is so puzzling was that in a single synchronization, SOME pictures imported metadata, while others did not. So there were no changes made to config_default.inc.php between when it worked and when it did not.

The metadata section of my config_default.inc.php is simply the default with the iptc functions set to "true".



And here is a statement I get when I synchronize that claims to have updated the metadata, but in reality this hasn't happened.


Search for new images in the directories
0 categories added in the database
3 elements added in the database
0 categories deleted in the database
0 elements deleted in the database
40 elements updated in the database
0 errors during synchronization
Metadata synchronization results
3 elements informations synchronized with files metadata
3 images candidates for metadata synchronization
Used metadata : filesize, width, height, high_filesize, keywords, date_creation, author, name, comment

I'd really appreciate any help. Something simple I'm just not seeing? Also, let me know if any other info would be useful. I've spent hours troubleshooting to no avail.

Last edited by Spooktalker (2009-03-10 05:38:54)

Offline

 

#2 2009-03-10 13:48:17

ddtddt
Piwigo Team
Quetigny - France
2007-07-27
6707

Re: Metadata synchronization suddenly stopped working

Made you one Quick local Synchronizion or you be pass by the menu ?


You love Piwigo so don't hesitate to participate, learn more on the "Contribute to Piwigo" page. If you don't have much time for contribution, you can also help the project with a donation.

Offline

 

#3 2009-03-10 18:27:18

Spooktalker
Member
2009-02-26
7

Re: Metadata synchronization suddenly stopped working

I've tried both methods many times.

As I understand, the quick local synchronization synchronizes only new files. But when I add new files, the metadata is not synchronized.

When I go through the menu, I am selecting
"directories + files""
"synchronize metadata (filesize, width, height, high_filesize, date_creation, keywords, date_creation, author, name, comment)"
"even already synchronized elements"

and "only perform a simulation (no change in database will be made)" is NOT checked



it tells me:

    *  0 categories added in the database
    * 0 elements added in the database
    * 0 categories deleted in the database
    * 0 elements deleted in the database
    * 40 elements updated in the database
    * 0 errors during synchronization

Metadata synchronization results

    * 40 elements informations synchronized with files metadata
    * 40 images candidates for metadata synchronization
    * Used metadata : filesize, width, height, high_filesize, date_creation, keywords, date_creation, author, name, comment

But again, some pictures are not synchronized.
(There are 40 pictures total in my galleries)

Offline

 

#4 2009-03-10 21:55:31

ddtddt
Piwigo Team
Quetigny - France
2007-07-27
6707

Re: Metadata synchronization suddenly stopped working

A link to photo ?

List of the metadata whom we should find ?


You love Piwigo so don't hesitate to participate, learn more on the "Contribute to Piwigo" page. If you don't have much time for contribution, you can also help the project with a donation.

Offline

 

#5 2009-03-10 22:03:53

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13148

Re: Metadata synchronization suddenly stopped working

Yes please, a link to a photo for which metadata synchronization doesn't work, and also your $conf['show_iptc_mapping'] setting.

Can you also try to synchronize metadata from the "Modify informations about a picture" administration screen? (you can reach this screen with the "Modify Information" button on gallery side picture.php page.


Latest blog post (May 3rd 2018) New subscription form

Offline

 

#6 2009-03-11 03:50:15

Spooktalker
Member
2009-02-26
7

Re: Metadata synchronization suddenly stopped working

Thanks for the help. :)

I  tried synchronizing a picture individually as you describe. It says the file has been updated, but it doesn't work.

Here's an example of a picture that does not synchronize

http://nullhorizon.com/galleries/pictur … category/9

The pic has the following metadata attached:
Title: Wood Elf Diorama
Author: Spooktalker
Tags: thunderbolt mountain, wood elves, diorama

You can see many others in the same galleries (see http://nullhorizon.com/galleries/index.php?/category/9)--all those that have the filename as the title.

Here is the iptc_mapping info from my config.local.inc.php file:

$conf['show_iptc_mapping'] = array(
  'iptc_keywords'        => '2#025',
  'iptc_caption_writer'  => '2#122',
  'iptc_byline_title'    => '2#085',
  'iptc_caption'         => '2#120'
  );

// use_iptc: Use IPTC data during database synchronization with files
// metadata
$conf['use_iptc'] = true;

// use_iptc_mapping : in which IPTC fields will Piwigo find image
// information ? This setting is used during metadata synchronisation. It
// associates a piwigo_images column name to a IPTC key
$conf['use_iptc_mapping'] = array(
  'keywords'        => '2#025',
  'date_creation'   => '2#055',
  'author'          => '2#122',
  'name'            => '2#005',
  'comment'         => '2#120'
  );

Last edited by Spooktalker (2009-03-11 04:10:11)

Offline

 

#7 2009-03-11 04:02:04

rvelices
Piwigo Team
2005-12-29
1959

Re: Metadata synchronization suddenly stopped working

Spooktalker wrote:

http://nullhorizon.com/galleries/pictur … category/9

The pic has the following metadata attached:
Title: Wood Elf Diorama
Author: Spooktalker
Tags: thunderbolt mountain, wood elves, diorama

Sorry but this information is in XMP only. As of today we don't read XMP data.
The only thing I can suggest now is use exiftool to copy that XMP data to IPTC data...

Offline

 

#8 2009-03-11 04:08:46

Spooktalker
Member
2009-02-26
7

Re: Metadata synchronization suddenly stopped working

Oh, ok, thanks. I wasn't aware of XMP. That's too bad it's not supported. I'm using Microsoft Live Photo Galleries to label the images, but I guess I will have to add another step to my workflow process. But that's great news if this is the answer!

I will try using the exiftool you mention.

. . . But I am even more confused, because some of the pictures synchronized and some did not. And ALL of the pictures were labelled in the same way (Microsoft Live Photo Galleries.  How could this happen?

Take this picture, for instance. Is it any different that the other?
http://nullhorizon.com/galleries/pictur … ategory/20

Last edited by Spooktalker (2009-03-11 04:10:49)

Offline

 

#9 2009-03-11 19:23:45

Spooktalker
Member
2009-02-26
7

Re: Metadata synchronization suddenly stopped working

Piwigo Team: with your help I've solved the problem. Thank you!

As you point out, the problem wasn't with Piwigo but with the software I used to tag the images in the first place.

I have still not been able to identify what went wrong. Some exchange between Picasa and Windows Live Photo Gallery must have caused the xmp metadata on some images but not others to be transferred to iptc. It's maddening how opaque those programs are, and equally maddening that neither has an option for copying the metadata to all appropriate fields in exif, iptc and xmp at once. For those interested I've abandoned use of these programs for tagging purposes, and have begun to use iTag. I tried Exiftool but found the lack of a gui made it unsuitable for my purposes.

I still have no idea how to transfer the original date of the picture to exif or iptc, but that is a question for another forum.

Thanks again.

Offline

 

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2018 · Contact