Announcement

#1 2009-10-29 23:40:13

brdemkr
Member
2009-10-29
8

help with Ploader login

If anyone can point me to an existing post, I'd appreciate it.

Here's my problem.  I have installed Piwigo 2.0.5 on my host site.  I can upload images via FTP and everything seems to be working fine.  However, I can't get PLoader to get past the login page.   this is the error I get.

http://i292.photobucket.com/albums/mm11/brdemkr/Untitled.jpg

My guess is that the url is wrong or I'm not using the right user/password combination.

How to I check if I have the right url?  I can view and access my piwigo gallery by http://brdemkr.com/piwigo

The User/password I'm using has Webmaster permissions and I can login to Piwigo from my site listed above.

Thanks!

Brian

Offline

 

#2 2009-10-30 01:59:20

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13123

Re: help with Ploader login

Hello brdemkr,

Your problem looks a lot like hench's problem on [Forum, topic 15266] pLoader login error (not solution found, no feedback from him)

Even if I can't register on your gallery (you have unchecked the "allow visitors to register" checkbox, I can perform anonymous web API request, and I get the same problem

Code:

$ perl piwigo_remote.pl --base_url=http://brdemkr.com/piwigo --action=pwg.categories.getList
$VAR1 = '{"stat":"fail","err":400,"message":"Unknown request format"}';
$VAR1 = undef;
$VAR1 = bless( {
                 '_protocol' => 'HTTP/1.1',
                 '_content' => '{"stat":"fail","err":400,"message":"Unknown request format"}',
                 '_rc' => '400',
                 '_headers' => bless( {
                                        'connection' => 'close',
                                        'x-powered-by' => 'PHP/5.2.6',
                                        'client-response-num' => 1,
                                        'cache-control' => 'no-store, no-cache, must-revalidate, post-check=0, pre-check=0',
                                        'date' => 'Fri, 30 Oct 2009 00:56:51 GMT',
                                        'client-peer' => '64.8.104.7:80',
                                        'client-date' => 'Fri, 30 Oct 2009 00:56:52 GMT',
                                        'content-type' => 'text/plain; charset=utf-8',
                                        'pragma' => 'no-cache',
                                        'client-transfer-encoding' => [
                                                                        'chunked'
                                                                      ],
                                        'server' => 'NOYB',
                                        'expires' => 'Thu, 19 Nov 1981 08:52:00 GMT'
                                      }, 'HTTP::Headers' ),
                 '_msg' => 'Unknown request format',
                 'handlers' => {
                                 'response_data' => [
                                                      {
                                                        'callback' => sub { "DUMMY" }
                                                      }
                                                    ]
                               },
                 '_request' => bless( {
                                        '_content' => 'method=pwg.categories.getList',
                                        '_uri' => bless( do{\(my $o = 'http://brdemkr.com/piwigo/ws.php?format=json')}, 'URI::http' ),
                                        '_headers' => bless( {
                                                               'cookie2' => '$Version="1"',
                                                               'user-agent' => 'libwww-perl/5.820',
                                                               'content-type' => 'application/x-www-form-urlencoded',
                                                               'cookie' => 'pwg_id=k2ie75uqufs6pkil1b1v9bj2j4',
                                                               'content-length' => 29,
                                                               'authorization' => 'Basic cGxnOnBsZw=='
                                                             }, 'HTTP::Headers' ),
                                        '_method' => 'POST',
                                        '_uri_canonical' => $VAR1->{'_request'}{'_uri'}
                                      }, 'HTTP::Request' )
               }, 'HTTP::Response' );

With hench, I thought the problem may come from the old Apache version 1.3. With you, as you say that the server is "None Of Your Business", I can't know. Don't hesitate to tell me in a private message, it may help to solve the problem.


Latest blog post (November 28th 2017) Server failures in october and november 2017

Offline

 

#3 2009-10-30 13:19:41

brdemkr
Member
2009-10-29
8

Re: help with Ploader login

plg  - I sent you an email via the forum.    Let me know how I can help you solve this problem.

Thanks!
Brian

Offline

 

#4 2009-11-12 22:14:41

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13123

Re: help with Ploader login

brdemkr wrote:

plg  - I sent you an email via the forum.    Let me know how I can help you solve this problem.

Sorry for the late reply, this problem is obviously not an easy one. Let's investigate a bit further.

In your email you're asking me what I need to solve your problem. My answer is that first I must understand what is the origin of the problem. Currently, I don't.

I've made a 1 hour Google search on our problem, and the best way to start is to have a closer look to the error log file of your web server, here is a similar problem: http://www.webmasterworld.com/apache/3562214.htm

I don't need an admin account on your Piwigo installation.


Latest blog post (November 28th 2017) Server failures in october and november 2017

Offline

 

#5 2009-11-18 00:20:09

brdemkr
Member
2009-10-29
8

Re: help with Ploader login

plg -  I don't know how to access the error log file on my shared server (I don't have a dedicated IP)  Is this a command line thing or something I have to request from the provider?

I am running Vista SP2 64bit....could that be problematic?

-Brian

Offline

 

#6 2009-11-18 23:21:23

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13123

Re: help with Ploader login

Hi brdemkr,

brdemkr wrote:

plg -  I don't know how to access the error log file on my shared server (I don't have a dedicated IP)  Is this a command line thing or something I have to request from the provider?

Either you can access your logs in a specific folder on your FTP connection, or you have to ask your provider (or just tell me who your provider is and I'll contact them.

After some additional investigation, your web server is Parallels H-Sphere, exactly as hench in [Forum, topic 15266] pLoader login error. I just can't ignore it! I'll contact them to report a bug.

brdemkr wrote:

I am running Vista SP2 64bit....could that be problematic?

No, hundreds of pLoader users are certainly using this very OS version.


Latest blog post (November 28th 2017) Server failures in october and november 2017

Offline

 

#7 2009-11-19 02:56:38

brdemkr
Member
2009-10-29
8

Re: help with Ploader login

Plg -

Thanks for looking into this and being patient with me.  I really appreciate your efforts.

My hosting company is infinology.net  (or Infinology.com) owned by Trip.net Inc      Houston TX  United States 77056  +1.281-675-736  support@infinology.com

I found my log and tried to log in (2x) to pLoader.  This is what I got:

71.191.246.230 - - [18/Nov/2009:19:36:19 -0600] "GET /piwigo HTTP/1.1" 301 310 "-" "Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.15) Gecko/2009101601 Firefox/3.0.15 (.NET CLR 3.5.30729)"
71.191.246.230 - - [18/Nov/2009:19:36:19 -0600] "GET /piwigo/ HTTP/1.1" 200 5050 "-" "Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.15) Gecko/2009101601 Firefox/3.0.15 (.NET CLR 3.5.30729)"
71.191.246.230 - brdemkr [18/Nov/2009:19:43:44 -0600] "POST /piwigo/ws.php?format=json HTTP/1.1" 400 72 "-" "libwww-perl/5.814"
71.191.246.230 - brdemkr [18/Nov/2009:19:43:44 -0600] "GET /piwigo/ws.php?format=json&method=pwg.categories.getList&recursive=true HTTP/1.1" 200 1098 "-" "libwww-perl/5.814"
71.191.246.230 - brdemkr [18/Nov/2009:19:43:45 -0600] "GET /piwigo/ws.php?format=json&method=pwg.tags.getAdminList HTTP/1.1" 401 63 "-" "libwww-perl/5.814"
71.191.246.230 - brdemkr [18/Nov/2009:19:43:49 -0600] "POST /piwigo/ws.php?format=json HTTP/1.1" 400 72 "-" "libwww-perl/5.814"
71.191.246.230 - brdemkr [18/Nov/2009:19:43:49 -0600] "GET /piwigo/ws.php?format=json&method=pwg.categories.getList&recursive=true HTTP/1.1" 200 1098 "-" "libwww-perl/5.814"
71.191.246.230 - brdemkr [18/Nov/2009:19:43:49 -0600] "GET /piwigo/ws.php?format=json&method=pwg.tags.getAdminList HTTP/1.1" 401 63 "-" "libwww-perl/5.814"
71.191.246.230 - brdemkr [18/Nov/2009:19:46:41 -0600] "POST /piwigo/ws.php?format=json HTTP/1.1" 400 72 "-" "libwww-perl/5.814"
71.191.246.230 - brdemkr [18/Nov/2009:19:46:42 -0600] "GET /piwigo/ws.php?format=json&method=pwg.categories.getList&recursive=true HTTP/1.1" 200 1098 "-" "libwww-perl/5.814"
71.191.246.230 - brdemkr [18/Nov/2009:19:46:42 -0600] "GET /piwigo/ws.php?format=json&method=pwg.tags.getAdminList HTTP/1.1" 401 63 "-" "libwww-perl/5.814"
71.191.246.230 - brdemkr [18/Nov/2009:19:46:46 -0600] "POST /piwigo/ws.php?format=json HTTP/1.1" 400 72 "-" "libwww-perl/5.814"
71.191.246.230 - brdemkr [18/Nov/2009:19:46:47 -0600] "GET /piwigo/ws.php?format=json&method=pwg.categories.getList&recursive=true HTTP/1.1" 200 1098 "-" "libwww-perl/5.814"
71.191.246.230 - brdemkr [18/Nov/2009:19:46:47 -0600] "GET /piwigo/ws.php?format=json&method=pwg.tags.getAdminList HTTP/1.1" 401 63 "-" "libwww-perl/5.814"

Does this help?

-Brian

Offline

 

#8 2009-11-19 23:24:37

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13123

Re: help with Ploader login

brdemkr wrote:

Does this help?

Yes, it does.

I've registered on H-Sphere forums but I can't post a new thread, I'm waiting for some kind of administrator activation.


Latest blog post (November 28th 2017) Server failures in october and november 2017

Offline

 

#9 2009-11-20 06:44:46

rvelices
Piwigo Team
2005-12-29
1956

Re: help with Ploader login

The same problem appears with ws.htm ( http://brdemkr.com/piwigo/tools/ws.htm ) when setting request format to POST

Did you manually change always_populate_raw_post_data in th php.ini  file ? Can you tell us what this value is (piwigo administration click Show Info) ?

Offline

 

#10 2009-11-21 19:41:51

brdemkr
Member
2009-10-29
8

Re: help with Ploader login

rvelices wrote:

The same problem appears with ws.htm ( http://brdemkr.com/piwigo/tools/ws.htm ) when setting request format to POST

Did you manually change always_populate_raw_post_data in th php.ini  file ? Can you tell us what this value is (piwigo administration click Show Info) ?

rvelices -

I don't think I changed the always_populate_raw_post_data, at least I don't remember.    From the Admin Show info, that value is "ON" for both local and master values.

Please let me know if there is anything else I can provide.  I'd love to start using PIWIGO for my website.

Brian

Offline

 

#11 2009-11-23 19:37:05

rvelices
Piwigo Team
2005-12-29
1956

Re: help with Ploader login

OK. I think there is an issue on how we interpret the posted data.
The story of all this: When I started the web service, I wanted to implement xml rpc and json as formats for the requests. This feature has never made it to the web service, however the code that looks for xml or json format in input is there ( http://code.piwigo.org/repositories/ent … s.php#L323 )...

brdemkr, the quickest way to make it work (if I'm not mistaken), is to put always_populate_raw_post_data = false (the default php behaviour) ...

Offline

 

#12 2009-11-23 21:44:18

brdemkr
Member
2009-10-29
8

Re: help with Ploader login

rvelices wrote:

brdemkr, the quickest way to make it work (if I'm not mistaken), is to put always_populate_raw_post_data = false (the default php behaviour) ...

Where do I find this file??? Thx!

Offline

 

#13 2009-11-23 21:55:48

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13123

Re: help with Ploader login

brdemkr wrote:

rvelices wrote:

brdemkr, the quickest way to make it work (if I'm not mistaken), is to put always_populate_raw_post_data = false (the default php behaviour) ...

Where do I find this file??? Thx!

In the php.ini file, but as you don't host the webserver on your own server, I guess you can't modify this file :-/


Latest blog post (November 28th 2017) Server failures in october and november 2017

Offline

 

#14 2009-11-23 22:19:42

brdemkr
Member
2009-10-29
8

Re: help with Ploader login

Thanks for your help plg and rvelices!!   I have a service ticket with my provider now about what's the best way to change my php.ini file.  I might be able to just create a php.ini file in my domain directory to overwrite the default server value for a specific variable...or modify the .htaccess file.

I just searched and found this page http://selectall.wordpress.com/2007/11/ … ed-server/  which agrees with what the tech support person initially told me.

I'll post back when I get an answer and if it works.

Again I appreciate your help!

-Brian

Offline

 

#15 2010-01-06 20:00:46

brdemkr
Member
2009-10-29
8

Re: help with Ploader login

Sorry for the slow reply.  I'd been traveling.

Anyway, I modified my .htaccess file with e following code:  php_value always_populate_raw_post_data False

That solved the problem. 

Thanks for the help!

-Brian

Offline

 

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2018 · Contact