Announcement

#1 2010-05-21 14:37:32

snarfies
Guest

Minor (?) error on admin page after upgrade

Under 2.1.0 I have the following message at the top of every admin page:
-----
Warning:  [mysql error 1048] Column 'language' cannot be null

INSERT INTO piwigo_user_infos
  (nb_image_line,nb_line_page,adviser,language,maxwidth,maxheight,expand,show_nb_comments,show_nb_hits,recent_period,theme,enabled_high,level,user_id,status,registration_date)
  VALUES('4','5','false',NULL,NULL,NULL,'false','true','true','25','dark','true','0','29','normal','2010-05-21 08:33:53') in /home/otakubel/public_html/LDs/include/dblayer/functions_mysql.inc.php on line 642


Warning: Cannot modify header information - headers already sent by (output started at /home/otakubel/public_html/LDs/include/dblayer/functions_mysql.inc.php:641) in /home/otakubel/public_html/LDs/include/page_header.php on line 98
-----

It doesn't seem to be stopping me from doing anything so far.  I have tried deactivating every plugin, but that doesn't change anything.  Should I just manually insert a language into my database, and if so, where?

 

#2 2010-05-23 06:22:30

Leo
Guest

Re: Minor (?) error on admin page after upgrade

I'm getting the same problem. I just installed the new version (Download version), and when I create a user in the admin area it returns this error:

Warning:  [mysql error 1048] Column 'language' cannot be null

INSERT INTO piwigo_user_infos
  (nb_image_line,nb_line_page,adviser,language,maxwidth,maxheight,expand,show_nb_comments,show_nb_hits,recent_period,theme,enabled_high,level,user_id,status,registration_date)
  VALUES('5','3','false',NULL,'800','600','true','true','true','7',NULL,'true','0','3','normal','2010-05-22 23:19:19') in /home/espaco/public_html/meu/include/dblayer/functions_mysql.inc.php on line 642


Warning: Cannot modify header information - headers already sent by (output started at /home/espaco/public_html/meu/include/dblayer/functions_mysql.inc.php:641) in /home/espaco/public_html/meu/include/page_header.php on line 98

The abilities to have users is very important. Would someone be kind to let me know why this is happening?

Again, this is a fresh new instalation of the new version 2.1.0

Thanks.

Leo

 

#3 2010-05-23 08:00:31

Leo
Guest

Re: Minor (?) error on admin page after upgrade

I take that back. Fresh isntall is always best. It works fine now.

 

#4 2010-05-23 09:31:38

Leo
Guest

Re: Minor (?) error on admin page after upgrade

Alright. Here I am again. This time I have something tangile to say... :)

Yes, a fresh instalation was breaking for no reason after playing with the setttings. So after a lot of trouble shooting I found what causes the problem. Here are the steps:

1) Install a new fresh install of Piwigo. Try to create a new regular user. It should work ok.

2)  Edit the GUEST SETTINGS, and change something there. (Or all settings).

3) Now try to create any user in the admin area, and you can this:

Warning:  [mysql error 1048] Column 'language' cannot be null

INSERT INTO piwigo_user_infos
  (nb_image_line,nb_line_page,adviser,language,maxwidth,maxheight,expand,show_nb_comments,show_nb_hits,recent_period,theme,enabled_high,level,user_id,status,registration_date)
  VALUES('5','4','false',NULL,'800','600','true','true','true','7',NULL,'true','0','10','normal','2010-05-23 02:25:42') in /home/espaco/public_html/meu10/include/dblayer/functions_mysql.inc.php on line 642

After this only a new db or a new fresh install altogether. There is something with the Guest Settings that's causing this. I guess for now I will install Piwigo again, and will just stay away from Guest Settings, so it doesn't crash my site.

It would be great if the admin could post a fix for this issue.

Thanks.

Leo

 

#5 2010-05-23 17:34:23

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13100

Re: Minor (?) error on admin page after upgrade

Thanks a lot Leo for your detailed explanation. I've encountered this issue 2 days ago on a Piwigo gallery (that I don't manage) and didn't know what the admin had done.

If you can please open an issue in the bugtracker or else I will create it and fix it anyway :-)


Latest blog post (November 28th 2017) Server failures in october and november 2017

Offline

 

#6 2010-05-23 21:13:17

Leo
Guest

Re: Minor (?) error on admin page after upgrade

Please create it for me if you can;. I'm new to your forum and don't know my way around that well yet.

Yes, I was going crazy also with the issue. I literaly spent the whole night yesterday going step by step and documenting until I got the error. And it was right after I had changed the Guest Settings. Something kept telling me that the issue was started by some setting changed in the admin; because a fresh install was always ok at first.

This issue really ruins the site if someone changes the Guest Settings (would have to be reinstalled from backup.) It's like a time bomb. :)

I'm also curious when you might be able to release a fix for this?

Thanks bro.

Leo Caju

 

#7 2010-05-24 01:26:23

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13100

Re: Minor (?) error on admin page after upgrade

Leo wrote:

Please create it for me if you can;. I'm new to your forum and don't know my way around that well yet.

[Bugtracker, ticket 1683, fixed] modify guest settings breaks registration

Leo wrote:

This issue really ruins the site if someone changes the Guest Settings (would have to be reinstalled from backup.) It's like a time bomb. :)

Yes, and I really don't like that. This is why I've coded and "automatic repair" piece of code for release 2.1.1.

Leo wrote:

I'm also curious when you might be able to release a fix for this?

I had not planned to release 2.1.1 so soon, but we need it. The bug is fixed, we will release 2.1.1 in less than 24h.


Latest blog post (November 28th 2017) Server failures in october and november 2017

Offline

 

#8 2010-05-24 17:55:07

leo
Member
2010-05-24
2

Re: Minor (?) error on admin page after upgrade

How do I patch my existing site instalation with this new fix? Also, I'm, curious to know exactly what files are updated/replaced with this fix/patch (for my records). I keep careful backups, so I want to patch the site knowing what was patched, just in case something else happens. :)

Thanks.

Leo

Offline

 

#9 2010-05-24 17:58:46

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13100

Re: Minor (?) error on admin page after upgrade


Latest blog post (November 28th 2017) Server failures in october and november 2017

Offline

 

#10 2010-05-24 19:32:00

mediapuck
Member
usa till nov - then Austria
2010-04-23
54

Re: Minor (?) error on admin page after upgrade

looked at the subversion - but am not clear exactly either where to replace what to fix this. Is it possible to give precise instructions?
Really appreciate it.
Thanks

Offline

 

#11 2010-05-24 20:23:49

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13100

Re: Minor (?) error on admin page after upgrade

If 2.1.1 is not available tonight, I'll give you specific instructions :-)

There is a workaround to get the registration working:

1) go to admin>configuration>themes and set a theme as default (not the current theme) and if it's not the right theme, then select another. It is important to click at least once on "set default"

2) go to admin>configuration>language and set a language as default (not the current language) and if it's not the right language, then select another. It is important to click at least once on "set default"

Note : this workaround does not fix the problem of the accounts created while default theme/language were null. 2.1.1 will fix it (it is [Bugtracker, ticket 1682, fixed] fails to create Piwigo user infos with external authentication this time)


Latest blog post (November 28th 2017) Server failures in october and november 2017

Offline

 

#12 2010-05-24 20:38:28

leo
Member
2010-05-24
2

Re: Minor (?) error on admin page after upgrade

That worked great! The issue is fixed! Awesome. :)

You guys are the best!

Leo

Last edited by leo (2010-05-24 20:39:11)

Offline

 

#13 2010-05-24 20:48:06

mediapuck
Member
usa till nov - then Austria
2010-04-23
54

Re: Minor (?) error on admin page after upgrade

plg wrote:

If 2.1.1 is not available tonight, I'll give you specific instructions :-)

There is a workaround to get the registration working:

1) go to admin>configuration>themes and set a theme as default (not the current theme) and if it's not the right theme, then select another. It is important to click at least once on "set default"

2) go to admin>configuration>language and set a language as default (not the current language) and if it's not the right language, then select another. It is important to click at least once on "set default"

Note : this workaround does not fix the problem of the accounts created while default theme/language were null. 2.1.1 will fix it (it is [Bugtracker, ticket 1682, fixed] fails to create Piwigo user infos with external authentication this time)

Don't worry about it - I will just wait till 2.1.1 is available.
Thanks :)

Offline

 

#14 2010-05-29 23:15:41

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13100

Re: Minor (?) error on admin page after upgrade


Latest blog post (November 28th 2017) Server failures in october and november 2017

Offline

 

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2018 · Contact