Announcement

#1 2010-08-15 05:53:25

Rourke
Guest

Errors

Will not allow for Admin login. Will not allow for user login until a new passwors is requested. After logging in and changing the password for user Can't  login after loggin out unless the autocheked is clicked.

Also I get this in the emails for the new password request.

Advice please
Warning: strftime(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/Los_Angeles' for 'PDT/-7.0/DST' instead in /virtuals/gamepursuit.com/piwigo/include/smarty/libs/Smarty_Compiler.class.php on line 400

 

#2 2010-08-15 16:38:48

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13129

Re: Errors

Hi Rourke,

Let's fix the "timezone" issue first.

A configuration setting is missing in your php.ini (on my computer, it is located on /etc/php5/apache2/php.ini). Add:

Code:

date.timezone = America/Los_Angeles

and then reload Apache configuration:

Code:

/etc/init.d/apache2 force-reload

If you're not the administrator of the server, ask your hosting provider to fix the problem.


Latest blog post (May 3rd 2018) New subscription form

Offline

 

#3 2012-10-15 12:49:39

Giuliano
Guest

Re: Errors

What if I really cannot change the default php.ini?

I'm using Gandi.net Simple Hosting and there's no way to modify the original php.ini file, so I'm wandering if there's any other usefull solution, except trying to override the php.ini on this particular setting.

 

#4 2012-10-15 19:56:39

flop25
Piwigo Team
2006-07-06
6791

Re: Errors

hi

Code:

<?php
date_default_timezone_set('America/New_York');
?>

in local config should work (use plugin LocalFiles Editor)


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#5 2012-10-16 08:32:04

Asylum
Guest

Re: Errors

My provider has corrected this problem so
added line
date_default_timezone_set('Asia/Novosibirsk'); into file
~/photos/include/functions.inc.php

 

#6 2012-10-16 10:03:06

mistic100
Former Piwigo Team
Lyon (FR)
2008-09-27
3270

Re: Errors

this is not a good idea, the modification will disapear with the next update

as flop25 saif put it in your local configuration (local/config/config.inc.php)

Offline

 

#7 2012-12-04 21:09:40

NWS
Member
Seattle, WA
2011-04-02
175

Re: Errors

I'm having a similar issue. Piwigo 2.3.5. Tried upgrading PHP from 5.2 to 5.4. This is the error I'm getting

Warning: Illegal string offset 'installed' in /homepages/23/d275617611/htdocs/northwestscenescapesnet/gallery/plugins/AMenuManager/amm_root.class.inc.php on line 652

Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /homepages/23/d275617611/htdocs/northwestscenescapesnet/gallery/plugins/AMenuManager/amm_root.class.inc.php:652) in /homepages/23/d275617611/htdocs/northwestscenescapesnet/gallery/include/user.inc.php on line 29

Warning: Cannot modify header information - headers already sent by (output started at /homepages/23/d275617611/htdocs/northwestscenescapesnet/gallery/plugins/AMenuManager/amm_root.class.inc.php:652) in /homepages/23/d275617611/htdocs/northwestscenescapesnet/gallery/include/page_header.php on line 103

Appears to be the Advanced Menu Manager causing the issue. If I disable that plugin I get error messages all over the place. A total catastrophe. I tried changing back to PHP 5.2 but it didn't seem to make the errors stop. Emptied my cache (Firefox) but that didn't seem to help.

BTW, the host is 1&1. Not the first issue I've had with using Piwigo on there.

This seems to be the only issue. If someone could help me fix that I'd really appreciate it.

Offline

 

#8 2012-12-04 21:11:58

flop25
Piwigo Team
2006-07-06
6791

Re: Errors

Hello
seems the plugins of grum induce errors with php 5.4
the only good way is to disable them or switch back to 5.2


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#9 2012-12-04 21:54:59

NWS
Member
Seattle, WA
2011-04-02
175

Re: Errors

Thanks. Seems Advanced Menu manager does too. I disabled Grum's plugin classes and it was still the same errors. Will just stay with PHP 5.2 for now I guess.

Offline

 

#10 2013-02-17 19:56:04

nd925
Member
2013-02-17
4

Re: Errors

mistic100 wrote:

this is not a good idea, the modification will disapear with the next update

as flop25 saif put it in your local configuration (local/config/config.inc.php)

My config file only contains two things index. php and database . inc . php

I am sorry if stupid question. If I find the right file I will edit. I cant access server side, only through a control panel or via Filezilla into the uploaded files

Last edited by nd925 (2013-02-17 19:57:44)

Offline

 

#11 2013-02-17 20:04:49

mistic100
Former Piwigo Team
Lyon (FR)
2008-09-27
3270

Re: Errors

use the plugin LocalFilesEditor to edit the config file

Offline

 

#12 2013-02-18 00:12:25

nd925
Member
2013-02-17
4

Re: Errors

ok, I am following, got to the point where I have plugin open and ready. What exactly do I enter and where?


Uploaded Images

Offline

 

#13 2013-02-18 09:41:02

mistic100
Former Piwigo Team
Lyon (FR)
2008-09-27
3270

Re: Errors

flop25 wrote:

date_default_timezone_set('America/New_York'); // change it with your Timezone

it's same thing, It only have to be between <?php and ?>

Offline

 

#14 2013-12-05 01:11:27

springdew
Member
2012-07-15
7

Re: Errors

NWS wrote:

I'm having a similar issue. Piwigo 2.3.5. Tried upgrading PHP from 5.2 to 5.4. .

Thank you, thank you, thank you. I've been banging my head against this one all afternoon. I'd forgotten that I'd upgraded PHP to 5.4. It seems to like 5.3 okay though.

Offline

 

#15 2014-02-16 21:59:07

Carsten Führmann
Guest

Re: Errors

I had the same problem, but the fix did not work. Until I discovered that, on my Ubuntu Server 13.10, "/etc/init.d/apache2 force-reload" did not work despite giving no error. Instead, I had to use "sudo service apache2 restart".

 

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2018 · Contact