Piwigo.org

You are not logged in. (Register / Login)

Announcement

#1 2010-10-16 13:17:35

Enzobresil
Member
Registered: 2010-10-16
Posts: 4

[resolved] pLoader under ubuntu 10.10

Tags: [linux, pLoader, ubuntu]

Hi !

Since I upgrade to ubuntu 10.10, pLoader 1.5 does not work anymore.
The error message is :

Can't load '/tmp/par-user/cache-0946827dd4e3f1367bfd5c31f6b4f516/f75dcc72.so' for module Image::Magick: libMagickCore.so.2: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou dossier de ce type at /usr/lib/perl/5.8/DynaLoader.pm line 225.
at /usr/local/share/perl/5.8.8/PAR/Heavy.pm line 128
Compilation failed in require at Uploader/ImageList.pm line 25.
BEGIN failed--compilation aborted at Uploader/ImageList.pm line 25.
Compilation failed in require at Uploader/GUI/wxApp.pm line 64.
BEGIN failed--compilation aborted at Uploader/GUI/wxApp.pm line 64.
Compilation failed in require at script/ploader.pl line 26.
BEGIN failed--compilation aborted at script/ploader.pl line 26.
&Image::Magick::constant not defined. The required ImageMagick libraries are not installed or not installed properly.
END failed--call queue aborted.

Of course, I already checked if imagemagick was installed (it was) and I even re-installed it... just to be sure :-) But without any change ! :-(

Any idea ?
Thanks
Enzo

Last edited by Enzobresil (2010-11-05 23:17:04)

Offline

#2 2010-10-17 14:43:40

Enzobresil
Member
Registered: 2010-10-16
Posts: 4

Re: [resolved] pLoader under ubuntu 10.10

Does anybody succeed to launch pLoader with ubuntu 10.10 ?

It could be helpful to know if I'm the only one with this problem, or if it's a bug...

Thanks
Enzo

Offline

#3 2010-10-17 14:52:16

plg
Piwigo Team
Location: Paris, France, Europe
Registered: 2002-04-05
Posts: 12128
Website

Re: [resolved] pLoader under ubuntu 10.10

I haven't upgraded to Ubuntu 10.10 yet :-/ I will in a very short term. Before that, I will try to install it in a virtualbox


Latest blog post on Piwigo.com: Piwigo.com website new design (April 4th, 2014)

Offline

#4 2010-11-02 22:29:02

plg
Piwigo Team
Location: Paris, France, Europe
Registered: 2002-04-05
Posts: 12128
Website

Re: [resolved] pLoader under ubuntu 10.10

OK, I have installed Ubuntu 10.10 on my virtualBox and I reproduce your problem. Here is the solution to run pLoader.

1) install subversion and download pLoader source on your desktop

sudo apt-get install subversion
cd $HOME
mkdir apps
cd apps
svn export http://piwigo.org/svn/extensions/pLoader/tags/1.6 pLoader

2) install pLoader dependencies

sudo apt-get install subversion perl libwx-perl-processstream-perl libfile-slurp-perl libfile-homedir-perl libjson-perl libdigest-md5-file-perl libimage-exiftool-perl perlmagick libcrypt-cbc-perl libcrypt-des-perl libclass-accessor-perl

3) run pLoader

cd $HOME/apps/pLoader/src
perl ploader.pl

Enzobresil, can you confirm it works on your desktop?

Next step is to create a shortcut in the menu. Tell me if you're interested.


Latest blog post on Piwigo.com: Piwigo.com website new design (April 4th, 2014)

Offline

#5 2010-11-02 22:43:42

Enzobresil
Member
Registered: 2010-10-16
Posts: 4

Re: [resolved] pLoader under ubuntu 10.10

Thanks a lot.
I can't test this today, but before the end of the week for sure !
Enzo

Offline

#6 2010-11-03 00:55:45

Enzobresil
Member
Registered: 2010-10-16
Posts: 4

Re: [resolved] pLoader under ubuntu 10.10

Finaly, I found 2 minutes to test it !

And it works ! Just perfect.

To launch it, I just made a script on my desktop :

#sh!
cd /home/user/apps/pLoader/src/
perl ploader.pl

But now I need to click twice to launch pLoader... so if you know a better way... ;-)

Enzo

Offline

#7 2010-11-03 01:15:21

Clément
Member
Registered: 2010-03-02
Posts: 4

Re: [resolved] pLoader under ubuntu 10.10

Hello,

instead of a script, you can add the following line to your .bashrc file :
alias ploader='cd ~/apps/pLoader/src/ && perl ploader.pl'
and run the command in a term.

Next, you can add a launcher to your top panel, with the command ploader.

Or, editing the menu with alacarte and add an new entry (again, command : ploader).

I think it will work that way.

I assume your French, so you can see my topic in the French forum :
http://fr.piwigo.org/forum/viewtopic.php?id=16806

Last edited by Clément (2010-11-03 01:19:56)

Offline

#8 2011-02-08 01:22:44

Adam
Guest

Re: [resolved] pLoader under ubuntu 10.10

Thanks for your help both in getting the program installed and the tip for getting the command to work. Both worked perfectly!

#9 2011-05-07 20:34:43

mahdiar
Guest

Re: [resolved] pLoader under ubuntu 10.10

Hi ! What about ubuntu 11.04 ? I found ploader in ubuntu software center but it didn't work . What should I do now ?

#10 2011-05-07 22:40:37

plg
Piwigo Team
Location: Paris, France, Europe
Registered: 2002-04-05
Posts: 12128
Website

Re: [resolved] pLoader under ubuntu 10.10

mahdiar wrote:

Hi ! What about ubuntu 11.04 ? I found ploader in ubuntu software center but it didn't work . What should I do now ?

Hi mahdiar, can you open a new topic for "pLoader under Ubuntu 11.04" please?


Latest blog post on Piwigo.com: Piwigo.com website new design (April 4th, 2014)

Offline

#11 2011-05-09 19:57:41

mahdiar
Guest

Re: [resolved] pLoader under ubuntu 10.10

I open it ! :)

#12 2011-10-12 16:03:21

photodenbow
Guest

Re: [resolved] pLoader under ubuntu 10.10

I would appreciate a shortcut or a launcher for Ubuntu 10.10 please.

Suggestions?

Board footer

Powered by FluxBB

About this website · Donate · Contact Piwigo project © 2002-2014