Announcement

#1 2011-04-03 21:33:05

rono
Member
2011-04-03
5

problem while updating and adding autoupdate

I was updating to 2.2.0. I thought I was done but when the following occured: ( I login as admin then click Administration)
Any advice or help is appreciated.

HTTP Error 502.2 - Bad Gateway
The specified CGI application misbehaved by not returning a complete set of HTTP headers. The headers it did return are "'\\boswinfs02\home\users\web\b2125\ez.rjsail2\photos\piwigo' CMD.EXE was started with the above path as the current directory. UNC paths are not supported. Defaulting to Windows directory. X-Powered-By: PHP/5.2.11 Expires: Thu, 19 Nov 1981 08:52:00 GMT Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0 Pragma: no-cache Content-Type: text/html; charset=utf-8 <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd"> <html lang="en" dir="ltr"> <head> <meta http-equiv="Content-Type" content="text/html; charset=utf-8"> <meta name="generator" content="Piwigo (aka PWG), see piwigo.org"> <title>Piwigo demonstration site :: Piwigo Administration</title> <link rel="shortcut icon" type="image/x-icon" href="themes/default/icon/favicon.ico"> <link rel="stylesheet" type="text/css" href="admin/themes/default/theme.css"> <!--[if lt IE 7]> <link rel="stylesheet" type="text/css" href="admin/themes/default/fix-ie5-ie6.css"> <![endif]--><link rel="stylesheet" type="text/css" href="admin/themes/roma/theme.css"> <script type="text/javascript" src="themes/default/js/scripts.js"></script> <!--[if lt IE 7]> <script type="text/javascript" src="themes/default/js/pngfix.js"></script> <![endif]--> <script type="text/javascript"> var mess_error = 'Unable to check upgrades...<br><a href="admin.php?action=check_autoupdate">Click here to check upgrades now</a>'; window.onload = function () { jQuery.ajax({ type: 'GET', url: 'plugins/autoupdate/remote.php', dataType: 'text', timeout: 10000, // 10 sec timeout success: function (data) { var reg = new RegExp("(warning|notice)","i"); if (data.match(reg)) { data = mess_error; } jQuery('#autoupdate').html(data); }, error: function() { jQuery('#autoupdate').html(mess_error); } }); } </script> <script type="text/javascript" src="themes/default/js/jquery.packed.js"></script> <script type="text/javascript" src="themes/default/js/plugins/jquery.cluetip.packed.js"></script> <script type="text/javascript" src="themes/default/js/ui/packed/ui.core.packed.js"></script> <script type="text/javascript" src="themes/default/js/ui/packed/ui.accordion.packed.js"></script> <script type="text/javascript" src="themes/default/js/plugins/jquery.tipTip.minified.js"></script> </head> <body id="theAdminPage"> <div id="the_page"> <div id="pwgHead"> <h1> <a href="index.php?" title="Visit the gallery"> <img src="admin/themes/roma/icon/home.png" alt="Home"> Piwigo demonstration site </a> </h1> <div id="headActions"> Hello admin : <a href="index.php?">Visit the gallery</a> | <a href="./admin.php?change_theme=1" title="Switch to clear or dark colors for administration">Change administration colors</a> | <a href="./admin.php?page=help" title="Instructions to use Piwigo">Help Me</a> | <a href="./index.php?act=logout">Logout</a> </div> </div> <div style="clear:both;"></div> <div id="theHeader"></div> <div class="header_notes"> <p id="autoupdate"><img src="plugins/autoupdate/template/ajax-loader.gif"> &nbsp; Checking upgrades for gallery and plugins...</p> 2 anomalies have been detected. </div> <div id="pwgMain"> <script type="text/javascript"> jQuery().ready(function(){ jQuery('#menubar').accordion({ header: "dt.rdion", event: "click", autoHeight: false, active: 0 }); }); </script> <div id="menubar"> <div id="adminHome"><a href="./admin.php">Administration Home</a></div> <dl class="first"> <dt class="rdion"><span>Photos&nbsp;</span></dt> <dd> <ul> <li><a href="./admin.php?page=photos_add">Add</a></li> <li><a href="./admin.php?page=upload">Pending</a></li> <li><a href="./admin.php?page=rating">Rating</a></li> <li><a href="./admin.php?page=tags">Tags</a></li> <li><a href="./admin.php?page=element_set&amp;cat=caddie">Caddie</a></li> <li><a href="./admin.php?page=element_set&amp;cat=recent">Recent pictures</a></li> </ul> </dd> </dl> <dl> <dt class="rdion"><span>Categories&nbsp;</span></dt> <dd> <ul> <li><a href="./admin.php?page=cat_list">Manage</a></li> <li><a href="./admin.php?page=cat_move">M". Detailed Error Information
Module CgiModule
Notification ExecuteRequestHandler
Handler PHP
Error Code 0x00000103
Requested URL http://sailcetacean.com:80/photos/piwigo/admin.php
Physical Path \\boswinfs02\home\users\web\b2125\ez.rjsail2\photos\piwigo\admin.php
Logon Method Anonymous
Logon User Anonymous
Most likely causes:
•The CGI process was shut down or terminated unexpectedly before it finished processing the request.
•The CGI process has a flaw and does not return a complete set of HTTP headers.
Things you can try:
•Check the event logs on the system to see whether the CGI process is shutting down unexpectedly.
•Troubleshoot the CGI application to determine why it is not sending a complete set of HTTP headers.
Links and More InformationThis error occurs when the CGI process handling the request exits before it finishes sending the response to IIS.
View more information »

Offline

 

#2 2011-04-03 21:37:51

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13182

Re: problem while updating and adding autoupdate

I think no test had been performed on Microsoft IIS before :-/ (not a very common webserver nowadays) Are your running it from your own computer or is it on a remote server?


Latest blog post (November 9th 2018) Why Flickr could not remain free for ever

Offline

 

#3 2011-04-04 06:54:24

rono
Member
2011-04-03
5

Re: problem while updating and adding autoupdate

Hi,
This is a remote server easycgi.com is the host company.
Any ideas?
Ron

Offline

 

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2019 · Contact