Announcement

  •  » Engine
  •  » Bug 2297: Stripslashes() missing sometimes to display username

#1 2011-05-04 23:46:06

LucMorizur
Member
Vienne (Isère) - France
2009-04-30
168

Bug 2297: Stripslashes() missing sometimes to display username

[Bugtracker, ticket 2297, fixed] Stripslashes() missing sometimes to display username: when adding user « Test d'apostrophe », the information message says: « User "Test d\'apostrophe" added » (see attached picture).

The same issue occurs for the comment author name (at least, maybe is there some other occurrences of this issue), but there it is more complex and I don't know how to solve it (second attached picture).

From line 232 of admin/user_list.php:

if (count($page['errors']) == 0)
    {
      array_push(
        $page['infos'],
        sprintf(
          l10n('user "%s" added'),
          stripslashes($_POST['login'])
          )
        );
    }

The stripslashes() must be added on line 238.


Uploaded Images

Last edited by LucMorizur (2011-05-04 23:47:30)


Our gallery : Le Site à Nous (a silly name in french, but here I don't care ;-) ! )
An event, a new gallery ? Plugin Event Cats
My test gallery : Tests Piwigo de Luc
Thanksalot for this beautiful project.

Offline

 

#2 2011-05-05 12:31:53

mistic100
Former Piwigo Team
Lyon (FR)
2008-09-27
3271

Re: Bug 2297: Stripslashes() missing sometimes to display username

+1 for the message

but I can't reproduce for the comment author

Offline

 

#3 2011-05-06 00:09:48

LucMorizur
Member
Vienne (Isère) - France
2009-04-30
168

Re: Bug 2297: Stripslashes() missing sometimes to display username

mistic100 wrote:

I can't reproduce for the comment author

?! Strange... I reproduce for all themes, and on my test gallery online: http://lucmorizur.free.fr/piwigo/pictur … 1#comments (the first test was done on the local gallery).

Here is the plugins activated for the local gallery:

Additional Pages
BBCode Bar
Download Multi
Event Cats
Extended Description
Language Switch
LCAS
LocalFiles Editor
Most Commented
Piwigo AutoUpgrade
Plugin Personnel
PWG Stuffs
RV Menu Tree
Smilies Support
UserAdvManager

Well I guess I should deactivate the plugins one by one first.

"Tomorrow"!


Our gallery : Le Site à Nous (a silly name in french, but here I don't care ;-) ! )
An event, a new gallery ? Plugin Event Cats
My test gallery : Tests Piwigo de Luc
Thanksalot for this beautiful project.

Offline

 

#4 2011-05-06 12:24:13

mistic100
Former Piwigo Team
Lyon (FR)
2008-09-27
3271

Re: Bug 2297: Stripslashes() missing sometimes to display username

well I will try on a fresh installation

hs : on dit "le palais DES papes" ^^

Offline

 

#5 2011-05-06 12:34:21

LucMorizur
Member
Vienne (Isère) - France
2009-04-30
168

Re: Bug 2297: Stripslashes() missing sometimes to display username

mistic100 wrote:

well I will try on a fresh installation

:-D ! That's what I was doing while you were writing your post ;-) ! And I reproduce the issue: http://lucmorizur.free.fr/tests/mail/pw … 1#comments

Were you not trying on a "trunk" gallery?

[HS] (Well I didn't find a satsisfying translation for "hors sujet" in english :-/ ... you find "irrelevant", but it is... irrelevant for this precise purpose...)

mistic100 wrote:

on dit "le palais DES papes" ^^

:-D

It was done for! ("C'était fait pour !" ;-) -- it was on purpose !)
[/HS]


Our gallery : Le Site à Nous (a silly name in french, but here I don't care ;-) ! )
An event, a new gallery ? Plugin Event Cats
My test gallery : Tests Piwigo de Luc
Thanksalot for this beautiful project.

Offline

 

#6 2011-05-06 12:38:59

LucMorizur
Member
Vienne (Isère) - France
2009-04-30
168

Re: Bug 2297: Stripslashes() missing sometimes to display username

As a matter of fact, the issue is also present on the comment notification:

Auteur : Test d\'apostrophe
Commentaire : Commentaire par « Test d'apostrophe »

Gérer ce commentaire : http://lucmorizur.free.fr/tests/mail/pw … mment_id=1

Utilisateur connecté : Test d'apostrophe
IP : 90.94.236.243
Navigateur : Mozilla/5.0 (Windows NT 5.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

-- Envoyé par "Test courriels 2.2" http://lucmorizur.free.fr/tests/mail/pwg220 Contacter lucmorizur@<FAI>.fr Propulsé par Piwigo


Our gallery : Le Site à Nous (a silly name in french, but here I don't care ;-) ! )
An event, a new gallery ? Plugin Event Cats
My test gallery : Tests Piwigo de Luc
Thanksalot for this beautiful project.

Offline

 

#7 2011-05-06 12:40:30

mistic100
Former Piwigo Team
Lyon (FR)
2008-09-27
3271

Re: Bug 2297: Stripslashes() missing sometimes to display username

wait ! what version do you use ?

because I didn't reproduce the bug on the notification page anymore XD

edit : 2.2, my test gallery is "trunk"

Last edited by mistic100 (2011-05-06 12:41:30)

Offline

 

#8 2011-05-06 12:54:39

LucMorizur
Member
Vienne (Isère) - France
2009-04-30
168

Re: Bug 2297: Stripslashes() missing sometimes to display username

mistic100 wrote:

wait ! what version do you use ?

The test I did just today, was done on a 2.2.0 version. I upgraded it to 2.2.1, and the three issues were present: at username creation, in the comment (still http://lucmorizur.free.fr/tests/mail/pw … 1#comments ), and in the notification:

Subject: |Test courriels 2.2| Commentaire par Test d\'apostrophe 2 wrote:

Auteur : Test d\'apostrophe 2
Commentaire : Commentaire par « Test d'apostrophe 2 »

Gérer ce commentaire : http://lucmorizur.free.fr/tests/mail/pw … mment_id=2

Utilisateur connecté : Test d'apostrophe 2
IP : 90.94.236.243
Navigateur : Mozilla/5.0 (Windows NT 5.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

-- Envoyé par "Test courriels 2.2" http://lucmorizur.free.fr/tests/mail/pwg220 Contacter lucmorizur@<FAI>.fr Propulsé par Piwigo 2.2.1

But of course this 2.2.1 version is a released version.

Last edited by LucMorizur (2011-05-06 12:55:59)


Our gallery : Le Site à Nous (a silly name in french, but here I don't care ;-) ! )
An event, a new gallery ? Plugin Event Cats
My test gallery : Tests Piwigo de Luc
Thanksalot for this beautiful project.

Offline

 

#9 2011-05-06 12:57:20

LucMorizur
Member
Vienne (Isère) - France
2009-04-30
168

Re: Bug 2297: Stripslashes() missing sometimes to display username

mistic100 wrote:

because I didn't reproduce the bug on the notification page anymore XD

edit : 2.2, my test gallery is "trunk"

This means that a correction has been made? Maybe the bug had already been identified?


Our gallery : Le Site à Nous (a silly name in french, but here I don't care ;-) ! )
An event, a new gallery ? Plugin Event Cats
My test gallery : Tests Piwigo de Luc
Thanksalot for this beautiful project.

Offline

 

#10 2011-05-06 12:58:56

mistic100
Former Piwigo Team
Lyon (FR)
2008-09-27
3271

Re: Bug 2297: Stripslashes() missing sometimes to display username

just tested from branch 2.2, no bug, so it's corrected ;)
(don't know how and where ^^)

Offline

 

#11 2011-05-06 13:03:22

LucMorizur
Member
Vienne (Isère) - France
2009-04-30
168

Re: Bug 2297: Stripslashes() missing sometimes to display username

mistic100 wrote:

just tested from branch 2.2, no bug, so it's corrected ;)
(don't know how and where ^^)

?!?!

Here it's unchanged: http://piwigo.org/dev/browser/trunk/adm … t.php#L232 (Or http://piwigo.org/dev/browser/branches/ … t.php#L232 in the branch 2.2). This block is for the admin page information message after the user creation. Now it may be corrected on some other place.

As for the other occurrences of the issue (comments, notification), I cannot find a place where it should be corrected. But maybe just one correction can be efficient for all occurrences of this issue.

Last edited by LucMorizur (2011-05-06 13:08:45)


Our gallery : Le Site à Nous (a silly name in french, but here I don't care ;-) ! )
An event, a new gallery ? Plugin Event Cats
My test gallery : Tests Piwigo de Luc
Thanksalot for this beautiful project.

Offline

 
  •  » Engine
  •  » Bug 2297: Stripslashes() missing sometimes to display username

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2019 · Contact