Announcement

#1 2012-06-27 10:09:50

skpManiac
Member
England
2012-02-15
140

[resolved] Error with Icon Set & Music Player compatability on 2.4

I have installed Music Player and find it to be great for what I want, the only problem is that if I use a CUSTOM ICON SET, I get the following error:

Warning: filemtime() [function.filemtime]: stat failed for ../../../../plugins/Icons_Set/icons/grum-dark-II/icon.css in /home/linweb04/f/freezinglifethroughthelens.co.uk/user/htdocs/include/template.class.php on line 1307

Any help appreciated :)

Flop seems to think its a bug with Icon Set & not Music PLayer?


Share & Enjoy

Offline

 

#2 2012-06-27 16:40:39

flop25
Piwigo Team
2006-07-06
6918

Re: [resolved] Error with Icon Set & Music Player compatability on 2.4

and if you change the set used, what happens ?


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#3 2012-06-27 22:12:25

skpManiac
Member
England
2012-02-15
140

Re: [resolved] Error with Icon Set & Music Player compatability on 2.4

good question :)

I have tried several sets, they all give errors

Warning: filemtime() [function.filemtime]: stat failed for ../../../../plugins/Icons_Set/icons/tango_bleu/icon.css in /home/linweb04/f/freezinglifethroughthelens.co.uk/user/htdocs/include/template.class.php on line 1307

Warning: file_get_contents(../../../../plugins/Icons_Set/icons/tango_bleu/icon.css) [function.file-get-contents]: failed to open stream: No such file or directory in /home/linweb04/f/freezinglifethroughthelens.co.uk/user/htdocs/include/template.class.php on line 1376


Share & Enjoy

Offline

 

#4 2012-06-27 22:15:15

flop25
Piwigo Team
2006-07-06
6918

Re: [resolved] Error with Icon Set & Music Player compatability on 2.4

does these files exist really on your server ?


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#5 2012-06-27 23:24:28

skpManiac
Member
England
2012-02-15
140

Re: [resolved] Error with Icon Set & Music Player compatability on 2.4

Yeah, they work fine across the top of the site, its just when Music Player is opened that the error occurs


Share & Enjoy

Offline

 

#6 2012-06-28 13:09:51

flop25
Piwigo Team
2006-07-06
6918

Re: [resolved] Error with Icon Set & Music Player compatability on 2.4

oki doki
I will see that problem


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#7 2012-06-28 13:57:25

flop25
Piwigo Team
2006-07-06
6918

Re: [resolved] Error with Icon Set & Music Player compatability on 2.4

Sry but I've tried my best to reproduce and I don't ! I've tried to combine css, to not combine css...
Could you try a purge of the template created via tool->'Maintenance' ? and to set $conf['template_combine_files'] = false; ?


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#8 2012-06-30 20:23:56

skpManiac
Member
England
2012-02-15
140

Re: [resolved] Error with Icon Set & Music Player compatability on 2.4

Hi Flop, yeah I will do that tomorrow as I have been on the road since 9am :s

Thanks for the help


Share & Enjoy

Offline

 

#9 2012-07-05 13:20:15

skpManiac
Member
England
2012-02-15
140

Re: [resolved] Error with Icon Set & Music Player compatability on 2.4

flop25 wrote:

set $conf['template_combine_files'] = false; ?

Where do I do this Flop?

Thanks m8


Share & Enjoy

Offline

 

#10 2012-07-05 13:47:18

pewe
Member
2012-03-16
439

Re: [resolved] Error with Icon Set & Music Player compatability on 2.4

You add this line to the config file by putting it in the Localfiles Editor.

In the Admin panel, go to 'Plugins' and make sure that the Localfiles Editor is activated.
Click on it in the list of plugins and add the line in the first tab 'Local Config', between the <?php and ?> and save the file.

Offline

 

#11 2012-07-05 14:34:01

skpManiac
Member
England
2012-02-15
140

Re: [resolved] Error with Icon Set & Music Player compatability on 2.4

ok, thats where I tried, but I get a syntax error:

Do I have to remove the previous
$conf[enable_i_log'] = true;
before adding anything else?


This is how it currently looks

Code:

<?php
$conf[enable_i_log'] = true;


?>

I was told to add this last week after the 2.4 update

This is how I have tried it

Code:

<?php
$conf[enable_i_log'] = true;
$conf['template_combine_files'] = false;

?>

but it wont save :s

Sorry about this, but I know a few cosing basics in PHP but thats all

(Just tried without the ' before template too, as thats not there on the one above, but still no joy)

Last edited by skpManiac (2012-07-05 14:45:03)


Share & Enjoy

Offline

 

#12 2012-07-05 14:39:06

flop25
Piwigo Team
2006-07-06
6918

Re: [resolved] Error with Icon Set & Music Player compatability on 2.4

try the forum balise [code\][/code\] without the \

conf[enabl => conf['enabl


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#13 2012-07-05 14:46:16

skpManiac
Member
England
2012-02-15
140

Re: [resolved] Error with Icon Set & Music Player compatability on 2.4

flop25 wrote:

try the forum balise [code\][/code\] without the \

conf[enabl => conf['enabl

I tried that too :p

Code:

<?php
$conf[enable_i_log'] = true;
$conf[template_combine_files'] = false;
?>

Share & Enjoy

Offline

 

#14 2012-07-05 14:59:33

flop25
Piwigo Team
2006-07-06
6918

Re: [resolved] Error with Icon Set & Music Player compatability on 2.4

nono both !
$var['foo']


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#15 2012-07-05 15:16:32

skpManiac
Member
England
2012-02-15
140

Re: [resolved] Error with Icon Set & Music Player compatability on 2.4

flop25 wrote:

nono both !
$var['foo']

Not sure what that Variable is lol :p

Anyways, I did it with just the code you said above and now it is working perfectly :)

THANKYOU VERY MUCH Flop :-)

You can see it working:
http://www.freezinglifethroughthelens.c … category/3

Last edited by skpManiac (2012-07-05 15:17:34)


Share & Enjoy

Offline

 

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2019 · Contact