Announcement

#1 2012-07-31 17:35:43

ezeben
Member
2012-07-31
5

Piwigo 2.4.3 not creating thumbnails of large photos of more than 20mb

Piwigo 2.4.3 I am having trouble and I do not know if it is piwigo or apache server.
I have try xampp server,wamp server and wampdeveloper pro.

THe ploblem is that when I upload a photo  of 20-30mb it does not create the thumbnail and midium web preview size, the photos are in the gallery but I cannot preview the thumbnails, I have been able to upload the photos of up to 15m. but the larger sizes photos are giving me that problem.

(ATT: Is not php.ini limit because the maximum to upload is 64mb and the maximum to post is 70mb)






gallery  :  http://99.3.184.151/piwigo/

Offline

 

#2 2012-07-31 18:10:34

mol
Piwigo Team Germany
germany
2010-05-26
108

Re: Piwigo 2.4.3 not creating thumbnails of large photos of more than 20mb

ezeben wrote:

THe ploblem is that when I upload a photo  of 20-30mb it does not create the thumbnail and midium web preview size, the photos are in the gallery but I cannot preview the thumbnails, I have been able to upload the photos of up to 15m. but the larger sizes photos are giving me that problem.

have a look at this thread : http://piwigo.org/forum/viewtopic.php?id=20044

what is the  memory_limit in the php.ini of your xamp/lamp.

the dimensions of your pictures (the file size of jpg compressed pictures is not relevant for the gdi lib) are 9000*5989 = 53 Megapixel and 13525x9000 =122 Megapixel.
The imagecreatefromjpeg() function in the GDI Lib needs about 250 Megabyte Server RAM for the "small" Picture and about 600 Megabyte RAM for the second picture.

Offline

 

#3 2012-07-31 18:36:47

rvelices
Piwigo Team
2005-12-29
1960

Re: Piwigo 2.4.3 not creating thumbnails of large photos of more than 20mb

Fatal error: Allowed memory size of 402653184 bytes exhausted (tried to allocate 54100 bytes) in C:\WampDeveloper\Websites\DefaultWebsite\webroot\piwigo\admin\include\image.class.php on line 674

Offline

 

#4 2012-08-01 04:58:44

ezeben
Member
2012-07-31
5

Re: Piwigo 2.4.3 not creating thumbnails of large photos of more than 20mb

Thank you the problem was the memory limit. I fixed it by editing it  in the  php.ini.

Offline

 

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2019 · Contact